Sign-in / Sign-up
Your question

Please help with strange RAID 0 issue

Tags:
  • Hard Drives
  • NAS / RAID
  • Windows XP
  • Storage
Last response: in Storage
January 14, 2010 10:22:26 AM

Folks, I would really appreciate your help. I have an XP setup with a RAID 0 array. It's worked beautifully throughout 09, never a problem. Last night, the PC starts being a little weird. The mouse works, but otherwise it "hangs". Running the DVD in and out will wake it up.

I decide to run a Macrium image. When I get up this morning the RAID controller has popped up a message saying the data on the two drives may be inconsistent, and do I want to fix? Sure....

Lightening flash, power burps. I turn the PC back on and during the BIOS screen, the RAID array is greyed out and says "conflict". Boot continues until right before the splash screen, at which point it says "Missing NTLDR".

NOW....I can boot from EITHER disk. It says, of course, RAID Degraded. But either disk working independently works fine: I'm posting from one now.

So, is this a "thing" that happens? Is it a sign that either a drive, or my MOBO based controller is going out? How do I fix?

More about : strange raid issue

January 14, 2010 11:18:49 AM

It may just be a "*** happens".

I think you mean RAID1. As pointed out later by sturm, you can't run RAID0 with a missing disk. RAID1 you can.

With 1 drive running, first, BACKUP ALL DATA in case next steps go wrong.

Now, in the RAID BIOS, you should be able to break the RAID reverting the disk you have connected back to a single disk. Now, re-hook up the other drive and in the RAID BIOS, tell it to use the "new" drive as a RAID1 partner to the existing drive and it should automatically wipe it and resetup the RAID1 set using the data on the drive you left connected all along.

(edit cause I mixed up RAID levels)
a b G Storage
January 14, 2010 11:21:03 AM

You say your running off one of the raid drives right now. Did you reinstall windows on it?
You can't run off just one drive in a raid 0 setup.
If you did install windows on one of the drives there is no fix. You will have to rebuild the array from scratch.
As for the original problem its hard to say what it is.
Related resources
Can't find your answer ? Ask !
January 14, 2010 12:33:29 PM

Gents, thanks so much for your replies. You are correct, I mispoke: it is a RAID 0 system. Please see the rest below, things took a horrible turn for the ugly after my last post. I'm pretty frazzled, and now I'm at the office (stewing). Let me recreate step by step.

1. I posted here.(the original post). Now, I was running on one of the two RAID drives when I posted. Let's call that "Red". Let's call the other drive "Blue". Note that I had previously verified that both Red and Blue worked independently of each other: both mirrors were good.
2. I wanted to shut down the machine to test the Macrium Rescue disk's ability to boot from the DVD drive.
3. I went through the windows shutdown, but during the shutdown screen I get this message "Installing update 1 of 4" then "do not turn off or restart PC. PC will shut down automatically". Note this is on the RED drive, and I had previously verified that both Red and Blue would boot independently and flawlessly. So even if this "update" assininity had messed something up, it could only have done so on "Red".
4. I remove the RED drive, so now there are no boot harddrives in the system (I have those removable trays).
5. I reboot. It will not reboot from the DVD. It says "press any key to boot from CD". But it appears the keyboard is dead (no caps lock light). THis is a USB keyboard. Note that the keyboard works long enough to get into the BIOS menu, but after that F8, CTRL-G (the pre-boot RAID set up utility) won't work---but then neither will the caps lock/num-lock lights.
6. It sits at the "press any key to boot from CD" message for a moment, then "NTLDR is missing".
7. Here is where everything goes horribly wrong. I figure, "okay, I'll just go back in and figure that out". No. Now I put the RED drive back in, and I get "NTLDR is Missing". Let me unpack that to be totally clear.
7a. Earlier this morning, I took Blue out. Boot starts, the drive recognition portion of the BIOS recognizes the DVD drive, then the RAID saying something like "RAID is degraded, suggest rebuilding the array to avoid data loss". (go back in time 1 year) Now, when I first built this system, one drive crapped out after an hour. I got this message on reboot. I shut it down, put in a new drive, rebooted, Windows came up and the Gigabyte utility integrated the new drive no problem. SO this message simply tells me a drive is either missing or bad. (back to the present). Then it boots up, windows starts, and I post here: the original post.
7b. Then the shutdown, with the "installing update 1 of 4, do not shut down" screen.
7c. Then the attempt to boot from CD where I can't "press any key" or at least it appears the USB keyboard isn't seen.
7d. I take out the Macrium rescue DVD. Red is in, blue is out. Reboot.
7c. it goes through the device id section When it gets to "Verifying DMI data pool" it pauses for a while, and then "NTLDR is missing".
7d. I crap my pants.
7e. Red goes out, blue goes in. Same thing as 7c: "NTLDR is missing".

So summing up, when I originally posted I suspected I might be having a drive issue the RAID array would let me work through. Now, I cannot access any drives. NTLDR is missing....

Oh, one last thing, I tried to boot from the Windows XP installation CD, and it says, "press any key to boot from CD" but pressing any key doesn't works.
January 14, 2010 1:15:07 PM

(again, did you mean RAID1?)

1. OK, that's good. Again, Mirror is RAID1.
3. You selected "Install Updates and Shutdown", not just "Shutdown".
5. And in response to your statement in #4, what else is in the system? A Windows boot disk, when you boot from it, will only display that message if it detects what appears to be a bootable OS somewherein the system.
7b. You selected "Install Updates and Shutdown", not just "Shutdown".

System may be borked. Hopefully you can at least (if you haven't already) backup your drives data. Do you have another system you could put one of the drives in as a secondary drive to pull the data? Or if you can manage to boot from a Windows Vista or 7 DVD, you can drop to a prompt where you will have access to the local drive as well as a USB connected drive to copy data.

Or, if all else fails, do a fresh install on one of the drives, then put the other drive in as secondary to copy data over, then re-establish the RAID1 mirror.
January 15, 2010 1:06:46 AM

Alrighty, here's the deal. I have two other not-previously-mentioned-drives on the systems. Both are redundant data back ups. My wife told me to never never EVER lose all the family pictures again. :o 

When I pulled out both Red and Blue the bios went to looking for the OS on THOSE. That's why I was getting the NTLDR is Missing error. The reason I couldn't boot from the CD was that when I first setup this PC I was using a PS-2 keyboard. After that crapped out, I replaced it with a USB keyboard but neglected to enable the BIOS to recognize a USB keyboard.

I pulled ALL the drives, then put RED back in. Booted fine, worked fine. Took Red out, put Blue in. Booted and ran fine. Put RED and BLUE in: CONFLICT during the drive recognition screen. Hop out to the store for a new drive. Put in RED, put in the new drive, and it's rebuilding now---on the PC I'm using this moment.

Now, why in the hell BOTH drives work independently, worked together yesterday, but won't work together today, I don't understand. But, it's working. I'm happy.

THanks!
January 15, 2010 2:51:06 AM

Ahh. SO there was something on the data drives the CD/DVD was recognizing as possibly bootable and that's why it was giving you the question.

Why the system was non-bootable with both drives in, I haven't seen before. Most RAID hardware I've worked with, when the RAID BIOS detacted a mis-match between the 2 mirror partners it would give a choice of which to boot from and which to mark "broken". From there you could simply boot from 1, then reset the other and re-mirror.