Sign in with
Sign up | Sign in
Your question
Solved

AHCI option(sata)

Last response: in Storage
Share
January 18, 2010 4:38:28 PM

I have a single SATA hard disk, so i enabled the AHCI option in bios, but i get BSOD when windows is booting,so i had to set it back to SATA IDE
why is it not working?

More about : ahci option sata

January 18, 2010 7:27:20 PM

Hi Damian,

I found something that sounds similar to what you are getting on the Xtreme Systems forums.

It appears to say that a driver is needed before Windows is installed on a boot volume you want to enable AHCI on, but I am not technical at all, so I may have it all wrong!

Thanks again for your help with my partition and missing volumes issue, you've been the only one who helped out so far! I did shorten my post, it was way too long!

-Ck
m
0
l
January 18, 2010 8:53:21 PM

Thanks for the article.i have read it, i think they are talking about XP.
I wonder if on windows 7 it would be different.
I think there is not point in creating a RAID setup for future as they said,i only have 1 drive and it will get bsod again.maybe i should leave this.but i will listen to more info if someone finds something.

Good luck with your missing volume.

m
0
l
Related resources

Best solution

a c 415 G Storage
January 18, 2010 9:22:56 PM

You did this on a system that already had Windows installed, right? The problem is that the disk drivers in your installed system are expecting to see an ATAPI connection to the disk. When you boot the system with the drives in SATA mode the drivers don't understand how to talk to the disk and so the system can't do anything.

I haven't tried this myself, but I understand that the following should work:

1) Set the BIOS to use IDE mode for the disks and boot the system.

2) Run RegEdit and set the following registry value so that it's value is zero:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\msahci\Start

3) Shut down, set the BIOS to use AHCI mode, and restart.

The system should start, detect the change, install new drivers, and automatically reboot once more .
Share
January 18, 2010 11:08:02 PM

That sounds a whole lot easier than reinstalling Windows! :) 

I wonder if it would work on XP as well?
m
0
l
January 18, 2010 11:12:08 PM

If it doesnt find achi drivers for xp, then you can use the motherboard disc or download them.

m
0
l
a c 415 G Storage
January 19, 2010 3:22:51 AM

c_k said:
I wonder if it would work on XP as well?
I know it's supposed to work for Vista and Windows 7, but I suspect it might not work on XP because the AHCI drivers are not part of the base XP kit - they have to be added manually via a driver disk when the system is installed.
m
0
l
January 19, 2010 4:38:13 PM

It shouldnt matter with XP, like I said, if it doesnt automatically find the driver, use your motherboard cd or download them. With any driver installation on XP, you get the "browse" option to install from a folder/location it didnt automatically find.
m
0
l
a c 415 G Storage
January 19, 2010 4:55:29 PM

To clarify - I'm not disagreeing with Boxa, just stating that I suspect the method I described won't work with XP.
m
0
l
January 19, 2010 9:39:29 PM

sminlal said:
You did this on a system that already had Windows installed, right? The problem is that the disk drivers in your installed system are expecting to see an ATAPI connection to the disk. When you boot the system with the drives in SATA mode the drivers don't understand how to talk to the disk and so the system can't do anything.

I haven't tried this myself, but I understand that the following should work:

1) Set the BIOS to use IDE mode for the disks and boot the system.

2) Run RegEdit and set the following registry value so that it's value is zero:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\msahci\Start

3) Shut down, set the BIOS to use AHCI mode, and restart.

The system should start, detect the change, install new drivers, and automatically reboot once more .

Understand.Yes,i already have my windows on it,music pics and stuff.
just now,i have it set on sata mode.i think they work as IDE
i don't like to touch the regedit,but if this is sure i will give it a shot,ok?
then as you said,shut down the pc,then turn it baack on and set ahci on and save+restart option.
I hope i'm not killing my windows boot with this.lol.Thanks will let you know.


m
0
l
January 19, 2010 10:55:22 PM

I followed the method that sminlal described and it worked fine.
The only problem I had/have is that my external harddrive didn't have it's port configured properly, but that's irrelevant.
m
0
l
January 20, 2010 10:52:19 PM

HI, i just done that,booted ok in AHCI mode,(thanks, very good trick)rebooted then windows installed AHCI drivers for it.(cool)The thing was, when i logged in,it froze for a while.after that,was trying to hibernate/sleep/hybrid sleep, lost the boot,get the typical 'restart and select booting device' message,so i switched off.after a few hours i turned back on and just booted ok.what the...?
m
0
l
January 20, 2010 10:52:43 PM

Best answer selected by damian86.
m
0
l
January 20, 2010 10:56:57 PM

sminlal said:
You did this on a system that already had Windows installed, right? The problem is that the disk drivers in your installed system are expecting to see an ATAPI connection to the disk. When you boot the system with the drives in SATA mode the drivers don't understand how to talk to the disk and so the system can't do anything.

I haven't tried this myself, but I understand that the following should work:

1) Set the BIOS to use IDE mode for the disks and boot the system.

2) Run RegEdit and set the following registry value so that it's value is zero:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\msahci\Start

3) Shut down, set the BIOS to use AHCI mode, and restart.

The system should start, detect the change, install new drivers, and automatically reboot once more .



I wish it was as easy as this.

I'm in a situation where I get a BSOD after enabling AHCI at the BIOS after installing all the latest F6 Floppy drivers during Windows XP HE + SP3.

What you're assuming is that everyone has "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\msahci\Start" @ the Registry. I looked. It's not there for me nor, I'd assume, a lot of other peoples' builds.
m
0
l
a c 415 G Storage
January 20, 2010 11:34:18 PM

mzadotcom said:
What you're assuming is that everyone has "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\msahci\Start" @ the Registry. I looked. It's not there for me nor, I'd assume, a lot of other peoples' builds.

First question - are you running Vista or Windows 7? If not, then I doubt this would work (as I mentioned earlier).

Secondly: if you don't have that value in the registry, have you tried creating it? Navigate to the "msahci" key in the registry, right-click in the right pane, and select "New -> DWORD (32-bit) Value", and change the value's name to "Start". Leave the value as a zero.
m
0
l
January 21, 2010 8:44:20 AM

As it states in my post, I'm using Windows XP HE + SP3 on this build. I know, I know. I do have Windows 7 on a netbook, of all things. Maybe I'll upgrade my main rig to 7 64-bit soon. :D 

Missed the part that your method was for Vista &/or 7. :??: 

I blame it on my bleeding eyes :ouch: ; a direct result of all the research I've done online regarding AHCI.

Thanks for the advice. Cheers.

m
0
l
July 3, 2010 8:59:15 PM

i have not found HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci in registry...

what will i do?
m
0
l
Anonymous
a b G Storage
August 23, 2010 3:52:16 AM

sminlal said:
You did this on a system that already had Windows installed, right? The problem is that the disk drivers in your installed system are expecting to see an ATAPI connection to the disk. When you boot the system with the drives in SATA mode the drivers don't understand how to talk to the disk and so the system can't do anything.

I haven't tried this myself, but I understand that the following should work:

1) Set the BIOS to use IDE mode for the disks and boot the system.

2) Run RegEdit and set the following registry value so that it's value is zero:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\msahci\Start

3) Shut down, set the BIOS to use AHCI mode, and restart.

The system should start, detect the change, install new drivers, and automatically reboot once more .



Will this work in going from RAID to AHCI? Value Data is now 3 for both Msahci and IastorV.
m
0
l
July 3, 2012 6:21:14 PM

sminlal said:


2) Run RegEdit and set the following registry value so that it's value is zero:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\msahci\Start

There's no such key in Win XP SP3 systems, and just creating it is not enough as in Win7 system there are a lot of other keys together with it!
So,which is the solution for XP?

m
0
l
!