Sign in with
Sign up | Sign in
Your question

Problem with speeds of WD drive: WD10EADS

Last response: in Storage
Share
January 19, 2010 2:39:26 PM

I bought a Western Digital Elements 1TB external hard drive. When I plug it in, Windows detects it as a "WD10EADS" but as far as I can find, all retailers and even the WD site say this is an internal hard drive. Complete model number: WD10EADS-00M2B0.

The access speeds are horrid. A file of 700mb takes about 10 minutes. Usually Windows copies about 600mb of it straight away, after that the speed just drops and drops and drops while the HD access light is flickering.

I run Windows 7 64-bit. My laptop runs Windows XP 32-bit, and has the same problems with it. I tried formatting the drive to both FAT32 and NTFS, same problem.

I have five other external WD hd's: two 120gb passports, two 500gb elements (older model, silver) and one 1TB passport. None have this problem.

Because the above mentioned harddrive is an external drive (USB) but every bit of information I can find says it should be an internal drive, I fear that something has gone wrong with perhaps configuration/firmware of the drive or putting the wrong drive in the external case. Maybe it wants to act as an internal SATA drive, but it is connected through USB.

Thanks for any and all information.
a b G Storage
January 20, 2010 1:41:15 AM

It might not be your external hard drive. On my MSI Wind for example, copying speeds are horrible, because I'm try to copy from my external drive (7200 rpm) to my netbook's internal 5400rpm hard drive. In other words, there might be a bottleneck somewhere in your system.
January 20, 2010 2:28:56 PM

I've tried all six of my external HDD's and none have this problem. If the speeds were a steady but slow, there would be another problem. For the first 80% of a 1gb file the speeds are normal, pretty quick, but on this particular new one it stops there and the speed drops to lets say, 0,1% of what it was before. It almost feels like the computer wants to send a lot of data to the HDD and it has trouble keeping up, and when the cache or whatever of the external HDD floods it just goes flat and barely does anything, that's why I'm afraid it has something to do with the HDD itself.

Anyone have any idea? Especially about the part where it shows up with the ID/product number of an internal HDD, while it clearly is an external hdd.

Thanks.
Related resources
January 20, 2010 2:31:19 PM

Won't let me edit previous post.

Ps, I run an Athlon X2 3.1ghz on a Asrock ESATA-dual2 or something motherboard. I know it's not the best, or most expensive, of motherboards but my other external HDD's don't have this problem.
a c 342 G Storage
January 20, 2010 2:58:29 PM

Regarding the model number, maybe all it means is that WD mounted that HDD unit (often sold by itself as an internal drive) in its Elements external desktop product. No problem there.

The file transfer performance story sounds rather like the unit has encountered errors in the large file near its end. Now, that could be an actual problem with the hard drive unit itself, or possibly with the controller inside the Elements system. If it is a hard drive hardware problem, you should be able to detect that by downloading and using the WD Data Lifegard diagnostic utility package. Another step might be to remove that HDD unit from the enclosure and mount it temporarily as an internal drive to check its performance there. However, I strongly suspect this step would void your warranty. So, get / use the diagnostic tools, then consult WD's Tech support people, prepared with notes to tell them everything their Data Lifegard tools told you about the external drive. Only after that should you consider (with their blessing?) temporarily moving it to an internal drive testing setup.
Anonymous
a b G Storage
February 19, 2010 1:19:58 PM

Hi Smoefer I have same WD external HDD and does same thing, I have tried on windows 7 and XP same result starts off good then slows down to about 3kbs, did you find a solution for this problem.
a b G Storage
February 19, 2010 4:40:59 PM

That transfer performance sounds like Windows caching most of the file, then waiting until the cache is mostly flushed to continue. In other words, it sounds pretty normal. I see that behavior all of the time on my external and on my flash drive. The transfer rate does sound slow though - a single 700MB file should not take 10 minutes.
April 18, 2010 5:24:24 PM

I have the same WD Hard Drive, WD10EADS, used as internal HD with 64bit Windows 7 Pro installed. For the first 3 months, everything's fine and fast, then I ran into random hangs and freezes. I have been into this trouble for several months now, googled hundreds of hours and tried all possible solutions with no success.

The sympton is very simple, randomly, my hard disk activity will go up to 100% for X minutes. During these X minutes, no application is responding. It immediately back to normal once the hard disk activity drops to a resonable number.

I hate to say it's the problem of this particular HD and model, but since my next step is to reformat and reinstall everything, I would definitely use another HD.
a c 415 G Storage
April 18, 2010 6:15:32 PM

cjl said:
That transfer performance sounds like Windows caching most of the file, then waiting until the cache is mostly flushed to continue.

That's exactly what'll be happening. Explorer issues reads to the source file and writes to the target file and reports on the speed that it's able to do that. Under the covers the Windows file system is caching the writes in RAM, and when it runs out of memory to do caching then suddenly Explorer isn't able to do the writes any faster than the output disk is capable of receiving the information.
a b G Storage
April 18, 2010 7:25:39 PM

@smoefer,
Try deleting and re-creating the partition from within Windows 7 (if you don't mind losing any data stored on it); I'd be very interested to see if you still have the problem.
April 18, 2010 7:52:15 PM

I am having the same problem right now with the new drive. I GET ridic slow speeds.. i even put in in the pc.. Transfer rate in usb external enclose is less than 1meg /sec and inside the hardd rive is 3.13megs/sec its so slow!! I also get a smart error at startup, doing fat32 (for ps3)

any ideas?? Iv tried reformatting and all that.. didnt try ntfs.. dont know what to do..
May 22, 2010 6:31:23 AM

Several months later I'm again puzzling with this problem. I finally decided to take this hunk of junk and try to fix it, mostly because it contains some big data I managed to put on there during the hours I'm at work or at sleep, piece by piece. I've managed to pry the thing open with a very helpful Youtube video and connected it via SATA.

First, the problem doesn't go away, so we can dismiss the external case being the problem.

Second, the problem which is decribed above by someone earlier: having it plugged in for 5 minutes trying to copy things from it resulted in Windows not responding to anything, I couldn't even open the task manager. It's the first time I remember since running Win7 pro 64-bit that I had to hit the reset button on my computer.

I am now deciding if it's worth the time getting the data off it to try some other tricks with it being an internal drive or if I should just format the thing, make a partition in Windows and see if that helps solving the problem.

In either case I will update here later on.
May 22, 2010 6:33:57 AM

On a related note, the source is two (exactly the same) older WD 7200rpm drives, 500gb in Raid0 with the destination being the WD10EADS. This is also the setup from which my system runs.

May 23, 2010 8:55:31 AM

I am happy to say that the drive is now working properly.

I've been able to copy all data from the WD10EADS that's now an internal SATA drive to one of my other external drives at the average speed of 20mb/s. Fortunately, the problem with < 1mb/s transfer rate appears to be only when putting data on the disk, instead of off.

I've removed the partition in Windows 7 and made two new ones, each consisting of half a TB. Quick format NTFS with a 16k allocated block size. I am now copying files from my raid setup to one of these partitions, 17.1gb of mixed content (small and very large files) and the speed is circling around the 50mb/s mark.

So the solution appears to be formatting in Windows 7 and creating partitions. If your WD10EADS is an external drive and not functioning even after formatting/recreating partitions in Windows, your solution might be to connect via SATA internally and create smaller partitions.

In the mean time, my new Verbatim 1TB external drive is great. It's the same price as the WD, works properly without problems, AND it has an on/off button! The WD elements series are known to cause problems with the power supply, I've already burned two of them on the older model Elements with the external power box thing.

Good luck everyone!
June 17, 2010 7:06:39 PM

Thank you so much smoefer! i WAS GETTING <1mb write speeds but when I formatted with 16k allocated block size I am now getting around 30-70mb!

Thanks again for posting your solution it saves so many of having to experience your pain!
June 19, 2010 8:53:10 AM

It seems that was of WD first green drives using the 4000k sector size which is fine/ok if formating or using with Vista or Windows7 which has native support for this. With XP there is an alignment tool used after partirion and format to improve performance, same with theWD10EAR versions but they have 64mb cache instead of 32mb. The drive you have has achieved a deserved poor reputation and higher than normal failure rates.
June 19, 2010 8:04:47 PM

WD 10/15 EADS/EARS is a problematic drive. (no matter it is internal or exernal)
try check newegg for their review.

personally i got WD15EARS DOA (actually is disconnect for don't know what reason.) on me just in 3 days stress test. i full format then check all my drive for bad sectors and it is also a good start for infant mortality test. and the drive wear out very fast due to it's aggressive power management.

so i suggest that u take out that drive and port it to a sata port. then run tests using seatools or WD's WinDLG
!