Sign in with
Sign up | Sign in
Your question

WD USB External HDD

Last response: in Storage
Share
January 20, 2010 2:48:45 AM

I recently bought a 320 GB Western Digital Elements USB external HDD for my daughter's PC.The PC uses Windows XP Pro SP2.

If the new drive is not connected the PC works fine.

Whenever the new drive (which I've named "W") is connected 'My Computer' runs extremely slowly. If I right-click or double-click the drive there is no productive response from the PC. The mouse cursor goes into "busy" mode but, after a minute or two, it's back to normal, having done nothing visible.
If I double-click on the C: drive then it opens the drive but takes a few minutes to do so.
I cannot open the WD drive, read from it or write to it. In fact at present it's just a decoration; however, I did have more ambitious plans for it .

When I first got this drive I had difficulties getting the PC to recognise it at all and when I plugged it into my own PC, using the same USB port as I use for my WD 500GB "My Book", it was recognised only as a "USB device", Windows asked me for the driver (there is none for the WD Elements), offered to find a suitable driver for me then advised that it could not.

I've used WD's support services. The only suggestion they made was to try different cables and different ports. When that was unsuccessful they told me the drive was faulty. I took it back to the shop who plugged it in to a Windows 7 machine and it worked perfectly. The shop suggested I buy a new operating system.

If I go into Device Manager I find under Disk Drives both my system drive and the Western Digital.

If I double-click the WD drive and select the 'volumes' tab, populate it and then select 'properties' the PC will either pretend to be busy doing something for a couple of minutes, then decide it's not busy any more but give me no results, or show me a blue disk with zero bytes used and zero bytes free and a file system 'RAW'. However, I'm not sure I believe it any more.

If I expand USB Controllers I find:

· USB Mass Storage Device (is this the WD drive in disguise??)
· USB Root Hub
· USB Root Hub
· USB Root Hub
· USB Root Hub
· VIA Rev 5 or later USB Universal Host Controller
· VIA Rev 5 or later USB Universal Host Controller
· VIA Rev 5 or later USB Universal Host Controller
· VIA USB USB Enhanced Host Controller

At first I thought maybe the drive was being treated as USB 1 so I disabled legacy support for USB (presumably USB 1) to no effect.

Any (positive) suggestions gratefully received!

More about : usb external hdd

a b G Storage
January 20, 2010 11:55:14 AM

Are you sure it's formatted? I would think that a factory built external drive would come formatted, but I have always built my own with an external enclosure so I don't know.
January 20, 2010 12:19:34 PM

Thanks Elel.
Yes it was formatted since, for a brief moment when it seemed to work (albeit very slowly), I was able to start a backup (which never completed but did write records as I found when I visited the shop). So it was formatted. Today I tried reformatting the drive. It took about 2 hours, at the end of which XP advised that it was unable to complete the format. I repeated the exercise with the same result.
!