Sign in with
Sign up | Sign in
Your question

Having trouble switching from my Nvidia to ATI...Help :(

Last response: in Graphics & Displays
Share
Anonymous
a b U Graphics card
a b ) Power supply
September 16, 2008 2:13:38 PM

So I'm playing this new mmohttp://en.wikipedia.org/wiki/Massively_multiplayer_onli... Warhammer Online and think my graphics cardgraphics card may be causing the choppy play I get here and there, mostly when a lot of players are on screen. So I wanted to switch out my 7950gtoc for my new ATI 8540.

Now in order to do this I had to buy a new power supply, 500W and install that as well. I tried to get rid of all things Nvidianvidia and then hooked the new card and power supply in. However when I started the system it would boot uphttp://en.wikipedia.org/wiki/Booting and give me two errors and then shut down and the repeat.

These are the errors it gave me:

Error loading C:\Windows\system32http://en.wikipedia.org/wiki/Architecture_of_Windows_NT \NvCpl.dll
The specified module could not be found

and

Error loading C:\Windows\system32\NvMcTray.dll
The specified module could not be found

Not sure what to do since I thought I had gottern rid of the old drivers. I tried driver sweeper but not really sure how to use it and probably did it wrong. I guess the *Nv* means Nvidia is still around yes? Maybe I should just get a 8800 gt from Nvidia and that will be easier.

Any suggestions would be most welcomed!
a b U Graphics card
a b ) Power supply
September 16, 2008 2:36:24 PM

there is no 8540 Lol I think you meant the 4850 but okay, I would back up data and reinstall windows. I think the errors you get are from windows registry so installing clean copy of windows would help.
September 16, 2008 2:47:46 PM

you dont happen to have a gigabyte motherboard if you do you need to update the bios
Related resources
September 16, 2008 4:30:20 PM

i updated old 7600gt with new 4850 yesterday on win xp 32. As smooth as it could be. I even forgot to uninstall nvida drivers before putting the new ati card.

No problem.

I put in the card, booted, uninstalled nvidia drivers. restarted. installed ati drivers. restarted- 100% working and fine system.
a c 107 U Graphics card
a b ) Power supply
September 16, 2008 5:14:43 PM

Those files are NVidia Driver files. It sounds to me like you didn't uninstall them properly. Boot your computer up in safe mode and uninstall them there. Also check the device manager to see if your 7600 is listed. If it is remove it. After you have done that reinstall the ATI drivers and you should be good to go.

:sol: 
September 16, 2008 5:47:16 PM

I agree with alvine, this is definitely a registry issue.
It looks like he managed to remove the Nvidia drivers but the registry keys where left behind, I would try to go into safemode and remove all references to nvidia from the registry.
!