2 Nvidia 8800 Ultra SLI

Hey guys, I'm new to this forum so I am not sure if this is the right place to ask this:

I bought a Dell XPS 720, Intel Quad Core Q6600 2.40, 3Gb Ram and with with 2 Nvidia 8800 Ultra working on SLI, running Windows Vista. I thought those video cards were enough to play all the games I want but I am having lots of lag in games like Crysis and Gears of War.
I would like to know if this low performance is a problem of my cards or if it's a configuration problem.
Thx for all :D
16 answers Last reply
More about nvidia 8800 ultra
  1. What resolution are you running at? Also, try installing the latest drivers from Nvida.com
  2. I am runnin at the max resolution of my screen 1360 x 768. I got the latest drivers today :(
  3. What quality settings are you using in crysis and what are your framerates?
  4. I am running everything on max and I am getting 6 to 14 FPS
  5. MDraak said:
    I am running everything on max and I am getting 6 to 14 FPS


    That's pretty bad for 2 ultras in sli. With single 8800gts, I get average 52 fps at High and 29 at Very High, on 1280x1024.



    The first thing to look at is sli. See if sli is enabled, look in Nvidia Control Panel or use Gpuz.
    http://www.techpowerup.com/gpuz/
  6. My guess is your CPU is bottlenecking your cards at that res. What I would do is download GPU-Z and check to see if the cards are running at 100%.

    If they aren't, then the CPU is likely bottlenecking them.

    Another guess of mine is you don't have quite enough RAM, in a lot of cases you want at least 4gb. Vista loves RAM.
  7. i'm sorry but dell played you
  8. What settings are you trying to run on Crysis? Very High in Direct X10 will run poorly on just about every GPU setup out, and Gears of War on the PC has some issues; sometimes similar setups can have completely different frame rates due to the poor port job.
  9. I changed all the settings to low and the rez to 800X600 and I get 38 FPS..... that's still low for my PC I guess.... Do you think I should install windows XP in the other HD to get better performance?
  10. I used GPUz and it said that my SLI was off..... still without SLI the FPS was low.......but when I turned on my SLI windows had an error ....... now when I try to turn SLI on again nothing happens :S
  11. ok.... I restarted my PC, SLI was working..... I had 20 - 27 on Crysis for like 3 mins then the game crashed...lol.... :P
  12. It's weird.... w SLI when something explodes the FPS goes to 3 lol....
  13. MDraak said:
    It's weird.... w SLI when something explodes the FPS goes to 3 lol....


    That means cpu bottlenecking. Crysis is heavy on physics. Those pieces of debris all need cpu to calculate trajectory. Either overclock your cpu, or you can turn physics details off, which will affect gameplay, of course.

    20-27 fps is still low for dual 8800ultra. The crushes may be due to psu not supplying enough power, or overheating.
  14. But do you think my CPU isnt enough for Crysis?
  15. MDraak said:
    But do you think my CPU isnt enough for Crysis?


    That's what the severe fps drop during explosions is pointing to. Although I had thought q6600 is enough for Crysis, strange... :p
  16. I doubt his CPU is the issue; I'm running an ancient socket 939 Athlon X2 4800+ and my Crysis framerates are much better than what he's reporting.
Ask a new question

Read More

Nvidia Graphics