Sign in with
Sign up | Sign in
Your question

Razer Copperhead mouse has issue with mobo

Last response: in Components
Share
November 12, 2008 3:57:45 PM

I just replaced my mobo with a Gigabyte-p45-ds3l and my razer copperhead mouse will not respond. It lights up completely but does not move the cursor at all. I have tried moving it to all 8 usb ports on the front and back of the machine. My razer keyboard, and my razer barracuda headset work fine in the usb. The human interface devices can read the copperhead but always has an error that says that is has the same name as a service name. Any ideas?
November 12, 2008 8:55:40 PM

Check your drivers first. Completely remove whatever ones you have on there now and try to get the latest version from the Razer site. If that dosen't work you could try older drivers too. You might also flip the mouse over and make sure there is nothing blocking the laser and that the laser is actually working. It could just be dead.


~AWS 32°~
November 12, 2008 9:24:12 PM

I have done the new and old drivers neither of which will install on my computer because it says it matches a service name.
Related resources
November 12, 2008 10:28:01 PM

I believe a "service" is a program set to run at start up and remain in the background. Perhaps one of your other razer products is using the same service name as the mouse does causing a conflict. Maybe try removing the other peripherals and their software then try installing the mouse drivers first. If all else fails I can vouch for the Logitech G5...nice little mouse. Hope it helps.

~AWS 32°~
November 13, 2008 6:55:36 PM

I actually figured it out. I went into my Human Interface Devices and had to change one of the USB HID devices into a USB mouse device. I have never had to do that before but the second i switched the drivers it worked like a charm. Thanks for the help.
!