Sign in with
Sign up | Sign in
Your question

No sound "driver enabled but not started"

Last response: in Windows XP
Share
January 27, 2011 3:48:04 PM

Just rebuilt my home PC and after trying to get audio out on the HDMI port of the PCIe graphics card I noticed I only had my onboard Realtek device showing in the audio playback list field of "control panel_Sounds&Audio devices"(no 210 device is shown). Mucking about with drivers and KB upgrades I made the situation worse and now neither audio device shows in the Sounds&Audio panel.

Hardware is OK as I can get sound if I run the Realtek control panel app and test surrond sound using their demo tab. This seems to be related to Windows not seeing the devices as media player says there is no audio device.

All the dirvers are listed with no errors in Device Manager (PnP Enumerator is also there).
Device manager says for all the audio drivers (realtek and nvidia) "driver is enabled but not started"
I have done the following (not necessarily in this order) WITH NO SUCCESS and need your help:

1. Upgraded all drivers from Manufacturers sites
2. Inserted a semi colon infront of ExcludeFromSelect=* from machine.inf and reinstalled the PnP Enumerator
3. Removed the Nvidia graphics card to try onboard audio only
4. Checked the Bootlog file for "did not start" audio entries (only one listed - cdaudio.sys)
5. Removed /fastdetect from boot.ini uninstalled the realtek audio driver and rebooted
6. Changed the name of the swenum.sys file to try and see if I could get the PnP enumerator to fail, but it just generated a new swenum.sys
7. Checked control panel_administrative tools_Services to ensure Windows Audio service was set to auto and running - it was.
8. Set MS Auto updates on and installed all the KB updates

I really don't want to re-install my OS!

Any other ideas or suggestions?

Jan the Man

AMD Athlon 3Ghz II X2 250
Win XP Pro SP2
Gigabyte GA-M68M-S2P mobo
Realtek onboard HD audio
Nvidia Geforce 210 (7.1 audio via bypass)
directX9
January 27, 2011 7:08:31 PM

I have now installed SP3 - same problem.

I think this may be something to do with Microsoft Universal Audio Adapter UAA, how can I uninstall these, windows keeps restarting them and I want to test the audio with them disabled (I have 2 in device manager, I guess 1 is for the Realtek and the other is for the Nvidia 210).

Any ideas?

m
0
l
January 27, 2011 9:42:50 PM

I've given up on the UAA idea, now I'm at my wits end
m
0
l
Related resources
January 27, 2011 9:47:59 PM

When you go into control panel and sound and settings. Do you see what your default device is selected as?
m
0
l
a b \ Driver
January 28, 2011 1:15:49 AM



There are two places that must agree on what your speakers consist of.

One is in the Realtek Control panel.......

In the Audio I/O tab, the left side, has a dropdown box to select your speaker setup.

Set to what you really have.

In the Windows XP Control Panel, Sounds and Audio Devices, in the Volume tab, down at the bottom right, there is a button labeled "Advanced" and you should click it. Set this to what your speakers really are also.

When Realtek and XP agree on what your speakers really are, they might just work.

Some high-end boards have many jacks to plug things in. Always start with the green one, and it should always be Front R/L.

Other jacks may seem like they can handle the rear, but really can't. Here you must try the different one's out, always allowing the Realtek control panel a couple seconds to acknowledge something was just plugged in , or pulled out, and it is properly identified as to what it was.



m
0
l
January 28, 2011 6:07:13 AM

That was how I first recognised that I had a problem. There is NO selectable entry in the default plaback device screen, just a greyed out Realtek entry. Therefore the advanced tab is greyed out too. So sorry Tigsounds I can't check teh speaker settings (I don't think this is teh problem).
m
0
l
January 28, 2011 6:50:40 AM

Rip the drivers completely, Make sure the audio is enabled in bios if it an on board card, Than reinstall newest drivers, Go to control panle sounds and devices and under the play back tab( Something similar havent used xp in a whille) and make sure that real tech is selected alternatively if you want I can just use teamviewer to try and fix it remotely if you would like send me a pm.
m
0
l
January 28, 2011 9:20:15 AM

Thanks Plasticjesus690 I will delete the drivers and re-install latest ones.
m
0
l
January 29, 2011 6:32:41 PM

Re-installing drivers have not fixed this. I am thinking of backing out my KB fixes one at a time and removing service packs, but will wait for a feee other responses before I do this. Maybe upgrading to Win7 will cure this too?
m
0
l
January 29, 2011 10:25:23 PM

You cannot do an upgrade install of windows 7 from xp. You will have to do a fresh install. If you could please upload a screen shot of the tabs in sound and devices for us. Also device manager. I really do not think it is a service pack issue. Perhaps one of the Hotfixes you attpemted caused further issues. Alternatively you could try a repair install of the os.
m
0
l
a b \ Driver
February 1, 2011 5:04:38 AM




You may need an SMBus driver installed. Look for any unknown devices in Device Manager that needs it's driver installed, if one is there, that would be it.
m
0
l
February 6, 2011 7:45:48 PM

I have now fixed this (in a round about way)...
I re-installed XP (SP2) and reinstalled the realtek drivers. Worked fine.

I think I was expecting too much from my graphics card. Although it does HD audio (as an output when it has the spdif cable connected to it from the mobo. I now don't think it would ever appear as an audio card in its own right.

I am waiting for the spdif internal cable to finally prove this and test I can get audio over my HDMI port.

Thanks for all your suggetions.
m
0
l
February 15, 2011 6:17:07 PM

HDMI audio now works.

The internal cable was needed (note: the polarity is weird and if you get it wrong your PSU will not startup!!), but I also have achieved my original objective of getting the graphics card audio device in Control Panel_Sounds&Audio.
I did this by using the Realtek sound manager and then the Nvidia control panel...
Realtek sound manager(you may need your TV switched on for this):
On the mixer playback spanner, set the "enable playback multistream"
Ensure SPDIF is ticked
On the digital portion of the screen, click on the spanner
Check the output source is "output digital audio source"

Nvidia control panel:
Click on "setup multiple displays"
Choose "Clone" or another dual screen option
Click apply
Then a new directory appears on teh LHS under displays, called "set up digital audio"
Click on this and click on the button to start windows sounds & audio devices

Select the audio device you want as they should now all be listed.
m
0
l
!