Sign in with
Sign up | Sign in
Your question

HD4870 dropping out on Crysis

Last response: in Graphics & Displays
Share
September 24, 2008 3:14:10 AM

HI,

My computer:
E2160 Dual Core @1.8Ghz
2GB 667Mhz RAM
ATi MSI HD4870 DDR5 512MB OC
Windows XP

When playing Crysis or Crysis Warhead, with a mix of High and medium settings and no AA I average about 20-30 FPS. Which is low but I think its my CPU bottlenecking from advice from another thread.

Anyway the card is brand new and sometimes I get 'dropouts'. It seems to happen more when I zoom in (right click) with weapons. It can happen at various points in the game and no specific time when it happens.

What happens is the screen goes black, sometimes I can still hear the sounds, then my ASUS monitor pops up 'NO SIGNAL' then goes back to black and after a few moments will load back to the desktop with VPU recover all up in my face saying "the drivers failed to respond etc etc'

This can be annoying becuase sometimes it will be after 5 min, sometimes after 45 min etc.

The card has the latest drivers (catalyst 8.9). What could it be? Anyone else with similar problems?

More about : hd4870 dropping crysis

September 24, 2008 3:21:33 AM

Whats your power supply ?
September 24, 2008 3:25:36 AM

I'm getting similiar issues. Like during heavy gunfire my screen goes black for half a second when i get hit. The game seems to crash randomly. I have a 8800gt which works flawlessly on all my other games. It's something i'm willing to bet will be addressed in the first patch for the game. just my 2 cents
Related resources
September 24, 2008 3:28:06 AM

550w toughpower, Computer shop said it would be plenty for my setup
September 24, 2008 3:31:44 AM

kimfromabove1985 said:
550w toughpower, Computer shop said it would be plenty for my setup


Unless defective, it's more than enough.

Maybe software issues? Or possibly cpu overheating.
September 24, 2008 3:51:23 AM

I have the same problem and have found that I am running short of ram. When I began noticing this I downloaded a program that monitors ram usage. When playing Crysis Warhead with high settings I usually have about 2% ram free of my 2GB. I had 80% before stating the game. Also my page file usually runs at about 80% free of 4GB. When running Crysis Warhead it drops to about 40%. I just ordered another stick of ram for 3GB, I will see what that does.

One way to see if it is a ram shortage is to look to see if your HD lead illuminates when zooming in or out. Mine does when I zoom and also when looking around corners and such.

This is with a C2D E6400 @ 3.2GHZ, HD4850 512, 2GB ram, and Windows XP SP3.

Edit: Sorry I just thought it was lagging. I didn't read the full post. It may be just a bug that will get patched or the card is overheating or is defective. Also as someone has mentioned your PSU may be defective.

I had a X1950XT that would give VPU recover warnings. I ran an ATI tool test on it an it produced all kinds of artifacts at stock settings. Even with the clocks 75% of the standard ones it still crashed. I think that the card was overheating for a while because it had been clogged with dust. The heat did permanent damage and the card had to be replaced.
September 24, 2008 12:23:19 PM

CPU bottleneck. Overclock your CPU to at least 2.4 GHz.
September 24, 2008 3:36:45 PM

I thought that it would be more related to the video card being defective, or the drivers?

Could a slow CPU really be the cause of it?

I used to play crysis with lower settings with my old 8600GTS and it never dropped out, but it does now that I've upgraded to a HD4870...

Also I just tried Crysis warhead and this time 5 minutes into it, the screen blacked out, no signal, then it loaded back up but there was a scramble of red boxes all over the screen. Then I quit the game and there was red tinge artifacts all over everything on screen, and VPU recover telling me it had to restart the drivers.....

Re-Booted computer and fine again.

This is really annoying, just bought warhead and cant play it properly! :fou: 
September 24, 2008 6:58:16 PM

kimfromabove1985 said:
I thought that it would be more related to the video card being defective, or the drivers?

Could a slow CPU really be the cause of it?

I used to play crysis with lower settings with my old 8600GTS and it never dropped out, but it does now that I've upgraded to a HD4870...

Also I just tried Crysis warhead and this time 5 minutes into it, the screen blacked out, no signal, then it loaded back up but there was a scramble of red boxes all over the screen. Then I quit the game and there was red tinge artifacts all over everything on screen, and VPU recover telling me it had to restart the drivers.....

Re-Booted computer and fine again.

This is really annoying, just bought warhead and cant play it properly! :fou: 


Sounds like gpu overheating. 4870 runs hot, and yours is oced.
http://en.expreview.com/2008/06/24/first-review-hd-4870...

Stress with this while monitoring temperature. Stress mode, default resolution no AA.
http://www.ozone3d.net/benchmarks/fur/
October 12, 2008 10:10:49 AM

Hey Dagger, I ended up upgrading to a E8500 and Asus P5Q-PRO MB, Just got stuck into Crysis Warhead and the same drop out happened again. So I did Furmark under the conditions you said and got the following results:

At idle, like on desktop GPU temp: 60-63C

When I started Furmark it went up to about 68-69C, Then as time progressed it slowly went up, 1C at a time, after 300 seconds it was at 70-71C, It felt like it was just going to get higher. I know I should have let it go for longer but I thought that was already a good indication.

So would you say that is too high? Causing the dropouts? Would furmark be more stressful on the GPU than Crysis?


I am going to research how to increase the HD4870 fan speed, and failing that see if there is any parts I can add to cool it better.

And btw the fur ring is freaky because it looks like it has red veins through it!


October 12, 2008 10:50:56 AM

ok Crysis Warhead is really annoying now, My specs are on Gamer, No AA, Ive tried 1440x900 and 1280x768 res.

Now I'm at 'Frozen Paradise' and it involves your team coming out of a tunnel, and being sniped at from a distant tanker ship. And EVERY time i zoom in with the sniper rifle it freezes, sound plays, then VPU recover kicks in. My FPS is solid, at 50+ FPS. And when I zoom in on something closer, like a squad memebr in the cave, it works fine.

So maybe it is a Crysis and Crysis Warhead problem, becuase prior to this ive noticed that it usually dropped out when right-click zooming in.

I dunno but It's doing my head in and preventing me from playing a otherwise kickass game.
October 12, 2008 11:14:29 AM

Just tried it again, dropped settings down to Medium (mainstream) and was getting 110+FPS (in the tunnel thing, dropped down to 40FPS when I get out of the cave)

Didnt scope, ran out side killed a few ppl, mucked around, then tried scoping the tanker from the cave again and it did it again. Ive heard of it possibly being a common problem when zooming in, like losing alot of FPS and lagging? Some ppl have even said a memory leak thing?
October 13, 2008 8:48:56 AM

could it be becuase im using 667hmz RAM? Anybody?
October 13, 2008 11:35:05 AM

ok so its definately not GPU overheating, as it can happen 2 seconds into the game, plus in big fire fights, where the FPS can slow down to 10FPS it doesnt crash.

Its ONLY when zooming in with sniper rifle or RPG Scope in outdoor environments. Makes me think it may be Memory problem due to game being crap.

Still if anyone has any ideas it would be helpful
October 13, 2008 2:09:23 PM

It is probably your GPU overheating. Get GPU-Z on there, and get the log-file writing while you have programs running over the top of it. I had EXACTLY the same issues after I upgraded the cooling, and it turned out the HS wasn't sat correctly because the clips on the Accellero where pulling the HS out of true.
October 13, 2008 4:20:09 PM

I hav similar issues when i oced my hd4850. So i recommend you to set your card frekvencies to 750/900 (standard by ati). I have noticed that your card is factory oc, so reduce the frekvencies. Tell if it solved your problem...
!