Sign in with
Sign up | Sign in
Your question

USB CARD READER NOT VISIBLE IN WIN7 x64 ?

Last response: in Storage
Share
January 30, 2010 10:03:24 PM

Has anybody got any experience of USB memory card readers not working in Windows 7 x64 ?

I have an eblue card reader with 3port usb hub, which was working perfectly until I upgraded from Win7 x32 to Win7 x64. Now the system is running in 64bit, it no longer brings up a drive letter to show the memory card, the drive also isn't showing under storage manager.

The strange part however, is that the device is definatly on and receiving power. The USB hubs work perfectly, and nothing is showing up as a problem under device manager. I've tried changing USB drivers and reassinging drive letters, but nothing is working.

Has anybody got a starting point for sorting this one.....I've spent hours so far, and its getting pretty annoying !! THANKS ALL...... :(  :( 
a b G Storage
February 1, 2010 4:22:24 AM

The drivers for 64-bit OSes are sometimes different than their 32-bit counterparts. So you need to find Windows 7 64-bit drivers for your card reader. Failing that, look for Vista 64-bit drivers, which should work as well.
February 1, 2010 5:20:48 AM

On my machine, (win 7 pro 64) the os hides the drive letters when they were visible under windows vista ult 64.. When I plug something into my card reader, it does show up though..

I also noticed that when I go to folder options (of a windows explorer) and specify that I do NOT want to hide hidden and system files, the 4 drives from my card reader appear again when opening up "My Computer"

Also, my computer is recognizing the card reader as there are 4 drives present for the card reader when looking under the "Disk Management" section of the "Computer Management" application in Windows 7. To get there, go to Control Panel - Administrative Tools - Computer Management - Disk Management.

I don't think there is anything wrong with your computer. Try plugging in some media
Related resources
February 1, 2010 6:57:16 AM

Thanks to everyone for replying.....I've tried media and it makes no difference, nothing shows up still, not even under disk management. I've also tried website for the maker EBLUE (maplins special) and they don't do drivers for many of their models, let alone this one !! I did notice it should be VISTA x64 capable so I've since tried it on an x32 Win7 machine but still nothing. It does however work on an XP machine, so I think it just clearly not working with Windows 7. I know it should, and I can't explain why ??
September 4, 2011 9:27:16 PM

ijtaylor said:
Thanks to everyone for replying.....I've tried media and it makes no difference, nothing shows up still, not even under disk management. I've also tried website for the maker EBLUE (maplins special) and they don't do drivers for many of their models, let alone this one !! I did notice it should be VISTA x64 capable so I've since tried it on an x32 Win7 machine but still nothing. It does however work on an XP machine, so I think it just clearly not working with Windows 7. I know it should, and I can't explain why ??


Hello All,

Maybe a little late but i had some bad experience with X64 (win7) and USB as well.
I ound a entry somewhere that USB cables that work fine under X32 windows might not work in X64 sytems.
dont ask me why. But after trying 4 USB cable from my drawer a was able to communicate with my HF10 Canon Camcorder.
so Try some other USB cables when possible of course.

All the best Ronald
!