Sign in with
Sign up | Sign in
Your question

Unable to boot after intel raid 0 rebuild

Last response: in Storage
Share
February 1, 2010 2:06:17 PM

Hello

I did a Win7 Pro build on a Gigabyte EP45-UD3P recently. Set up RAID zero on a pair of Seagate Barracuda 7200.10 drives (ST3250410AS to be exact). Was fine for a week or so then I got a SMART error. I cleared it but got another the next day. I pulled the drive and put in a spare. Used the Intel Manager to do do a rebuild. After a reasonable amount of time I came back to see a blue screen. Booted up and the system was running on the NEW drive with the original out of the mirror.
Subsequent attempts fail in a similar manner. Thanks in advance for any assistance!
a c 127 G Storage
February 1, 2010 2:14:18 PM

You broke the RAID0 array by adding a new drive; thus you lost all data on the RAID0 and have to re-install.

Or did you thought you could 'rebuild' RAID0s? Ofcourse since you use RAID0 you have a good backup somewhere; simply restore from there. Also, it would benefit solution if you provide information on that SMART error.

Basically, one of your drives failed in a RAID0; so you lost access to the data on the RAID0.
m
0
l
February 1, 2010 2:36:33 PM

Sorry, Bad title. I tried to change it but think I posted again.
Anyway, I did NOT lose the data, just the mirror. I WAS able to switch back to the original (Port 0) drive and boot.
I just can NOT get it to rebuild. It starts the rebuild, runs for an hour or so then blue screens.
m
0
l
Related resources
a c 127 G Storage
February 1, 2010 3:07:01 PM

RAID0 cannot be 'rebuilt'.

Are you sure you don't run a RAID1 array instead? That's a mirror, RAID0 means striping.
m
0
l
February 1, 2010 4:29:01 PM

OOOPS!
Indeed. Mirror not stripe. Sorry!
m
0
l
a c 127 G Storage
February 1, 2010 4:53:06 PM

1) do you have the controller in RAID mode?
2) do you see the RAID1 (mirror) volume when booting with the Intel MatrixRAID firmware stuff?
3) Does your current mirror exist of 1 or 2 disks? Meaning, perhaps its running degraded and on a single disk now.
4) Did you try rebuilding using Intel MatrixRAID BIOS or inside windows with its utility? Can you post screenshots?
m
0
l
February 1, 2010 5:30:59 PM

Hi,

YES, in RAID mode. (using INTEL not GIGBYTE, this board has both).

Yes can see the RAID and enter the RAID BIOS (CTRL-I) when booting.

Current Mirror is degraded, 1 disk on PORT 0 with disk on PORT 1 in error and out of array.

Used utility in Windows. I looked at initiating rebuild from RAID BIOS, but that said it would finish rebuild from within windows so I just quit and did it from Intel Utility in windows.

I will step through the rebuild again tonight and do some screen captures.
I tried to run the SeaTools to test the drive but could not while it was controlled by the Intel RAID.
The Intel RAID manager did not specify what the SMART error was. Any way to find out what it was?

Thanks again for the assistance!
m
0
l
!