Sign in with
Sign up | Sign in
Your question

Raid on Gigabyte X58A-UD7.

Last response: in Storage
Share
February 1, 2010 3:39:43 PM

First time I tried to run the computer in normal hard drive configuration it worked perfectly. I set it up this way to make sure all the components worked before the return date ran out. After making sure it all worked I wanted to go back and do a fresh install setting up a Raid 0 for my OS on the 2 SATA6Gb/s ports, and storage on 3 normal sata 2.0 ports in a Raid 5. I went into the bios and set up all the drives according to manual and everything looked fine. I copied the drivers from the Gigabyte website for Raid controllers to a flash drive, (so far so good). When I went to install the OS Windows 7 I did a custom install. When it gets to the hard drives they show up like I expected, and at this point you have the option to load drivers. I open my files and there's an option to show only compatible drivers for the board. This is where things start to look messed up. I have an Intel board but the only compatible application driver is marked as an AMD?????? 4 files showed up that where supposed to be compatible so I installed them even though they didn't seem to be the right ones. Everything looked fine till Windows rebooted and said drive read error. I've tried every type of driver that is supposed to work whether it showed up on the compatibility option or not with the same results. I'm very frustrated because I've sent Gigabyte and email and of course they haven't responded and there support line is non-existent. It's always "All circuits are busy."
The computer ran great with the normal setup, but that's NOT why I bought 5 hard drives!!!!!!

If anyone can help I'd really appreciate it. I've searched and searched and I'm not the only person having trouble but I haven't found anything for my particular motherboard. The manual is not up to date with Windows 7 install instructions, but I don't think it would be that different from the others and Windows 7 seems pretty straight forward about installation!!!!???? I'm bummed. I can usually figure these things out eventually, but this one has me stumped.

This is my computer build, here are the components:
Windows 7, 64 Ultimate.
Intel Core i7-975 Extreme Edition Bloomfield 3.33GHz LGA 1366.
5 WD 10,000rpm 300Gb drives, (2 for Raid 0, 3 for Raid 5)
Gigabyte X57A-UD7, Revision 1.0, BIOS F2. 2 x 16 Mbit flash, support for Dual BIOS, PnP 1.0a, DMI 2.0, SM BIOS 2.4, ACPI 1.0b, QPI, 4.8GT/s, 6.4GT/s.
North Bridge: IntelĀ® X58 Express Chipset, support for SATA RAID 0, RAID 1, RAID 5, and RAID 10.
South Bridge: IntelĀ® ICH10R.
Marvell SE9128 high speed SATA3 storage interface, support for SATA RAID 0, and RAID 1.
GIGABYTE SATA2 chip, support for SATA RAID 0, RAID 1, and JBOD.
JMicron JMB362 chip, support for SATA RAID 0, RAID 1, and JBOD.
(6 Gb) G.SKILL PIS Series 4GB (3 x 2GB) 240-Pin DDR3 SDRAM DDR3 2200 (PC3 17600) Desktop Memory, (Support for DDR3 2200/1333/1066/800 MHz memory modules).
Saphire HD 5970 Hemlock dual CPU graphics card.
LG Blu-ray burner.
KINGWIN Lazer LZ-850 850W Modular 80 PLUS BRONZE Certified Active PFC Power Supply.

More about : raid gigabyte x58a ud7

a c 126 G Storage
February 1, 2010 5:00:24 PM

1) You cannot use an AMD driver for an Intel-chipset. You need an Intel RAID driver.
2) You know RAID5 is fragile and can fail with all disks being 100% fine, thus requiring you to have a backup of the data on the RAID5; otherwise your data is at risk, especially with these low-quality onboard drivers. Avoid RAID5 if you can.
3) Make sure the SATA controller is in RAID mode; create RAID in the RAID BIOS setup; then install Windows using usb/cd with drivers. Windows should not see your RAID drivers individually; only one big volume. If Windows does see the physical drives; your controller is not operating in RAID mode.
February 1, 2010 5:16:59 PM

Yes I know you shouldn't be able to run an AMD driver but I was desperate after trying everything else and it DID show up on the Windows install as compatible. I've done all of the above mentioned tips. I can only assume there's a very specific sequence (which I've tried to emulate from reading the XP and Vista instructions seeings thats all I have to go by). On the web site it does say to install One driver first then it mentions installing one before a certain other, but it doesn't give any particular sequence for the 5 driver downloads othe than what I just mentioned.
The other option is that the drivers, hardware and software aren't all on the same page yet.
Related resources
a c 126 G Storage
February 1, 2010 5:35:00 PM

The AMD drivers may be compatible with Windows, but will not work for Intel-created fakeRAID arrays. Im pretty sure the cd included with the motherboard containing RAID drivers is not an AMD driver but instead the Intel MatrixRAID storage that you need.

Also, im assuming you know your motherboard has multiple RAID controllers:

Quote:
South Bridge:
1. 6 x SATA 3Gb/s connectors (SATA2_0, SATA2_1, SATA2_2, SATA2_3, SATA2_4, SATA2_5) supporting up to 6 SATA 3Gb/s devices
2. Support for SATA RAID 0, RAID 1, RAID 5, and RAID 10

Marvell 9128 chip:

1. 2 x SATA 6Gb/s connectors (GSATA3_6, GSATA3_7) supporting up to 2 SATA 6Gb/s devices
2. Support for SATA RAID 0, and RAID 1

GIGABYTE SATA2 chip:

1. 1 x IDE connector supporting ATA-133/100/66/33 and up to 2 IDE devices
2. 2 x SATA 3Gb/s connectors (GSATA2_8, GSATA2_9) supporting up to 2 SATA 3Gb/s devices
3. Support for SATA RAID 0, RAID 1, and JBOD

JMicron JMB362 chip:

1. 2 x eSATA 3Gb/s connectors (eSATA/USB Combo) on the back panel sup- porting up to 2 SATA 3Gb/s devices
2. Support for SATA RAID 0, RAID 1, and JBOD


So in short, you have:
- 6x SATA 3Gb/s on Intel RAID controller
- 2x SATA 6Gb/s on Marvell controller
- 2x SATA 2Gb/s on "Gigabyte controller" (which is actually Silicon Image)

You would want to use the Intel RAID controller and drivers. So connect your disks to the blue coloured SATA ports. Then create RAID array using Intel MatrixRAID BIOS utility and then install the drivers during Windows install setup.
February 1, 2010 5:38:55 PM

OK, I'll have to try again later. I have classes tonight. Thanks for the help in the mean time.
February 2, 2010 4:44:28 PM

Yippee!!!!!! It works!!!!!
I finally figured it out. Here's how I got the drivers to load During my Windows 7-64 OS install.

First there are two completely different set of drivers: 1 set on the disc; and 1 set on Gigabytes website.

You need 3 drivers for the OS setup: iMSM (Intel), GSATA (Gigabyte), and Marvell (Marvell).

I had to use the iMSM and the Marvell drivers from the motherboard disc in the folder label BootDrv, and the GSATA (GIGABYTE SATA2 Driver) from the website.

The website driver is buried in the folder. Open the file and go to the Application folder, open it and select the jmide folder (this is the driver you need).

I'm not sure if it makes any difference or not but I loaded the Intel driver first, the Gigabyte second, and the Marvell last all from a flash drive.

When I heard my hard drives start clicking away I knew something was happening!!! I'm thrilled I was able to figure this out, but now it seems that my hard drive was faster without the RAID 0.
According to the Microsoft Performance and Information Tool my hard drive was rated a 5.9 before the RAID 0 install, now it's rated at a 5.1???????
I don't know why that would be, but that's what it says. So I may be removing my RAID 0 and replacing it with a mirror drive setup.

Many thanks sub mesa for your interest and help with my problem.
I love my computer again!!!!!!
a c 126 G Storage
February 2, 2010 4:57:24 PM

You may want to use real benchmarks instead of the microsoft tool - and for additional performance you can enable 'write caching' as an option in the Intel RAID-drivers. This will allow your RAM to be used as writeback - like hardware RAID has. This will speed up writes and allow more efficient buffering.

It does come at a risk though - if your OS crashes or the power interrupts while it has data in your RAM, your filesystem may become corrupted. So consider the RAID0-volume extra vulnerable to failure if you use this option. As long as you keep proper backups this would allow you a very fast storage setup.
October 1, 2010 7:43:26 PM

Hi .i have similiar problem.
i have set up arrays in bios.
i have downloaded intel drivers 64 bit due to 64 bit win 7 installation to usb stick
when i am promted to load driver ,i load driver intel IC10R sata/raid drivers *64bit ,push next button and it says
Please load 32 bit and singed 64 bit drivers????????? or windows is unsubale
October 11, 2010 1:43:06 AM

Copy all the available drivers to your stick. When you load Windows 7 to your hard drive and are prompted to load drivers from the stick, only the ones that will actually work will show up on your files to load in the system. If none are showing up you don't have the right drivers.
!