Sign in with
Sign up | Sign in
Your question

Explorer Directory Cache Corrupted - Fixes?

Last response: in Windows XP
Share
Anonymous
September 4, 2005 1:56:03 PM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

Some cache used by Windows XP (SP2 with all updates) Explorer is clearly
corrupted on one of my systems. Directory properties (including folder
type, icon, and picture) for many folders are incorrect and cannot be
corrected. In specific instances, attempting to correct the info for one
directory fixes that directory but changes another; fixing the 2nd then
changes the first...as if Windows appears to have the properties for
the two directories "cross-threaded".

Creating a new copy of one of the "linked" directories would appear to be
a possible solution. That is, until the files from the old copy are moved,
the
old copy is deleted, and the new copy is renamed. As soon as the new
directory is renamed, it acquires the corrupted properties of the previous
copy.
So the problem is linked to the directory NAME, not the actual file on disk.

Results are the same, regardless of... Explorer's Folder Options Advanced
Settings "Do/Do Not Cache Thumbnails", the TweakUI Explorer Folder
Customizations "folders to remember" setting, BagMRU size per KB813711
"customizations are lost or incorrect", or other "help" as provided by the
generic KB812003 "how to" article.

I suspect there are registry entries for the properties of the corrupted
directories
that point to the same place, one or more of which must be repaired. I
further
suspect an XP bug which, even if I do get the current errors corrected, will
come
back to haunt me in the future. Any help at all?
Anonymous
September 4, 2005 4:11:38 PM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

On Sun, 4 Sep 2005 09:56:03 -0700, Leland Bruns wrote:

> Some cache used by Windows XP (SP2 with all updates) Explorer is clearly
> corrupted on one of my systems. Directory properties (including folder
> type, icon, and picture) for many folders are incorrect and cannot be
> corrected. In specific instances, attempting to correct the info for one
> directory fixes that directory but changes another; fixing the 2nd then
> changes the first...as if Windows appears to have the properties for
> the two directories "cross-threaded".
>
> Creating a new copy of one of the "linked" directories would appear to be
> a possible solution. That is, until the files from the old copy are moved,
> the
> old copy is deleted, and the new copy is renamed. As soon as the new
> directory is renamed, it acquires the corrupted properties of the previous
> copy.
> So the problem is linked to the directory NAME, not the actual file on disk.
>
> Results are the same, regardless of... Explorer's Folder Options Advanced
> Settings "Do/Do Not Cache Thumbnails", the TweakUI Explorer Folder
> Customizations "folders to remember" setting, BagMRU size per KB813711
> "customizations are lost or incorrect", or other "help" as provided by the
> generic KB812003 "how to" article.
>
> I suspect there are registry entries for the properties of the corrupted
> directories
> that point to the same place, one or more of which must be repaired. I
> further
> suspect an XP bug which, even if I do get the current errors corrected, will
> come
> back to haunt me in the future. Any help at all?

Ian, you forgot to give us details. About the only concrete thing I got out
of your message is that you see no changes when toggling thumbnails on or
off. You can delete the hidden thumbs.db file to force the creation of a
new one.

More details about the differences between what you expect to see and what
you are seeing (including folder names) are needed.

--
Sharon F
MS-MVP ~ Windows Shell/User
Anonymous
September 4, 2005 4:11:39 PM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

"Sharon F" wrote:

> On Sun, 4 Sep 2005 09:56:03 -0700, Leland Bruns wrote:
>
> > Some cache used by Windows XP (SP2 with all updates) Explorer is clearly
> > corrupted on one of my systems. Directory properties (including folder
> > type, icon, and picture) for many folders are incorrect and cannot be
> > corrected. In specific instances, attempting to correct the info for one
> > directory fixes that directory but changes another; fixing the 2nd then
> > changes the first...as if Windows appears to have the properties for
> > the two directories "cross-threaded".
> >
> > Creating a new copy of one of the "linked" directories would appear to be
> > a possible solution. That is, until the files from the old copy are moved,
> > the
> > old copy is deleted, and the new copy is renamed. As soon as the new
> > directory is renamed, it acquires the corrupted properties of the previous
> > copy.
> > So the problem is linked to the directory NAME, not the actual file on disk.
> >
> > Results are the same, regardless of... Explorer's Folder Options Advanced
> > Settings "Do/Do Not Cache Thumbnails", the TweakUI Explorer Folder
> > Customizations "folders to remember" setting, BagMRU size per KB813711
> > "customizations are lost or incorrect", or other "help" as provided by the
> > generic KB812003 "how to" article.
> >
> > I suspect there are registry entries for the properties of the corrupted
> > directories
> > that point to the same place, one or more of which must be repaired. I
> > further
> > suspect an XP bug which, even if I do get the current errors corrected, will
> > come
> > back to haunt me in the future. Any help at all?
>
> Ian, you forgot to give us details. About the only concrete thing I got out
> of your message is that you see no changes when toggling thumbnails on or
> off. You can delete the hidden thumbs.db file to force the creation of a
> new one.
>
> More details about the differences between what you expect to see and what
> you are seeing (including folder names) are needed.
>
> --
> Sharon F
> MS-MVP ~ Windows Shell/User
>

First, deleting the thumbs.db files, as with the other fixes I've tried, has
no
effect on the problem. (Ditto, lots of reboots.)

One example (since I have too many to list them all): I have 2 directories,
C:\...\MyMusic\Artist1\Album1 and C:\...\MyMusic\Artist2\Album2, both of
which were customized with folder type "Music Album" and a specific picture
from within the folder itself. However, at some point, opening Artist2 in
thumbnail mode shows Album2 with the picture from Album1. Correcting
the problem here at first appears to work. However, subsequently opening
Artist1 in thumbnail mode shows Album1 with the picture from Album2.
Correcting Album1 here once again changes the picture for Album2...I
can toggle back and forth all day! NOT something, I as a user should be
able to damage.

Leland
Related resources
Anonymous
September 4, 2005 5:42:57 PM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

On Sun, 4 Sep 2005 10:32:01 -0700, Leland Bruns wrote:
> First, deleting the thumbs.db files, as with the other fixes I've tried, has
> no
> effect on the problem. (Ditto, lots of reboots.)
>
> One example (since I have too many to list them all): I have 2 directories,
> C:\...\MyMusic\Artist1\Album1 and C:\...\MyMusic\Artist2\Album2, both of
> which were customized with folder type "Music Album" and a specific picture
> from within the folder itself. However, at some point, opening Artist2 in
> thumbnail mode shows Album2 with the picture from Album1. Correcting
> the problem here at first appears to work. However, subsequently opening
> Artist1 in thumbnail mode shows Album1 with the picture from Album2.
> Correcting Album1 here once again changes the picture for Album2...I
> can toggle back and forth all day! NOT something, I as a user should be
> able to damage.
>
> Leland

Thanks for the added info Leland. In the case of music folders you have
Windows and your default media player poking fingers at it. Windows will
follow your customizations (folder properties> Customize> Change Picture).
However a media player can be configured to update album info (and album
photo pics) from the internet.

Try disabling the customizing features in your media player. If you use
multiple players, you should repeat the steps in each program. Then try
sorting out the music folder info directly via Windows options only.

Also, album art is controlled by desktop.ini in the album folder and not by
thumbs.db. Here is a link to an article that explains how to rebuild the
desktop.ini files for music and picture folders:
http://support.microsoft.com/default.aspx?scid=kb;en-us;555077

Since there is an outside element of players updating album info, you may
also want to ask in those newsgroups about how to manage albums and how to
correct wrong info where the player is involved in maintaining info in one
of these folders. There is an index within Windows Media Player (WMP) but I
don't know much about it. However, the folks in the mediaplayer newsgroup
should be able to give you some helpful suggestions. A link for the web
interface for this newsgroup can be found under Windows Media on this web
page:
http://support.microsoft.com/newsgroups/default.aspx


--
Sharon F
MS-MVP ~ Windows Shell/User
Anonymous
September 5, 2005 12:09:02 AM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

"Sharon F" wrote:

> On Sun, 4 Sep 2005 10:32:01 -0700, Leland Bruns wrote:
> > First, deleting the thumbs.db files, as with the other fixes I've tried, has
> > no
> > effect on the problem. (Ditto, lots of reboots.)
> >
> > One example (since I have too many to list them all): I have 2 directories,
> > C:\...\MyMusic\Artist1\Album1 and C:\...\MyMusic\Artist2\Album2, both of
> > which were customized with folder type "Music Album" and a specific picture
> > from within the folder itself. However, at some point, opening Artist2 in
> > thumbnail mode shows Album2 with the picture from Album1. Correcting
> > the problem here at first appears to work. However, subsequently opening
> > Artist1 in thumbnail mode shows Album1 with the picture from Album2.
> > Correcting Album1 here once again changes the picture for Album2...I
> > can toggle back and forth all day! NOT something, I as a user should be
> > able to damage.
> >
> > Leland
>
> Thanks for the added info Leland. In the case of music folders you have
> Windows and your default media player poking fingers at it. Windows will
> follow your customizations (folder properties> Customize> Change Picture).
> However a media player can be configured to update album info (and album
> photo pics) from the internet.
>
> Try disabling the customizing features in your media player. If you use
> multiple players, you should repeat the steps in each program. Then try
> sorting out the music folder info directly via Windows options only.
>
> Also, album art is controlled by desktop.ini in the album folder and not by
> thumbs.db. Here is a link to an article that explains how to rebuild the
> desktop.ini files for music and picture folders:
> http://support.microsoft.com/default.aspx?scid=kb;en-us;555077
>
> Since there is an outside element of players updating album info, you may
> also want to ask in those newsgroups about how to manage albums and how to
> correct wrong info where the player is involved in maintaining info in one
> of these folders. There is an index within Windows Media Player (WMP) but I
> don't know much about it. However, the folks in the mediaplayer newsgroup
> should be able to give you some helpful suggestions. A link for the web
> interface for this newsgroup can be found under Windows Media on this web
> page:
> http://support.microsoft.com/newsgroups/default.aspx
>
>
> --
> Sharon F
> MS-MVP ~ Windows Shell/User
>

This is not a media player problem. I only reluctantly use Windows
Media Player 10 and it is NOT set to neither retrieve info automatically
from the internet nor automatically update music files.

Further, the example I quoted previously is only one of many clearly
related problems. Folder thumbnails all over the system (not just
music related) show the wrong pictures and types, and the columns
displayed for a given directory are frequently not what I set the last time
I visited the folder, just minutes ago. I just had a "documents" folder
containing nothing but JPEG images suddenly go to "music album" with
an image from a completely different disk drive. And yes, the problem
is not limited to disk C: but shows up on a 2nd drive D: as well (both
NTFS). Incorrect images, when they show up, appear to be from
either drive, from directories in which I've recently been making
updates.

More unbelievable, links to directories completely off this system
(including both Windows 98 SE and other XP systems) show icons
which are not related to the contents of the off-system directory, but
rather to something on the local system.

While the fixes in KB555077 might be relevant to the "My Whatever"
directories, I don't think they will resolve the myriad of other symptoms
I'm seeing. For fear of making a bad situation worse, until it's my last
resort I think I'll hold off on executing the "rundll32
mydocs.dll,PerUserInit"
command until it's my last resort!

35 years of experience as a software architect (Intel, et al) & consultant
tell me this IS a file system/explorer problem, whether it's a caching failure
or corruption, possibly a registry problem, or maybe even NTFS... I HAVE
scheduled disk checks for both C: and D: on my next reboot, but I'm
skeptical that this will prevent future symptoms, much less correct
what has already been damaged. While I've pretty much given up
thinking I'll find a KB article saying that "this is a bug and here's the fix
for your system!", I'd sure like to find a way to repair my corrupted file
system! Any suggestions, given my latest description of the problem,
will be welcome!

Leland
Anonymous
September 5, 2005 9:19:02 AM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

"Sharon F" wrote:

> On Sun, 4 Sep 2005 10:32:01 -0700, Leland Bruns wrote:
> > ...
> Thanks for the added info Leland. In the case of music folders you have
> Windows and your default media player poking fingers at it. Windows will
> follow your customizations (folder properties> Customize> Change Picture).
> However a media player can be configured to update album info (and album
> photo pics) from the internet.
>
> Try disabling the customizing features in your media player. If you use
> multiple players, you should repeat the steps in each program. Then try
> sorting out the music folder info directly via Windows options only.
>
> Also, album art is controlled by desktop.ini in the album folder and not by
> thumbs.db. Here is a link to an article that explains how to rebuild the
> desktop.ini files for music and picture folders:
> http://support.microsoft.com/default.aspx?scid=kb;en-us;555077
>
> Since there is an outside element of players updating album info, you may
> also want to ask in those newsgroups about how to manage albums and how to
> correct wrong info where the player is involved in maintaining info in one
> of these folders. There is an index within Windows Media Player (WMP) but I
> don't know much about it. However, the folks in the mediaplayer newsgroup
> should be able to give you some helpful suggestions. A link for the web
> interface for this newsgroup can be found under Windows Media on this web
> page:
> http://support.microsoft.com/newsgroups/default.aspx
>
>
> --
> Sharon F
> MS-MVP ~ Windows Shell/User
>

Sorry, sloppy text editing (I can't work in these little boxes!)
resulted in several typos on my part in my last; corrections:

|This is not a media player problem. I only reluctantly use Windows
|Media Player 10 and it is set to neither retrieve info automatically
|from the internet nor automatically update music files.
|...
|For fear of making a bad situation worse, I think I'll hold off on
|executing the "rundll32 mydocs.dll,PerUserInit" command until it's
|my last resort!

More input:
Disk checks on both drives on this system showed only the following
types of errors...
Cleaning up minor inconsistencies on the drive.
Cleaning up 932 unused index entries from index $SII of file 0x9.
Cleaning up 932 unused index entries from index $SDH of file 0x9.
Cleaning up 932 unused security descriptors.
CHKDSK discovered free space marked as allocated in the
master file table (MFT) bitmap.
Windows has made corrections to the file system.
The corrections did not resolve any of the problems.

Examining the registry, I have been able to determine that there
must be some corruption to the hashing mechanism for the "bags"
in "HKCU\Software\Microsoft\Windows\ShellNoRoam\Bags\...". If
I change the picture associated with one directory to a uniquely
named JPEG file, it shows up in a single bag. However, that
image shows up in the thumbnail view of at least 2 directories,
even tho there's only a single reference to it in the registry.
Changing the image to a brand new JPEG (thus previously not in
the registry) in one of the 2 directories results in that image
appearing in both directories' thumbnail views...tho only in a
single bag. Thus, it would appear that both directories are
hashing to that same "bag". And further examination of the
registry shows that directories to which I've never made any
customizations (in Shared Documents for example) must be
hashing back to other directories (in My Documents or on
disk D:)  that I've modified since whatever event damaged
the hashing mechanism.

So my desire at this time would be a safe way to correct the
hash tables. It would seem unlikely that there is any way
to do that without loosing all the entries that are correct...
I'm resolved now to having to repair everything. Is there some
published procedure to clear the "bag" cache AND it's hash table?
That is, some procedure short of my manually deleting the Bags
entries AND whatever is pointing to them? Searches of the
MS Knowledge Base and in general on the internet so far have
turned up nothing. Too many hits on the keywords I can think
of to use, and nothing really relevant to the situation at hand.

But I can't be the only one with this problem! If this is a system
bug or the result of damage to the registry due to a system crash,
then everyone using XP must be vulnerable to the problem.

Leland
Anonymous
September 5, 2005 1:22:01 PM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

On Mon, 5 Sep 2005 05:19:02 -0700, Leland Bruns wrote:

> "Sharon F" wrote:
>
>> [32 quoted lines suppressed]
>
> Sorry, sloppy text editing (I can't work in these little boxes!)
> resulted in several typos on my part in my last; corrections:
>
>> [7 quoted lines suppressed]
>
> More input:
> Disk checks on both drives on this system showed only the following
> types of errors...
> Cleaning up minor inconsistencies on the drive.
> Cleaning up 932 unused index entries from index $SII of file 0x9.
> Cleaning up 932 unused index entries from index $SDH of file 0x9.
> Cleaning up 932 unused security descriptors.
> CHKDSK discovered free space marked as allocated in the
> master file table (MFT) bitmap.
> Windows has made corrections to the file system.
> The corrections did not resolve any of the problems.
>
> Examining the registry, I have been able to determine that there
> must be some corruption to the hashing mechanism for the "bags"
> in "HKCU\Software\Microsoft\Windows\ShellNoRoam\Bags\...". If
> I change the picture associated with one directory to a uniquely
> named JPEG file, it shows up in a single bag. However, that
> image shows up in the thumbnail view of at least 2 directories,
> even tho there's only a single reference to it in the registry.
> Changing the image to a brand new JPEG (thus previously not in
> the registry) in one of the 2 directories results in that image
> appearing in both directories' thumbnail views...tho only in a
> single bag. Thus, it would appear that both directories are
> hashing to that same "bag". And further examination of the
> registry shows that directories to which I've never made any
> customizations (in Shared Documents for example) must be
> hashing back to other directories (in My Documents or on
> disk D:)  that I've modified since whatever event damaged
> the hashing mechanism.
>
> So my desire at this time would be a safe way to correct the
> hash tables. It would seem unlikely that there is any way
> to do that without loosing all the entries that are correct...
> I'm resolved now to having to repair everything. Is there some
> published procedure to clear the "bag" cache AND it's hash table?
> That is, some procedure short of my manually deleting the Bags
> entries AND whatever is pointing to them? Searches of the
> MS Knowledge Base and in general on the internet so far have
> turned up nothing. Too many hits on the keywords I can think
> of to use, and nothing really relevant to the situation at hand.
>
> But I can't be the only one with this problem! If this is a system
> bug or the result of damage to the registry due to a system crash,
> then everyone using XP must be vulnerable to the problem.
>
> Leland

Some of the Bags keys can be safely deleted and they will rebuild. Am
sending you a link to a page on MVP Kelly Theriot's site. Scroll down to
the "Folders" topics. Plenty of info there about resetting to standard and
about customizing.
http://www.kellys-korner-xp.com/xp_f.htm

And another good reference:
http://windowsxp.mvps.org/folderviews.htm

--
Sharon F
MS-MVP ~ Windows Shell/User
Anonymous
September 8, 2005 12:39:08 PM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

"Sharon F" wrote:

> On Mon, 5 Sep 2005 05:19:02 -0700, Leland Bruns wrote:
>
> > "Sharon F" wrote:
> >
> >> [32 quoted lines suppressed]
> >
> > Sorry, sloppy text editing (I can't work in these little boxes!)
> > resulted in several typos on my part in my last; corrections:
> >
> >> [7 quoted lines suppressed]
> >
> > More input:
> > ...
> >
> > So my desire at this time would be a safe way to correct the
> > hash tables. It would seem unlikely that there is any way
> > to do that without loosing all the entries that are correct...
> > I'm resolved now to having to repair everything. Is there some
> > published procedure to clear the "bag" cache AND it's hash table?
> > That is, some procedure short of my manually deleting the Bags
> > entries AND whatever is pointing to them? Searches of the
> > MS Knowledge Base and in general on the internet so far have
> > turned up nothing. Too many hits on the keywords I can think
> > of to use, and nothing really relevant to the situation at hand.
> >
> > But I can't be the only one with this problem! If this is a system
> > bug or the result of damage to the registry due to a system crash,
> > then everyone using XP must be vulnerable to the problem.
> >
> > Leland
>
> Some of the Bags keys can be safely deleted and they will rebuild. Am
> sending you a link to a page on MVP Kelly Theriot's site. Scroll down to
> the "Folders" topics. Plenty of info there about resetting to standard and
> about customizing.
> http://www.kellys-korner-xp.com/xp_f.htm
>
> And another good reference:
> http://windowsxp.mvps.org/folderviews.htm
>
> --
> Sharon F
> MS-MVP ~ Windows Shell/User
>

An update, just FYI...

Per your suggestion, I checked out Kelly's site...except for an
assertion implying that deleting the bag cache in the registry was
safe, nothing new there that I hadn't known or already found in
my searches.

This AM, I did a system checkpoint, exported the bag entries from
HKCU in the registry, deleted them, then did a clean reboot.

Upon restart, it did appear as if the problem directories (indeed
all of my directories) had been reset to vanilla folders, with no
preferences other than the defaults.

At which time I proceeded to begin restoring my preferences and
images, using a breadth-first approach across a large directory
tree so I'd be sure of which directories I'd touched. Doing
absolutely nothing else but opening directories and changing
preferences, for about 2 hours this went OK.

However, I started noticing directories I had not yet opened or
modified were showing up with folder preferences randomly set.
I quickly discovered that once again I have pairs of directories
whose folder properties are linked, ie, changing the folder
preferences on one changes the other too. Same old same old.

Well...clearly a Windows bug. Regardless of cache size issues
(which can always be exceeded), the system nevertheless should
"degrade gracefully" when it can't keep everything straight.
This is not graceful!

Having no expectation of Microsoft acknowledging and/or fixing
the problem in a timely fashion, and in the absence of any further
suggestions, I appear to be left with only one way to proceed:
clear the registry bag entries once again and forget about using
folder preferences. Nice idea in concept, poor implementation.
Can you trust an OS at all if you can't trust the file system?

Leland
!