Sign in with
Sign up | Sign in
Your question

Why does the Automatic Updates service change the start type on the Ba

Last response: in Windows XP
Share
January 31, 2011 2:17:57 PM

Hello,

Why does the Automatic Updates service change the start type on the Background Intelligent Transfer service from Manual to Automatic?

Is this a new feature or a bug? It does it on some of my computers, but not others. I can see the start type change as soon as Microsoft Security Essentials starts its update. I don't want BITS running every time I start my computer. So I have to manually go and change BITS back to manual start.
:( 
January 31, 2011 10:37:16 PM

Updates will cause all kinds of surprises. The best way to deal with updates is not to use them.
m
0
l
January 31, 2011 10:52:48 PM

soundguruman said:
Updates will cause all kinds of surprises. The best way to deal with updates is not to use them.



So true... But the updates I am getting are updates to the virus data base that Microsoft Security Essentials uses. So I like to keep pretty up to date with those.
m
0
l
Related resources
Can't find your answer ? Ask !
February 1, 2011 1:27:30 PM

MSE requires BITS to get it's updates.

From Wiki:

Background Intelligent Transfer Service (BITS) is a component of modern Microsoft Windows operating systems that facilitates prioritized, throttled, and asynchronous transfer of files between machines using idle network bandwidth. It is most commonly used by recent versions of Windows Update, Microsoft Update, Windows Server Update Services, and Systems Management Server to deliver software updates to clients, Microsoft's anti-virus scanner Microsoft Security Essentials to fetch signature updates, and is also used by Microsoft's instant messaging products to transfer files
m
0
l
February 1, 2011 1:30:58 PM

That is true, but it doesn't mean that the BITS service has to be running all the time. "Manual" start is perfectly acceptable and means that programs will start it when they need it.

As a matter of interest, on my Windows 7 installation BITS is set to "Manual" start and updates have never changed it. Must be an XP bug.
m
0
l
February 1, 2011 2:29:56 PM

BITS defaults to automatic in XP home and XP Pro. XP Pro with SP2 or above defaults to manual. It doesn't use that much memory. Just leave it as is so that updates will continue normally.
m
0
l
February 1, 2011 2:31:45 PM

Ijack said:
That is true, but it doesn't mean that the BITS service has to be running all the time. "Manual" start is perfectly acceptable and means that programs will start it when they need it.

As a matter of interest, on my Windows 7 installation BITS is set to "Manual" start and updates have never changed it. Must be an XP bug.



Yes, I agree... I can even watch "Automatic Updates" change BITS from "Manual" to "Automatic" start. As soon as I tell Microsoft Security Essentials to update its security files, Automatic Updates starts up, then BITS gets changed from Manual start to Automatic start and starts up. On my other computer, both start up, but it does not change the start option.

Starting when needed is fine. But I don't want to have BITS running even when it is not needed. So I want to have the start option to stay at Manual.
m
0
l
February 1, 2011 2:36:44 PM

Hawkeye22 said:
BITS defaults to automatic in XP home and XP Pro. XP Pro with SP2 or above defaults to manual. It doesn't use that much memory. Just leave it as is so that updates will continue normally.


Sorry, I do not want to leave it at Automatic. I only have 384 MB of memory on this computer and every bit is precious. The computer is at its max supported memory, so adding is not a option. I don't mind BITS using memory when it is being used. But I do not want to have it running and using memory when it is not needed. I set the start option to Manual, but something keeps changing it to Automatic.
m
0
l
February 1, 2011 2:39:00 PM

You can always create a batch/command script and fire it off with a scheduled task.

All you need in the batch file is:

  1. sc config BITS start = manual
  2. sc stop BITS


This will set the service to manual and stop it if it's running.
m
0
l
February 1, 2011 2:58:56 PM

Hawkeye22 said:
You can always create a batch/command script and fire it off with a scheduled task.

All you need in the batch file is:

  1. sc config BITS start = manual
  2. sc stop BITS


This will set the service to manual and stop it if it's running.


Thanks, that's a good work around... I think I tried something like that before and it would not run. If I remember correctly, it said I had to be an administrator to run those commands. As a security measure, I only run as an administrator when I want to install something. 99% of the time, I run as a Limited user. I feel it gives me a little extra measure of security. But I might have to do something like that as a work around. I guess I was hoping it was a bug and I could fix it another way. I have XP prof SP3.
m
0
l
February 1, 2011 3:11:01 PM

Hawkeye22 said:
You can always create a batch/command script and fire it off with a scheduled task.

All you need in the batch file is:

  1. sc config BITS start = manual
  2. sc stop BITS


This will set the service to manual and stop it if it's running.


I gave it a quick try... Yep, you have to be an administrator.
It would be nice if I could just find a way to get it to stop
changing it in the first place. Thanks.



------------------------------------------------------------------------------------

C:\>ver

Microsoft Windows XP [Version 5.1.2600]

C:\>sc config BITS start= demand
[SC] OpenService FAILED 5:

Access is denied.
m
0
l
February 1, 2011 3:31:06 PM

When you make an entry in scheduled tasks, you can set it to "run as" a different user. Set the scheduled task to run as administrator.
m
0
l
February 1, 2011 3:37:57 PM

Hawkeye22 said:
When you make an entry in scheduled tasks, you can set it to "run as" a different user. Set the scheduled task to run as administrator.



Thanks ... That will make it easier...
m
0
l
!