Sign in with
Sign up | Sign in
Your question

X86 os instability with 4gb ram

Last response: in Memory
Share
December 22, 2008 6:05:17 AM

I have an Asus M2N68 with Athlon x2 Brisbane 4400+ and i cannot get any x86 os to work when i install my 2x2gb Geil kit. Windows xp will randomly freeze and vista won't even load. If i remove one memory then the pc runs fine. I searched a few solutions but nothing seemed to work. KB929777 did nothing, i underclocked the ram step by step till i got to 400MHz, i do have memory remapping enabled, I tested both memory modules with memtest - they're both good. Can you please give me any other ideas i could try? I know its possible to run x86 os with 4gb ram (though it won't use all of it) and
I just feel that I'm missing something...
December 22, 2008 6:18:38 AM

check the voltage and speed of the ram sticks and compare them to what the bios has. Try relaxing the timings or uppinng the memory voltage.
a b } Memory
December 22, 2008 6:32:08 AM

Does it matter which of the memory sticks you remove? Or are you always removing the same RAM stick?
Related resources
December 22, 2008 7:26:31 AM

Helped someone with a similar problem just the other day, he had an AMD 690G chipset and was getting video corruption.

He solved his problem by updating his bios.

http://www.tomshardware.com/forum/255296-30-memory-prob...

*Make sure your using the latest bios.*

Make sure you have the latest drivers for everything especially video drivers and nforce drivers.

Make sure you manually set the voltages and timings correctly.

Is the speed of your memory supposed to be DDR2 1066? And you said you underclocked it to DDR2 800? And it still didn't work?
December 22, 2008 8:29:23 AM

Thank you for the quick reply.

I have already tried altering the memory clocks. The memory modules are geil legacy 5 5 5 15 at 800 mhz. They are not supposed nor did I try to run them at 1066, i know that causes issues. What I meant is that I took them down to 667 - 533 - 400 MHz and also I tried with 5 5 5 18 and 6 6 6 18. Nothing worked. I didn't try to flash the bios yet (my fdd broke, buying a new one today), it will be the next thing I'll try. However, the later bios versions available on asus.com have comments saying they support new cpu's, nothing about fixing memory issues.
December 22, 2008 9:17:50 AM

I'm betting you can solve this by updating your bios. The comments don't usually describe all of the fixes. You dont need a floppy drive, a USB flash drive will do the trick, EZ Flash 2 is build into your bios:

http://vip.asus.com/forum/view.aspx?id=2007021522310966...

(In fact don't use a floppy drive, they seem to be very prone to errors, EZ Flash 2 is the way to go)
December 23, 2008 5:16:07 AM

I updated the bios but it still doesn't work. It just turned the freeze that I was getting when vista was trying to start into a bsod 0x0000000a irql not less or equal.
December 23, 2008 2:32:36 PM

I got that error on vista with 4GB before i installed SP1. I had to install vista and SP1 with only 2GB of memory :-/ . Have you installed SP1? Did you reset the bios settings to default after updating the bios?
!