Sign in with
Sign up | Sign in
Your question

Poor SSD performance with AHCI, and a note on the 80 MBps ICH9 limit

Last response: in Motherboards
Share
December 24, 2008 8:49:33 AM

I'm running into a strange issue with a GA-P35-DS3L (rev 1.0) and an Imation / Mtron Pro 7000 64GB SSD when AHCI is enabled in the BIOS.

Without AHCI, the drive gets about 80 MBps (sometimes more, see discussion below). With AHCI it's cripped to 4 MBps in every environment I tested! The buffered read is just as quick and the verified transfer is about 70 MBps but both read and write are capped at 4 MBps. I updated the drive's firmware to 0.019R1 and the motherboard's BIOS to F9B and tried a couple of older BIOSes. None of them have an effect, and none update the Intel iSrc AHCI BIOS which is stuck in 2006 with version 1.07.

I also tried the latest chipset drivers for Vista but as expected these don't change a thing. It's a deeper problem almost certainly on the level of the AHCI BIOS. I'm posting to document the issue and solicit others' experiences.

Now on to the really interesting part for those of you that follow SSD's. Several hardware sites (Benchmark Reviews, AnandTech) have stated that Intel's ICH9 south bridge is capping sustained transfers at 80 MBps. My troubleshooting over the last few hours has led to some findings that show that this is incorrect. The 80 MBps limit exists, but only when the OS puts it there!

If I boot UBCD and use the System Benchmark Tool to look at the hard drives I get a full 100 MBps (with AHCI disabled, of course). It's when I get into Vista that the 80 MBps limit shows up, so it's not inherent in the ICH9 but in the Intel chipset drivers. The latest drivers do not address the issue.
December 24, 2008 10:55:22 AM

Is that drive a SLC SSD or MLC?
December 24, 2008 2:54:07 PM

SLC

Also, with AHCI enabled its access time jumps from 0.1 to 0.65
!