Sign in with
Sign up | Sign in
Your question

Users cannot see User Name's Documents in My Computer

Last response: in Windows XP
Share
Anonymous
September 4, 2005 6:55:02 PM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

As we all know in "My Computer" there is an area called "Files Stored on This
Computer" which should show each user two folders. "Shared Documents" and
"User Name's" Documents" obviously with <User Name> replaced by the person's
username.

If you are the Administorator you see these two folders.
If you are User with Administrator privelages you see these two folders.
If you are User with User privelages (even Power User) you only see Shared
Documents.

An aside. At some point "Shared Documents" renamed it self to Documents. I
could not figure out how to fix this besides pointing the registry setting to
a new folder which I created as a reparse point (i.e. I created c:\documents
and settings\all users\Shared Documents which pointed to the Documents
folder). I mention this if it helps anyone with solutions.
Anonymous
September 4, 2005 9:21:47 PM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

%ALLUSERSPROFILE%\Documents
or
C:\Documents and Settings\All Users\Documents

is the Shared Documents folder. It gets its name from the desktop.ini
file.

The desktop.ini file may be missing or messed up.

Detailed instructions here on how to fix or create a desktop.ini file for
the Shared Documents folder...
http://computers.douglasthrift.net/winxpfaq.html#faq3

-----

See the WORKAROUND here...
Shared Documents Folders Are Missing From My Computer
http://support.microsoft.com/default.aspx?scid=kb;en-us;319825

The My Computer Icon Displays the My Documents Folders of Another User
http://support.microsoft.com/default.aspx?scid=kb;en-us;286727

My Documents folder missing in My Computer
http://www.tweakxp.com/article139980.aspx

--
Hope this helps. Let us know.

Wes
MS-MVP Windows Shell/User

In news:4799B793-080D-4EF7-8628-EF36563B13A9@microsoft.com,
HODHOUTEX <HODHOUTEX@discussions.microsoft.com> hunted and pecked:
> As we all know in "My Computer" there is an area called "Files Stored on
> This Computer" which should show each user two folders. "Shared
> Documents" and "User Name's" Documents" obviously with <User Name>
> replaced by the person's username.
>
> If you are the Administorator you see these two folders.
> If you are User with Administrator privelages you see these two folders.
> If you are User with User privelages (even Power User) you only see Shared
> Documents.
>
> An aside. At some point "Shared Documents" renamed it self to Documents.
> I could not figure out how to fix this besides pointing the registry
> setting to a new folder which I created as a reparse point (i.e. I
> created c:\documents and settings\all users\Shared Documents which
> pointed to the Documents folder). I mention this if it helps anyone with
> solutions.
Anonymous
September 5, 2005 2:49:07 PM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

The registry key at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\
CurrentVersion\Explorer\DocFolderPaths contains the user names (and contains
the correct location of folders. - The administrator's account, and the
three users.

Could it have anything to do with permissions on this key?


"Wesley Vogel" wrote:
....
> See this for a fix to add logged on User's docs folder.
>
> My Documents folder missing in My Computer
> http://www.tweakxp.com/article36827.aspx
> --
> Hope this helps. Let us know.
>
> Wes
> MS-MVP Windows Shell/User
Related resources
Anonymous
September 5, 2005 6:31:09 PM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

On Mon, 5 Sep 2005 10:49:07 -0700, HODHOUTEX wrote:

> The registry key at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\
> CurrentVersion\Explorer\DocFolderPaths contains the user names (and contains
> the correct location of folders. - The administrator's account, and the
> three users.
>
> Could it have anything to do with permissions on this key?

Do you have TweakUI for XP installed? There is a setting in that program
(in the My Computer section) to show/hide "files stored on this computer.

If not installed, you might consider installing it. Uncheck the box to
remove the display of these items. Then check it to restore them. Often
this little dance of turning settings off/on will restore whatever's
missing the registry.

TweakUI for XP is one of the power toys that can be found here:
http://www.microsoft.com/windowsxp/downloads/powertoys/...

--
Sharon F
MS-MVP ~ Windows Shell/User
Anonymous
September 6, 2005 12:30:10 AM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

TweakUI
[+] My Computer | Files stored on this computer |

With this UNCecked you see no Files stored on this computer in My Computer.
With this Checked you see Files stored on this computer in My Computer.

TweakUI changes this key.

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\
Policies\Explorer
Value Name: NoSharedDocuments
Value Type: REG_BINARY
Value Data: 0x00 or 0x01
0x00 = Files stored on this computer is displayed in My Computer.
0x01 = You do not see Files stored on this computer displayed in My
Computer.

--
Hope this helps. Let us know.

Wes
MS-MVP Windows Shell/User

In news:ecSJ%23AlsFHA.2348@tk2msftngp13.phx.gbl,
Sharon F <sharonfDEL@ETEmvps.org> hunted and pecked:
> On Mon, 5 Sep 2005 10:49:07 -0700, HODHOUTEX wrote:
>
>> The registry key at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\
>> CurrentVersion\Explorer\DocFolderPaths contains the user names (and
>> contains the correct location of folders. - The administrator's
>> account, and the three users.
>>
>> Could it have anything to do with permissions on this key?
>
> Do you have TweakUI for XP installed? There is a setting in that program
> (in the My Computer section) to show/hide "files stored on this computer.
>
> If not installed, you might consider installing it. Uncheck the box to
> remove the display of these items. Then check it to restore them. Often
> this little dance of turning settings off/on will restore whatever's
> missing the registry.
>
> TweakUI for XP is one of the power toys that can be found here:
> http://www.microsoft.com/windowsxp/downloads/powertoys/...
>
> --
> Sharon F
> MS-MVP ~ Windows Shell/User
Anonymous
September 6, 2005 2:50:01 AM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

That did not work. I find it very intriguing. All the usual stuff does not
help this problem. I have no idea what happened.

"Sharon F" wrote:

> On Mon, 5 Sep 2005 10:49:07 -0700, HODHOUTEX wrote:
>
> > The registry key at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\
> > CurrentVersion\Explorer\DocFolderPaths contains the user names (and contains
> > the correct location of folders. - The administrator's account, and the
> > three users.
> >
> > Could it have anything to do with permissions on this key?
>
> Do you have TweakUI for XP installed? There is a setting in that program
> (in the My Computer section) to show/hide "files stored on this computer.
>
> If not installed, you might consider installing it. Uncheck the box to
> remove the display of these items. Then check it to restore them. Often
> this little dance of turning settings off/on will restore whatever's
> missing the registry.
>
> TweakUI for XP is one of the power toys that can be found here:
> http://www.microsoft.com/windowsxp/downloads/powertoys/...
>
> --
> Sharon F
> MS-MVP ~ Windows Shell/User
>
Anonymous
September 6, 2005 3:38:38 PM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

I am the only user on my machine and I am an Administrator.

Look at these settings.

1. Right click a user's My Documents folder (on Desktop or in Windows
Explorer).
2. If Use simple file sharing (Recommended) is enabled in Folder Options,
click Sharing tab.
3. Is Make this folder private selected?

Make this folder private
[[Specifies that only you can access the folder. When you make a folder
private, you also make all the files and subfolders it contains private.
This option is only available for your folders in your user profile (My
Documents and its subfolders, Desktop, Start Menu, and Favorites). If you
want to make a file in a private folder available to other users, you can
move the file to the Shared Documents, Shared Pictures, or Shared Music
folders.]]

2. If Use simple file sharing (Recommended) is disabled in Folder Options,
click Sharing tab
3. Is Do not share this folder selected?

--
Hope this helps. Let us know.

Wes
MS-MVP Windows Shell/User

In news:A96F620A-DE22-4500-83CB-3CBB8F03E870@microsoft.com,
HODHOUTEX <HODHOUTEX@discussions.microsoft.com> hunted and pecked:
> That did not work. I find it very intriguing. All the usual stuff does
> not help this problem. I have no idea what happened.
>
> "Sharon F" wrote:
>
>> On Mon, 5 Sep 2005 10:49:07 -0700, HODHOUTEX wrote:
>>
>>> The registry key at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\
>>> CurrentVersion\Explorer\DocFolderPaths contains the user names (and
>>> contains the correct location of folders. - The administrator's
>>> account, and the three users.
>>>
>>> Could it have anything to do with permissions on this key?
>>
>> Do you have TweakUI for XP installed? There is a setting in that program
>> (in the My Computer section) to show/hide "files stored on this computer.
>>
>> If not installed, you might consider installing it. Uncheck the box to
>> remove the display of these items. Then check it to restore them. Often
>> this little dance of turning settings off/on will restore whatever's
>> missing the registry.
>>
>> TweakUI for XP is one of the power toys that can be found here:
>> http://www.microsoft.com/windowsxp/downloads/powertoys/...
>>
>> --
>> Sharon F
>> MS-MVP ~ Windows Shell/User
!