Sign in with
Sign up | Sign in
Your question

WD Caviar Black not recognized

Last response: in Storage
Share
February 4, 2010 4:14:42 PM

Hello,
I'm hoping one of the board gurus can help me. I recently purchased a WD Caviar Black 1TB SATA-II HD to install into my 6 year old computer which has an onboard SATA controller (VIA VT8237). After connecting everything, the drive wasn't recognized, even during the bios bootup. I set the jumper on the Caviar Black to force it to 1.5, but to no avail.

So I bought a PCI to SATAII controller expansion card, and when XP booted I seemingly properly installed the appropriate drivers. Again, no drive is recognized.

When the new PCI controller BIOS boots, a message appears so "no valid drive" and if I go into the BIOS menu again I get an error that "not enough single drives"

So I have a new disk that neither my onboard SATA controller nor my new PCI SATA-II controller seems to recognize.

I've tried different SATA cables, and that's been no help. I've also swapped power cables to the drive and that doesn't work. So no I'm thinking I either f-ed something up or my new drive is broken.

Can anyone help me? Thanks!
February 4, 2010 6:18:02 PM

Try and connect the drive with a different Pc , not necessarily newer than your's ! . Oh yes , some bios have options like , On chip sata mode enable , Combined mode :-PATA AND SATA , Enhanced Mode - Enable both sata and Pata , and Auto selection . I think on chip Sata mode mite be disabled. Have a check . Hope it works .
m
0
l
February 4, 2010 6:34:10 PM

Try another PC. If it still doesn't work you got a dead drive.
m
0
l
Anonymous
a b G Storage
March 2, 2010 2:46:10 AM

megamanx00 said:
Try another PC. If it still doesn't work you got a dead drive.


As Lee Corso (if you watch College Gameday in US) would say, "Not so fast!"

I have been having this exact same problem. In fact, I have been working on it ALL DAY. :( 

After some initial googling, I finally called WD, their "advanced" tech told me to update my motherboard BIOS. I didn't want to go to that extreme unless absolutely necessary, so I kept looking around.

Turns out that this may be a problem with this particular southbridge / SATA controller chipset (the VT8237) supporting newer SATA II (300 Gbps) drives, particularly ones >= 1TB. Like you, I put this computer together years ago and at that time SATA was relatively new. According to one of the moderators at the MSI (my motherboard manufacturer, I'm guessing yours too) forums, the problem may be in the chipset itself, and updating the BIOS will NOT fix that (see link):

http://forum-en.msi.com/index.php?topic=135591.msg10211...

After much googling and reading today, that forum (and here) are where I have followed the trail thus far. So I have posted in that thread (same name as here if you want to follow along). I have also lodged a support request with MSI directly, although I just did that so no response yet.

I haven't got this thing figured out yet, but when I do I will report back here and would appreciate if you did the same.

BTW, I'm glad to know (well sorry to hear it, but it helps me ;)  ) that installing the PCI based SATA controller seems not to work either as that was going to have to be my next step if in fact this drive is incompatible with my mobo. Although that seems to not make a lot of sense, I dunno why a different PCI SATA controller (with it's own chipset) wouldn't work with your drive. Maybe your drive is DOA after all, I dunno but those are pretty rare I would think.

Did you have it shipped to you FedEx or UPS? I ordered mine via NewEgg and read someones comment suggesting using FedEx (+$13) instead of the free shipping that comes by default. Forget his exact number, but said something along the lines of he has installed about 20+ of these drives and after a year or two, 80% of the ones he shipped via UPS were still in operation, while 100% of the FedEx shipped ones were still in operation. He also said that on UPS website they state that "packages may be dropped from a height of as much as 6 feet" or somesuch. Made sense to me, so I paid the extra $13. Just another thought...
m
0
l
!