Sign in with
Sign up | Sign in
Your question
Solved

Incredibly Frustrating RAM Problem

Last response: in Overclocking
Share
November 28, 2009 6:26:19 PM

Hey guys, I currently have an Acer E380 that i've upgraded over the years, right now the specifications are:

AMD Athlon 64 X2 6000+ 3.0ghz
A-Data 4 Gigs of ram (PC5300) --> Mushkin 2 gigs of ram (PC6400)
Asus 9800GT Hybridpower
EM61SM/EM61PM Stock Acer Motherboard
Bios: Phoenix Technologies Version: R01-C0 Date: 2007

It seems that I have an issue on my hands. Went out and bought 2 1gig sticks of Mushkin 800mhz, and CPU-Z only reads as 400mhz (DRAM Frequency reading about 200mhz so x2 = 400mhz). Which is terribly frustrating. I even did a bios update (R01-C0), in which I am thanking lady luck that it succeeded updating my bios, however still did not fix my RAM frequencies. My motherboard does support PC6400 RAM. So I don't think this is the problem.

The problem here, I think that my DRAM divider is way too high, I believe at CPU/15. CPU being 3100mhz/15 = 200mhz, this is my DRAM frequency right now. However, I don't understand why it is the divider is that high, as I have been researching, a RAM divider of 8 is what it is suppose to be for my processor.

When I first bought my prebuilt ACER (first mistake, I know), the DRAM frequency was at 333mhz, an an effective clock of 667mhz, this was correct. Then, I think the whole problem started happening when I upgraded my CPU from AMD 64 X2 4200+ to AMD Athlon 64 X2 6000+ (not knowing about my DRAM frequencies at the time). Then after I upgraded my CPU, I switched out my old 2 sticks of 667 RAM for 4 sticks of 667 RAM. One day I just checked CPU-Z and was like "This is not right", since it was showing 200mhz rather than 333mhz for DRAM frequency.

I ignored it for a time, but now it is getting on my nerves. And here we are now.

What I don't understand is I did not even touch any settings in BIOS before or post upgrade to the AMD 6000+. My BIOS doesn't even show my RAM timings nor any options to deal with my RAM clock or anything to deal with overclocking so I don't know how this problem arised. So now I am back to square 1, trying to figure out how to fix this problem.

Currently my RAM Timings is as follows:

200 Mhz (400mhz effective clock)
CPU/15
CAS Latency: 4
RAS to CAS : 3
RAS Precharge: 3
Cycle Time: 9
Bank Cycle TIme: 12
Command Rate (CR): 2T

-------------------------

UPDATE:

So after a year of searching for this fix, I have fixed this issue with a modded bios.
http://www.bios-mods.com/showthread.php?tid=170&page=3
This changed my RAM divider back to 8
Also, it even allows me to overclock my CPU.

If anybody else has this problem, and they have the same motherboard and same computer as me. Try this out.

Be warned that it is not guaranteed to work and may stop your computer from working.

However, it was worth it for me.

New RAM timings is as follows:

389.3 Mhz
CPU/8
CL: 5
tRCD: 5
tRP: 5
tRAS: 18
tRC: 24
Command Rate: 2T

Best solution

November 29, 2009 12:32:27 AM
Share

Take out the Mushkin and look at your clocks and then take out your stock ram and look at your timings, the timings should jump up to the level of the mushkin when you take out the stock but the motherboards downclock the ram to the lowest level in the system
November 29, 2009 12:46:36 AM

that I understand, however, I am not putting int he two ram together. I am just saying that stock RAM (suppose to be at DRAM: 337) separately is at DRAM 200mhz, and the Mushkin (suppose to be at 400 mhz) is also at 200mhz. I did not mix and match RAM, it was either the Mushkin in my system or my AData.
Related resources
November 29, 2009 12:55:43 AM

hm, does your mobo support ddr2, or is that just ddr
November 29, 2009 1:00:22 AM

No they are all DDR2, i'm just telling you the DRAM frequencies.

The ADATA Ram which was 667 was showing up as 400mhz RAM
The Mushkin Ram which was 800mhz was also showing up as 400mhz RAM

But it is alright now, as I fixed it with a bios flash.
November 29, 2009 2:23:27 AM

oh ok
!