Sign in with
Sign up | Sign in
Your question

MSE v2 and 0x8004FF04 install/upgrade error on WinXP FLP

Last response: in Windows XP
Share
February 6, 2011 4:01:08 AM

Strange thing about this:

Version 1 of Microsoft Security Essentials (the one with the blue background) installs just fine on Windows For Legacy PCs. I mean, why wouldn’t it -- WinFLP is EXACTLY like Windows XP just with a few programs missing (MS Paint, games, OE, WMP, etc.).

However, when trying to upgrade MSE v1 to v2 (the one with the grey background and the white curved grid on the right), I get an "incompatible OS" error, with the 0x8004FF04 error.

Same thing happens when I try to upgrade a current installation of v1 to v2 via Windows Update or its own internal upgrade tool.

So, WTF -- what in Windows is MSE v2 using to disqualify WinFLP, and how can I get MSE v2 to install?

On the other hand, it appears that MSE v2 is much more forgiving in its 64-bit variants, as I have suddenly been able to install it on XP 64-bit and Windows Server 2008 R2 without ANY ill effects at all.
February 7, 2011 9:01:58 PM

did you try to install it with all security and firewall shut off?
m
0
l
February 7, 2011 10:04:55 PM

Yes. No dice. I would have tried safe mode, but it depends on the windows installer (it doesn’t use its own).

I really do suspect that it checks a specific sub-version entry for Windows (Registry?), and refuses because it isn’t “pure” XP SP3

I should also point out that the same thing happens when MSEv2 is installed on a fresh install of WinFLP. Aside from a few MS extras (C++ 2008 redistributable, DotNet, etc.) there is nothing extra on the system. And yet, it fails where v1 installed just fine.
m
0
l
August 17, 2011 7:07:18 PM

MSE detects WinFLP as Embedded NT through the following registry value:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control

Key: ProductOptions
Type: REG_MULTI_SZ

In Windows XP, the value of this key is "Personal" for Home version and "EmbeddedNT" for Windows Fundamentals.

To install MSE v2 you need to change this value to "Personal" or leave it empty (that means "Windows XP Professional").

Note the value ProductOptions is protected and monitored, so, when you try to change it, a Message is displayed telling that any change on this key is a license violation.

To bypass this, you can look for the ControlSet Keys. They are together with CurrentControlSet and have numbers (i.e. ControlSet001, ControlSet003, etc.).

Acess the ControlSet with the highest number (in the case of ControlSet001, ControlSet002 and ControlSet003, you need to access ControlSet003) and navigate to "Control" key. Change "ProductOptions" according your needs and reboot Windows.

Before OS starts to load, press F8 and choose "Last Know Good Configuration" on the menu.

After system starts, you can install MSE.

If MSE tell that your key is invalid, read this: http://www.zhacks.com/2010/03/18/install-microsoft-secu...

Good Luck
m
0
l
April 18, 2014 12:59:56 PM

Ilanio, the problem with this solution is that once you make that registry change, the system is no longer Windows XP FLP, and the license key gets rejected. Plus, when I tried to do this in a VM (I wasn’t going to risk my main FLP rig on this trick), I was unable to change the registry key back to what it was before. For some reason the edit only goes in one direction. And since I did not have any spare license keys for XP Professional, I had to leave my physical system as-is.
m
0
l
!