Sign in with
Sign up | Sign in
Your question

Windows 7 OS not starting with IDE drive installed

Last response: in Storage
Share
February 8, 2010 4:24:54 PM

Hi All

Just bought a new PC (i5, 4GB RAM and an ATI 4870) and thought I would throw in my 300GB IDE from my rather aging system. I hook it up to the mobo, check the BIOS and it's recognised no problem. The boot sequence is fine and the IDE bus is enabled. Boot up and I get the flash screen (Windows starting..), then nothing. It just sits there. Whip it out and the new PC starts fine. Put the IDE drive back in my old PC and XP starts no problem. Any ideas what's causing the conflict?

Cheers

Dougsey
a b $ Windows 7
a c 327 G Storage
February 8, 2010 4:42:29 PM

Two things could cause this. One is how the IDE drive is connected and identified; the other is the BIOS' boot sequence setting.

I'm going to assume you have a machine with ONE IDE port on its mobo. Connected to that port on a ribbon cable you may have one or two devices, although you do not mention a second. Anyway, check these details:
1. Every IDE port MUST have a Master; since this MAY be the only device on the port, it must have its jumpers set to the Master position. (Some drives have different settings for "Master with No Slave Present" and "Master with Slave".) Then you should plug it into the END of the IDE ribbon cable. The alternative is to set the drive's jumpers to "CS" for Cable Select, and then it MUST be on the END connector.
2. IF you have a second IDE device sharing the port and cable, it MUST be set to Slave by jumpers. Alternatively, if BOTH devices are set to "CS" that's OK, and then the END device will be the Master.
3. IF you have a HDD and an optical drive on the same port / cable, make the HDD the Master.

Now, once those are done, boot and go directly into BIOS Setup. Verify in the first screens that the disk shows as Master on the Primary IDE Port. Then find the place where the Boot Priority Sequence is specified. Often on a new PC it will have the Primary IDE Master as the default boot device, which you do not want. Change it. You probably want to set the first boot device to try as the optical drive, and the second device your SATA boot drive. Unless you have a reason for another, make sure there are NO other boot options in BIOS. Save and Exit and you should be fine.
February 8, 2010 5:01:47 PM

Cheers paperdoc. You're spot on that I only have one IDE port on the mobo (it's an ASRock P55), and the other devices are connected by SATA. Haven't checked the jumpers but was def being identified in the BIOS as the Master IDE. I tried the slave connection on the ribbon just to see and whilst the BIOS picked it up as an IDE slave, it made no difference.

Boot sequence is fine (IIRC it was set to Sata then DVD/CD drive anyway). Will check out the jumper positions, cheers.
Related resources
February 8, 2010 5:05:12 PM

Looks like the jumper is set to Cable Select. Was attached at the end with no joy - will the presence of the slave connection had an effect (even if not being used?)
a b $ Windows 7
a c 327 G Storage
February 8, 2010 6:33:49 PM

If you choose CS for jumper settings, the absence of a Slave on the middle connector of the ribbon cable is NOT supposed to be any problem at all. If you just want to be sure, set its jumpers to Master instead.

Look closely at the way your BIOS names things. Some use terms like IDE Master 3 etc for actual SATA ports (clue: there is no IDE Slave 3 because there is no Slave in SATA). So it MIGHT cause you confusion in the Boot Priority screens.

In Boot priority it is more common to set the first device as the optical drive. Setting it second AFTER the HDD will mean you cannot boot from the optical drive at all unless your HDD fails. But putting the optical first, and then NOT putting a bootable disk in it, will allow that drive to be tried first and fail, which then causes the system to go on to the second boot device, your SATA drive. As you work on these, watch out for its default actions. Often if you change one, it will fill in other options on other lines for you. That MIGHT end up putting your old drive on the IDE port into the sequence, and you do NOT want it in there at all.

I just looked through the manual for the ASRock P55 Deluxe board (not sure if that's yours). On p. 66 it covers configuration of drives, and I see a potential source of confusion. The first line called "SATA II Operation Mode" and the default choices is "IDE". This does NOT Enable the IDE port. Is sets the SATA ports 1-4 to IDE Emulation Mode so that Windows thinks it is dealing with an older plain IDE device, rather than a SATA or AHCI device. This is mainly for use with Win XP, probably not necessary with Vista or Win 7. Lower on the screen are the lines for details of what device really is on each SATA port. Still in the upper part of the screen, though, is a line called "Onboard eSATA and IDE" which must be Enabled to use either eSATA, IDE, or both. If Enabled, then you can configure the eSATA port mode on the next line (similar to the modes on SATA 1-4). Now, near the bottom of the screen is the line that shows what eSATA device, if any, is connected. Then the last two lines show you details of the IDE devices connected, and THIS is where you must make sure your IDE Master device (your old drive) shows up and is configured properly.
February 11, 2010 7:18:59 AM

Hi, thanks for your reply - been away with work, so not had a chance to look at it properly before now.

I haven't got a jumper key for some reason, so don't really want to mess about there and risk breaking the pins! The mobo is a P55M Pro, sorry should've been more specific. Have checked the boot sequence and there's not even an option to choose my IDE drive when connected. Set it to both CD/DVD first, then the Sata, but no joy there either.

In the storage configuration of the BIOS, the Sata shows up under the 2nd SataII slot (CD/DVD first), with the IDE drive as the master in the IDE drives. Onboard IDE is enabled. So it all looks like everything is connected fine, completely baffled.

One thing that has been suggested to me is that despite the boot sequence, on start-up it recognises that it needs to access the Sata first, but then at the splash screen gets confused, trying to access the IDE drive. One way to fix this is to amend the boot.ini. Which seems a little odd to me, and again not something I'm keen to mess about with....
a b $ Windows 7
a c 327 G Storage
February 11, 2010 1:01:16 PM

I, too, find this very puzzling. It certainly appears you have all the BIOS settings correct. I agree you don't need to put extreme effort into the jumper settings on the IDE drive - EXCEPT to check this: you say you do not have any jumpers to install, so I assume there are NO jumpers on the IDE drive's pins. Is that the correct configuration for CS or for Master? On some drives (maybe not yours), no jumpers is the Slave setting. If you NEED a jumper, you can probably get one from a computer parts shop, or even from a friend with an old piece of junk lying around. Just be sure it is one for an IDE drive. Some new SATA drives also use jumpers, for entirely different purposes, and their jumper size is different.

Editing boot.ini is easy using s simple text editor like EditPad or Notepad, but I agree you would not want to do that without knowing exactly what to change, and what to leave untouched.
February 12, 2010 6:47:47 AM

Ah, sorry, meant the jumper is there (set to CS) but I haven't got the key with which to change it to master (or so I'm led to believe there prob was one with the drive but long since lost!).

Looks like I need to pick up a caddy and use it as an external! Cheers for your help though, much appreciated.
March 1, 2010 5:11:35 PM

Just as an update to this, picked up a caddy....and guess what, no joy! Both the Windows 7 PC and an XP netbook recognise the drive, but give no access to the files.

Best guess now is that as it's partitioned, there's a conflict somewhere there, though I didn't think that would matter (as in I'd be able to see both partitions, system files and all). Going to have to reboot my old PC, and do some file transfers through another external.
a b G Storage
March 1, 2010 5:54:43 PM

If it's a Western Digital drive try removing the jumper completely. I have had to do this many times to get WD drives to work as a single drive on the IDE cable.
March 1, 2010 7:39:42 PM

Cheers, it's a Seagate Barracuda, but I'll give it a go anyway!
!