Sign in with
Sign up | Sign in
Your question
Closed

Asus P5Q Pro Network Problem

Last response: in Motherboards
Share
January 1, 2009 7:36:55 PM

I just put together a new build and everything went perfect yesterday but now out of nowhere my network connection doesn't work.
Specs:

Q6600
Asus P5Q Pro
ATI 4870
4 Gigs Corsair Ram
WD Caviar Black 640

I installed the newest drivers and still no dice. The port light on my router doesn't come on when plugged into this new build but I know that the router and internet connection aren't the problem because they work perfect on two other computers.

Any ideas?
a b V Motherboard
January 1, 2009 7:46:14 PM

Stupid questions, but I have to ask them:
  • If you MB has network activity lights (normally beside ethernet port) are the lights at the back of your MB lighting up ?
  • Tried another cable?
    January 1, 2009 7:51:01 PM

    No I don't have any lights to indicate anything on the MB. The cable works perfect on other machines too. Thanks though. Stupid question: under Vista 64 what should the network adapter show up as under the Device manager? For the life of me I'm not seein it.
    Related resources
    a c 216 V Motherboard
    January 1, 2009 7:53:10 PM

    Did it work right after you put it together? Is the onboard LAN still enabled in the BIOS?
    a b V Motherboard
    January 1, 2009 8:03:13 PM

    Tried a different port on the router?

    In Windows device manager, anything showing under "Network Adapters"? Anything under a Yellow exclamation mark?
    January 1, 2009 8:11:20 PM

    I think this is part of my problem, under device manager "network adapters" isn't even showing up, I've never seen that before. :heink:  Any ideas?
    a b V Motherboard
    January 1, 2009 8:16:44 PM

    The device manager won't show "empty categories" so if your device is experiencing problems, the whole category might not show-up. I know Windows puts all "problematic" hardware under a special category with a yellow exclamation sign, do you have that?
    January 1, 2009 8:21:32 PM

    Ok, extremely strange thing just happened. Before when I looked for network adapters the entire category wasn't there. I just checked again and it showed up and the atheros utility said it was functioning properly and then when I clicked off of it the entire network adapter category vanished.
    a c 216 V Motherboard
    January 1, 2009 8:21:43 PM

    Have you checked if the LAN is enabled in the BIOS?
    a b V Motherboard
    January 1, 2009 8:24:39 PM

    My guess is that either the drivers got messed-up or the built-in network card is dying.

    Try starting windows in safe mode, uninstalling the device from the device manager and restarting. Windows should detect it and "reinstall it".
    January 1, 2009 8:36:49 PM

    Well, so far it looks like that's the ticket. Hopefully it stays that way. Thanks! I'll let you know if I have any other probs, you're the man!!!
    January 1, 2009 8:41:48 PM

    Ok, I might have spoken too soon... the internet worked briefly and then cut out again... let me play around with it for a sec.
    January 2, 2009 4:18:27 AM

    Ok, here's the full story from start to finish.

    Fresh build, everything posted perfect, installed all updated drivers, worked perfect. Today I boot up (I'm using Vista 64) and I see that I don't have an internet connection. First thing I think is, "ok, I need to go restart my cable modem and router". I do that, restart my computer and no dice, still doesn't work.

    I enter device manager and it doesn't show "network adapter" anywhere. I think to myself, hmmm, that's weird. So I post up here and take the advice you guys gave. Checked BIOS, yes it's enabled. Start windows in safe mode. Unistall drivers and then install them and restart.

    At first I was pumped because it looked like everything worked. I had internet and things were great. Then it stopped and said I had "limited to no connectivity". I restarted and now the same thing has happened. The lights on the back where the ethernet port are don't light up and I can't find "Network Connection" anywhere in the device manager.

    I called ASUS technical dept but they're closed because of the holidays. I'd like to figure out what the problem so I can finally start playing with this baby! :D 
    a c 216 V Motherboard
    January 2, 2009 12:53:37 PM

    If the LAN disappears from Device Manager, you might have to RMA the motherboard. A quick search on the Internet shows that you're not the first one running into that issue. What LAN chip is used on that motherboard?
    January 2, 2009 7:28:13 PM

    Well the drivers are atheros so I'm assuming that's also the chipmaker.
    November 14, 2009 8:38:07 AM

    Just keep the Asus driver (it works with the beta version also). If the router can't find your network adapter just reset it. Then right-click on "My Computer" and select "Manage". Look for you Atheros network adapter and double-click to make appear the properties. In advanced tab select "APS Mode" and modify the value to "Enable". Next time you will boot you'll be happy to see the Leds of your router blinking :love:  I also set the "Flow Control" to enable to see any difference but I didn't experienced any...
    June 25, 2010 4:16:14 AM

    Hi ozzy702,

    I using P5Q pro mainboard and have the same problem, when searching for solution, I found this topic. Have you find any solution ?
    January 13, 2012 11:56:30 PM

    I found a solution to this miserable problem, or at least an easy workaround. I've had this happen on and off once or twice and it just happened again after flashing my BIOS. After thinking about how it came back the first time I figured the only random thing that might have caused it to come back was removing power from the machine for an extended period of time, perhaps clearing something jacked in CMOS or memory or Lord knows what. Solution that worked very first try, I turned off my computer and unplugged in from power for about 30 seconds, started back up and lo and behold I had network connectivity.

    TLDR: Unplugging your computer for ~30 seconds and then plugging it back in and starting seems to fix the issue until it happens again.
    !