Sign in with
Sign up | Sign in
Your question

HELP! Asus P6T Deluxe: SATA HDD/IDE OPTICAL DRIVE and WIN XP 64-bit

Last response: in Motherboards
Share
January 2, 2009 2:25:06 PM

Hi All,

I'm assembling my first core i7 PC. The following is my config:

Core i7 920
Asus P6T MB
Corsair 6GB
GeForce 8800GT 512MB
WD Velociraptor 300GB
SONY DVD/RW (IDE Drive)

I have a Velociraptor connected to one of my (6) SATA ports (connected it to the first one) and the optical drive connected to IDE. When I try to install XP 64-bit, the HDD doesn't show up in the setup. This is expected behavior of any SATA Disk. I then, slipstreamed SATA Drivers from the Asus supplied MB disk onto the XP disk. Still doesn't work. I created a second disk, with drivers downloaded from Asus site. Still no luck.

The BIOS is new to me and I am still in learning process. The opening screen of the BIOS shows no disks connected to any of the six SATA ports. However, just before entering the BIOS (after POST), I do see a line about the HDD and another line about my SONY optical drive.

I've changed the SATA mode to "compatible" in the BIOS from "enhanced", trying to make it work as an IDE, without AHCI. But, XP setup still doesn't recognize it. I've even "disabled" the SATA mode (out of frustration), and it wouldn't obviously work.

At this point, I am out of options. Any ideas?

Thank you all for the help!
a b Ĉ ASUS
a c 216 V Motherboard
January 2, 2009 2:51:46 PM

The bios should recognize the sata device. It sees the device before the os does.
Verify that the sata cables are secure, and that the vr has power.

Set sata configuration to enhanced, and configure sata as ide. AHCI may be a problem for xp-64, as it requires drivers that might not be present initially.
Vista-64 has all the drivers already, and is probably a better option if you can manage that.
January 2, 2009 3:04:48 PM

Thanks geofelt.

The cables should be secure. I will check again. But, I do see the HDD on screen, just before it enters BIOS.
Related resources
February 16, 2009 5:16:39 AM

Check the book that came with the P6T, there are 2 RAID controllers on the motherboard. An Intel one, and a Marvell one. If you change the system BIOS to boot to RAID for the SATA controllers, then Vista 64 will detect the HD. If you are plugged into the wrong SATA ports, then you are in teh Maxwell SAS/SATA ports, and you will need the driver disk. I went through this pain the first time, and cause of performance, formatted, and installed on the Intel RAID.
February 16, 2009 7:40:27 AM

Are you 100% sure you havent tried to connect your HDD to one of the SAS ports by mistake?

Yeah turn off the support for the 2 raid devices, and that crappy express gate that comes on when you first boot.
!