Sign in with
Sign up | Sign in
Your question

HD2900 XT , sound stopped working

Last response: in Graphics & Displays
Share
October 5, 2008 10:43:40 AM

So, my friend got his HD2900XT working, played crysis and everything but then heard that the sound, from the beginning when he installed the card, there was no sound. So we checked the onboard audio device his status, nothing wrong. WE started up DXdiag and it see's 4 audio devices, 1 soundmax , 1 ati hdmi something, and 2 bleutooth ( which were there already ) I know the Ati driver is for the sound , but how do i get his onboard soundchip working? It's activated and the boxes are plugged in but nothing happens, I can start media player and play music but i wont hear anything.

Thanks in Advance,

Tijmen
October 5, 2008 11:18:55 AM

The ati one is for HDMI ;)  Still no solution
October 5, 2008 11:50:58 AM

Hey.
Yes, the HD lineup of Radeon graphics cards (2xxx, 3xxx, 4xxx) all have integrated sound card, which will conduct digital audio through an HDMI port. It can only be used if your TV or monitor is able to receive audio over HDMI and output it to speakers of it's own, otherwise you should not have to use this feature.
Now, to fix your problem, I think that your default sound device was switched to ATI HDMI after you installed the ATI card. So, what you'll need to do is switch your default device to onboard audio, be it realtek or whatever. Are you using Vista or XP? On Vista, in right lower corner should be a sound icon (the standard Windows Vista one, not your proprietary software), right click that, select 'Playback Devices'. You should see in a windows that opens up all your installed devices, mine shows: 'Digital Output Device (HDMI)', 'Speakers', 'Realtek HD Audio 2nd Output', 'Realtek Digital Output'. Also you should see one of them checkmarked - my guess is you have it set to HDMI one. So, right click 'Speakers' and select 'Set as Default Device'. THat should do it.
What am I doing answering questions this early in the morning!? :) 
gl
Related resources
October 5, 2008 11:51:43 AM

Hey.
Yes, the HD lineup of Radeon graphics cards (2xxx, 3xxx, 4xxx) all have integrated sound card, which will conduct digital audio through an HDMI port. It can only be used if your TV or monitor is able to receive audio over HDMI and output it to speakers of it's own, otherwise you should not have to use this feature.
Now, to fix your problem, I think that your default sound device was switched to ATI HDMI after you installed the ATI card. So, what you'll need to do is switch your default device to onboard audio, be it realtek or whatever. Are you using Vista or XP? On Vista, in right lower corner should be a sound icon (the standard Windows Vista one, not your proprietary software), right click that, select 'Playback Devices'. You should see in a windows that opens up all your installed devices, mine shows: 'Digital Output Device (HDMI)', 'Speakers', 'Realtek HD Audio 2nd Output', 'Realtek Digital Output'. Also you should see one of them checkmarked - my guess is you have it set to HDMI one. So, right click 'Speakers' and select 'Set as Default Device'. THat should do it.
What am I doing answering questions this early in the morning!? :) 
gl
October 5, 2008 12:16:31 PM

problem fixed, deleted the driver for audio. Changing the Audio default device didn't have any effect. PS : Can play Crysis on high @ 40-50 fps :D 
!