Sign in with
Sign up | Sign in
Your question

Noob needs a little help updating m2n-sli deluxe bios

Last response: in Motherboards
Share
January 5, 2009 1:52:36 AM

I'm trying to update my M2N-Sli Deluxe Motherboard Bios so that I can use the AMD phenom 9600 BE chip that my buddy gave me. My current cpu is an AMD Athlon 5200+ 2.61 GHz.

I'm using the ASUS EZ Flash Utility...downloaded the most recent non-beta bios (1502) unzipped/saved it to a USB flash drive..everything goes fine until the EZ flash restarts my pc (it flashes the new bios and everything fine)...once it restarts it first searches for a CD in the CD drive and fails (there isn't one in there) then searches for the USB Flash drive. It finds the flash drive and then looks for AWDFLASH.exe, doesn't find it and then just sits there. I downloaded the AWDFLASH.exe file from the Asus website and tried copying it to the flash drive but that doesn't really help...it finds it but then just does nothing. This is the first time that I have updated a bios and I have a feeling that I am missing a step or something.

Any help would be gratefully appreciated.

Other info that might help

current bios version: 0702 (I had a more updated one that came installed on the board when I got it but I had to flash from the CD that came with the board after trying to update it with the Asus Update program and having it fail on me, I guess that it fails often while validating)

motherboard: Asus M2N-sli deluxe

current cpu: AMD Athlon 5200+ 2.61 GHz.

Video card: evga nvidia 260 core 216

sound card: cheap/mid-level sound blaster, i think it was called extreme gamer or something like that.

Also...1604 is the most recent bios version but its a Beta...once I get this problem solved should I be updating to 1604beta or 1502 (most recent nonbeta)
January 7, 2009 9:39:54 AM

not sure with my board the M3N 32 EZ flash worked fine. you could try:

formatting your usb drive . is it fat32 or ntfs? maybe they will effect it.

using a floppy disc oldskool method.

or burning it onto cd which i doubt will work.

the only other way is i do beleive that asus made a utility that installs it while your computer is in windows. then restarts and makes any last neccesary changes. perhaps this will work better for you?? but other than that i cannot think why it is not working for u.


ah go into you BIOS setting by pressing DEL while your computer posts!

then go through your buios and u will find a setting that turns on ez flash drive or off that may be why it doesnt work????
January 7, 2009 2:52:14 PM

Yea im not sure why its not working...I tried using the Asus windows bios updating program and thats what messed it up originally. When it got the the validating stage of the flash the program crashed...i looked online and found a lot of posts saying that that program is buggy and that is a common error.

I'm like 99.9% positive my usb is fat32 which should work fine according to the manual that came with my motherboard.

I recently ordered vista 64bit with the "I bought the wrong version" offer that came with my retail copy of windows vista 32 bit. I'm going to format and reinstall windows once i receive that and then try again to update bios with the 64bit update...hopefully it will work.

@ ch1ef...thanks for your guide...I will follow it once I get my vista 64bit copy
!