Sign in with
Sign up | Sign in
Your question

Vista 64 8GB DDR2 Only 3GB Showing.

Last response: in Memory
Share
January 5, 2009 6:21:49 PM

This is my first post on here so i apologize in advance if i don't do this correctly.

I have vista 64bit ultimate. I was running 3gb of DDR2 667 and decided to switch to 8GB DDR2 800. Bios detects the ram and shows 8GB. Vista 64 in the properties shows 8GB. But talk manager only sees 3GB. I have memory remap enabled (even disabled and then enabled again) i have even reset the CMOS. What am i doing wrong? =(

This is the ram i purchased http://www.newegg.com/Product/Product.aspx?Item=N82E168...

my board is a p5k se with a q6600. Someone please help or am i screwed?
a b } Memory
January 5, 2009 6:32:20 PM

u try remap off? i thought, though i could be mistaken, that remap helped 32bit reallocate memory resources to pci. So in task manger you see 3 or 3.5 gigs and the reamining ram is in use for pci addressing. Seeing how you already have a 64bit system. you wouldn't want that on.
January 5, 2009 6:36:48 PM

i tried both ways no dice. I will even try again now. I see 3070 total. in properties and bios i see all 8GB so the ram is good. i ran DXDIAG.exe in both 32 and 64 and still see only 3070mb ram. Im really at a loss here. Since the properties and bios say im using 8gb ram does that mean im ok even though task manager and DXDIAG.exe say otherwise?
Related resources
January 5, 2009 6:36:52 PM

Load CPU-Z and see what it tells you. You can download it at cpuid.com. Task manager is probably did not update itself or something like that. If the properties of Vista sees 8 gb, no problem.
January 5, 2009 6:45:50 PM

CPU-Z says i have 8192mb of ram so that is right. So at wont point will task manager and the DX show all my 8gb? Also my everest vista sidebat gadget shows only 3 as well. Everest shows 8GB but the memory utilization shows 3gb just like task manager. Will this fix itself over time?
January 5, 2009 6:49:36 PM

are you ocing? and is vista dececting if your l2 is set right? also try running a memtest and see if you come up with any errors. also if you can post a pic of your taskman and of your system prop. (just edit out the key.)
January 5, 2009 6:50:54 PM

Was OC but reset everything thinking that might be it. Still didnt work. Im sorry i dont know what l2 means. Sorry. Will run memtest right now
January 5, 2009 6:51:22 PM

I hate to ask this... but is the OP 100% positive he has a 64 bit flavor of Vista?
January 5, 2009 6:53:14 PM

thats why i asked for the system prop page to see if it said 64 bit. and L2 Cache. vista sometimes doesn't set it properly.
January 5, 2009 7:05:29 PM

yes i have 64bit, if you can tell me how to get the screenshot and post it i would love to. and cache l2 says 2x 4096 if thats what you mean im sorry guys
January 5, 2009 7:12:57 PM

right click computer and go to properties. then hit print screen and open paint and paste the pic in there then edit out your key info.
January 5, 2009 7:22:23 PM

i think thats what you guys wanted.I dont mind if it doesnt display all 8gb but if im not actually utilizing 8gb when i use photoshop 64 for example then thats no good
January 5, 2009 7:24:05 PM

ok can we get taskman and the memory tab of cpuz?
January 5, 2009 7:24:54 PM

ya 1 second
January 5, 2009 7:39:15 PM

and here is 1 more picture of everest showing 4 x2 sticks but only 3gb of ram.weird. 1 in the taskman pagefile is showing 8gb total.


January 5, 2009 7:51:37 PM

ok i turned off the computer and decied to try just 2 sticks(4gb) and its still showing me 3gb of ram. This is to weird. Properties and everything says 4gb but task is saying 3gb.
January 5, 2009 7:53:41 PM

ok somethings telling me its got to be a bios thing or the way vista was installed. Did you have vista installed and added the extra ram? I'd check to see if there is an update for your bios. also looking at your board specs it looks like it try's to run the ram at 1066 with its tuning feature. (try turning it off) also heres a link to the boards qualified ram list.

http://support.asus.com/download/download.aspx?model=P5...

Just in case if you decide to rma to get another set of ram.
January 5, 2009 7:58:29 PM

Yes vista was already installed. There are no more updates for my bios. running the ram at 1066???? how would i turn it off?set it to manual 800 in the bios? so do you think its utilizing all 8gb and just not showing in the taskman or am i really only getting 3gb?
January 5, 2009 8:09:29 PM

might try reinstalling vista with the ram in place.
a b } Memory
January 5, 2009 9:34:08 PM

Run msconfig and go to the tab labeled "boot". Go to "Advanced options" and make sure the "Maximum memory" checkbox is unchecked.
Anonymous
a b } Memory
January 6, 2009 12:44:39 AM

I used to have that board and ran into the same problem using 4gb at 1000mhz.
I eventually figured out the board wasn't supplying enough power to the ram. It would only show up as 3gb using certain benchmarks and it wouldn't actually run at 1000mhz. It never got solved so I bought a new mobo.

Maybe they have a bios update that actually lets you change the voltage?
January 6, 2009 1:21:20 AM

Also this might be silly but it must at least be mentioned. Make sure you are fully up to date with windows updates. There is a patch out there (don't remember the kb) that addresses how Vista displays your memory available. This patch may of only have applied to 32 bit, but it's worth at least reading about before you do something like blow away and reload your OS.
January 6, 2009 12:45:04 PM

it was the maximum memory tab was checked to 3gb.problem solved.thank you so much guys for trouble shooting this.i was racking my brain thanks again!!
Anonymous
a b } Memory
January 28, 2009 12:18:01 PM

hi to all,
i have the SAME problem but with 4Gb p physical RAM instead of 8Gb, but unfortunately for me nothing changes after uncheck Max Memory in Advenced Options under Boot tab in msconfig: task manager stills to view only 3069Mb of RAM.
I have Vista 64 Ultimate SP1, and system properties under control panel says 4Gb total memory but Task Manager says only 3069Mb Physical Memory and MSINFO says:

* Installed Physical Memory (RAM): 4Gb
* Total Physical Memory: 3Gb.

My pc is a Toshiba Laptop with Toshiba with Intel T5500, Northbridge Intel i945PM rev. 03 and Southbridge Intel 82801GHM (ICH7-M DH) rev. 02. The chipset supposedly supports correctly 4Gb, and bios says correctly 4Gb of memory installed.
Any suggestion?
Thanks in advance for support and sorry my poor english...
March 3, 2009 11:09:37 AM

Vista 34-64 bit only can only detects 3g Ram although your hardware detects the actual amount of ram inside your computer, this is why some of u have bought computers or installed up to like 8g ram in this case and are only detecting 3g. Although vista detects only 3g it still uses the hole amount of ram u have in your motherboard so stress less guys :D 

Feel free to email me at boen99999999999@hotmail.com although i may not reply.
April 18, 2009 5:01:38 PM

free862... feel free to delete that entire garbage post, because well it's complete garbage.
April 21, 2009 4:26:03 AM

Hi guys

I have a similar problem. I bought my system about 18 months ago with 8gb of 'Transcend' 800mhz RAM installed, using Vista Home Premium 64-bit OS.

When I look in 'System Information' it states

Installed Physical Memory : 8.00gb
Total Physical Memory : 4.0gb
Available Physical Memory : 6.70gb

How is this possible? Aren't all three of those lines contradictory?

In the Task Manager is states to have 8198mb Total Physical RAM available. It's using 1.50gb at the time I'm writing this message.

Is there a problem in which the way my RAM is being utilised, or is the System Information tool merely useless?

Any explaination would be greatly appreciated.
April 21, 2009 12:21:14 PM

I'm guessing that just like XP, Vista is putting a portion of the RAM away for system use.

For example (assuming 4GB of installed RAM), XP puts 2GB RAM aside for the system, and the rest is avaliable for the user(s). If Vista does the same thing (which it probably does), those lines make perfect sense:

Installed Physical Memory : 8.00gb (The amount of RAM installed)
Total Physical Memory : 4.0gb (The amount avaliable to the user)
Available Physical Memory : 6.70gb (The total amount of unused RAM, counting RAM avaliable for system use)

If I'm right, 4GB of RAM is being put aside for the system, and 4GB is being put aside for the user, and of that RAM, 6.7GB is not being used by either the system or the user.

How Vista decides to segment RAM between the user and system is beyond me though; it might depend on how much is avaliable.
April 22, 2009 9:56:05 AM

Much appreciated. I was worried for a while there, thanks
April 24, 2009 3:33:43 AM

im having the same problem but with windows XP Pro 64bit SP3 it only sees 3.00gb of ram installed please a little help
July 1, 2009 7:48:56 PM

I am having the same problem with freaking 64bit too loool!, i installed 2 extra gb of ram having a total of 6, but it still only shows 3gb. i have Smart RAM Running at all times to see my ram usage and how much are free, it used to go up to like 2500 free, but since i installed vista 64bit from 32bit, it went down! wtf.
October 1, 2009 8:36:15 AM

stevensl2 said:
I am having the same problem with freaking 64bit too loool!, i installed 2 extra gb of ram having a total of 6, but it still only shows 3gb. i have Smart RAM Running at all times to see my ram usage and how much are free, it used to go up to like 2500 free, but since i installed vista 64bit from 32bit, it went down! wtf.


I just had this same problem, Vista64, 8GB ddr21066 upgrade, only 3007 showing in Task manager. CPI-Z showed 8gb.

FIX:

run MSCONFIG

Boot tab

Advanced Options

uncheck "Maximum Memory"

(you don't have to make this change permanent)

save and reboot.

VOILA!

8 beautiful gigs in Task Manager.



!