Sign in with
Sign up | Sign in
Your question

Why can't I use Remote Desktop?

Last response: in Networking
Share
March 26, 2009 4:40:33 AM

I am having trouble using remote desktop. I have a trendnet TEW-639GR router which is pretty new. I am using Vista Ultimate.

My gateway is 192.168.0.1, nothing unusual about that. I am forwarding port 3389 on both TCP and UDP to a laptop which has a verified (by ipconfig) IP of 192.168.0.15.

Windows Firewall is set to allow remote desktop connections on my LAN computers as well as outside (work). I used to connect to work over VPN, my sysadmin verified that RDP is working for our company. I can access our network at work over VPN just fine, just not RDP.

Additionally, I cannot even connect to another machine on the LAN. I can ping the machine by name and IP, no problems there. I also checked the firewall on the LAN machine, it appears just fine.

If I run netstat, it shows this:
TCP [::]:3389 [::]:0 LISTENING 1704

Hmm.

So...
Ping is okay
VPN is okay
IP adresses are okay
Firewalls are okay
Port forwarding is okay

What else could it be? Virus? I missed the obvious? Help!

More about : remote desktop

March 26, 2009 9:24:37 AM

unless the machine your attempting to rdp to has a fixed static ip which is directly linked to the internet, or uses port forwarding from the internet gateway (at work) to a particular machine im pretty sure this wont work.

use the vpn to connect your machine to the work network, then from there use rdp to connect to the machine you have access to at work. you need the vpn to link the two networks over the internet.

the machine you cant connect to on the lan, is this at home or at work?
March 26, 2009 3:34:59 PM

All machines Im connecting to have static IPs. The machine on the LAN has a static 192.168.0 address. The machine I am using to connect RDP to the work machine is being forwarded port 3389 (as I stated in the OP).

And I also said I used to be able to use RDP over VPN to connect to work, and it isnt working anymore. So telling me I need to use VPN to use RDP with work isnt terribly helpful.

The problem is that something is blocking RDP- everywhere on my network. I cant connect on my LAN, I cant connect to work. Again: static IPs, 3389 forwarded (TCP and UDP), firewalls open.

I would suspect I have a bug in the router firmware for port forwarding, but I can forward other ports okay.
Related resources
May 22, 2009 2:24:09 PM

Any luck with your problem ?

I'm having the exact same issue:
My laptop at home is able to connect the VPN at work, but no RDP connections would work. Ping doesn't work either.
The router at home is a Trendnet TEW-432BRP (or 632BRP, I can't quite remember, I'm at work right now), and when I use a wireless 3G card, it connects fine (VPN AND RDP).
So it comes from the router... Any idea ?
May 29, 2009 2:11:12 PM

If you are trying to remote desktop from home to work then your router should have nothing to do with it since the communication would be NAT'ed and outgoing (The routers settings are for incoming traffic).

So after you establish your VPN you can ping your pc but not RDP. My first thought would be that RDP got turned off on your work pc.

As for at home, your router should also have nothing to do with it since the communication is on the same subnet (internal to your home). So my first thing to check would still be to ensure Remote Desktop is enabled on your home computers.


In both situations, if remote desktop is turned on and you still can't connect. Try telneting to that port to see if it times out.
command -> telnet (ip address) 3398
June 2, 2009 8:50:31 PM

Hey, thanks for the help phlatline :) 
Fortunately, I decided to try and reinstall the VPN client, and everything worked fine after that !

I guess you were right about the router having nothing to do with the connection in the way home > work.

About the ping not working when I'm just connected through VPN (not RDP) : the admins told me it wasn't supposed to.

So everything's cool, thanks a lot for your help ^^
!