USB Ports not working

Hello,
None of my usb ports are working. When u insert a pen drive or mouse or keyboard or anythin else, there is no response. Please help.
Reply to laptopUser3690
6 answers Last reply
More about ports working
  1. click my computer, on your desktop
    click control panel, it's on the left hand side of my computer window
    click the "system" icon, a window will open that says system properties
    click the hardware tab
    click the device manager bar
    when the device manager window opens, scroll down, find universal serial bus controllers
    double click universal serial bus controllers, it's on this list
    now you will see a list, find USB root hub on the list
    double click the first USB hub on the list (or in a laptop check the settings for mouse and keyboard power saving)
    when the USB hub properties window opens, click the power management tab at the top of the window
    now you will see a box that says: "allow computer to turn off this device to save power"
    Un-check that box, click OK
    Now double click the second USB hub on the USB Hub Properties list, click the power management tab, un-check the power saver box just as above and click OK
    Now repeat that same procedure for all the other USB hubs on the list, un-check the power saver box in each USB hub, until you have done all the USB hubs on the list. There may be several, you must do each, one at a time.
    Now close all your windows and restart the computer.
    Now the mouse should stay on.
    The computer was turning off the mouse keyboard USB to save power. It's a bug in XP.
    Reply to soundguruman
  2. Thank you so much!
    Reply to Spirlazz
  3. soundguruman said:
    click my computer, on your desktop
    click control panel, it's on the left hand side of my computer window
    click the "system" icon, a window will open that says system properties
    click the hardware tab
    click the device manager bar
    when the device manager window opens, scroll down, find universal serial bus controllers
    double click universal serial bus controllers, it's on this list
    now you will see a list, find USB root hub on the list
    double click the first USB hub on the list (or in a laptop check the settings for mouse and keyboard power saving)
    when the USB hub properties window opens, click the power management tab at the top of the window
    now you will see a box that says: "allow computer to turn off this device to save power"
    Un-check that box, click OK
    Now double click the second USB hub on the USB Hub Properties list, click the power management tab, un-check the power saver box just as above and click OK
    Now repeat that same procedure for all the other USB hubs on the list, un-check the power saver box in each USB hub, until you have done all the USB hubs on the list. There may be several, you must do each, one at a time.
    Now close all your windows and restart the computer.
    Now the mouse should stay on.
    The computer was turning off the mouse keyboard USB to save power. It's a bug in XP.
    Reply to chip12gionet
  4. How do I do that with all the ports dead, i.e., no mouse, no keyboard.
    Reply to chip12gionet
  5. chip12gionet said:
    How do I do that with all the ports dead, i.e., no mouse, no keyboard.

    You need a PS/2 mouse. If you don't have one, then buy one. before that, ask first some of your friends or from within your family, if he/she has a ps/2 mouse
    Reply to nikos545
  6. laptopUser3690 said:
    Hello,
    None of my usb ports are working. When u insert a pen drive or mouse or keyboard or anythin else, there is no response. Please help.


    Probably you usb is a 3.0 backward compatible (it looks like a 2.0) > insert the pen into an windows 7 and format fat32, (of course, backing up files previously with any Linux live disk, or using the file manager contained in the 'Kaspersky Rescue Disk 10' , freeware ).
    Greetings,
    Andrea
    Reply to AndreasPtr030
Ask a new question Answer

Read More

Drivers Keyboards USB Windows XP