Sign in with
Sign up | Sign in
Your question

Need help please with bios update problem

Last response: in Motherboards
Share
January 14, 2009 12:36:38 AM

I have a AMD Phenom II 920, 4GB OCZ 1066 RAM, an 800 watt OCZ P/S, 300GB velociraptor HD & a Biostar TA790GX A2+ MB. I just built the computer today and everything went fine except that both in the bios and when I installed vista 64 bit it didn't recognize my new processor by name (I got the first release bios almost 5 months old.

In the included CD for the Biostar board was an online bios flash utility. I read on new egg that it was pretty easy to use and when I ran it it appeared so. A DOS box poped up, it said everything went normal, then asked me to restart.

Now it won't get anything past the bios. It actually recognizes my processor by name now in the bios (and shows that it's the up to date version) and I can hang out in the bios as long as I want without restarts, but as soon as I try to start windows it restarts without any screen or warning. It won't even let me boot from my windows disc to repair or reinstall windows.

Can anyone help me, please?

Edit: I finally got an error screen after my 10th attempt to repair/reinstall windows. Blue screen that said under technical info: Stop: 0X00000124 (0X000000000000000, 0XFFFFFA8003FC1030, 0X00000000B4002000, 0X0000000087000128)

More about : bios update problem

January 14, 2009 2:55:58 AM

Sounds like a stupid HAL issue, I could be wrong though.

Windows might think there is different hardware installed now and refuse to boot.

You may want to look at loading optimized settings in the BIOS, if that doesn't work - try safe settings.

If you have a SATA hard drive - look at the AHCI setting (for the hard drive of course), if it is set to use AHCI set it to use ATA instead - if it is set to ATA mode switch to AHCI....

um....

try turning the voltage up on yur ram +0.1

If you know the exact timing for your memory look and set them manually instead of letting the bios detect (AUTO setting).

Perhaps you may have to set the memory to a very loose setting first 800mhz 1.8v 5 5 5 18 (something like this) once yur in windows do some research on your memory ... find better settings etc etc..

If all else fails - reinstall Windows, which is probably what I would do first because all that I've listed above will take about the same amount of time and reinstalling windows will probably be the fix (unless the AHCI setting is the issue)
January 14, 2009 3:52:17 AM

The memory is CAS 5 @ 2.2 volt well that's what it says on the box I just left it on default. It worked fine the first time I installed windows before I flashed. I tried to reinstall windows by changing the boot order to optical drive (both my hdd and od are sata) but it only gets as far as loading files then blue screens even booting from the disc.

I was hoping it was just a windows problem like you said but if I can't even boot from the windows disc to reinstall it's probably something wrong with the board...the weird thing is it works perfectly while i'm actually in the bios so then I think maybe the board is alright. I don't know.
Related resources
Anonymous
a b V Motherboard
January 14, 2009 8:25:22 PM

hey nonstoprobot, it's 0401tech just following up on the quick face-to-face chat we had at work. the response about the sata settings/ahci above was what i was referring to. vista should already be prepped even on the disc for any sata settings, but maybe there was an update that vista didn't know what to do with.

play w/ the sata/ahci settings, try safe and optimized settings if they're available. since you're bsoding from the vista disc, try a vista 32-bit disc if you have one, note what it does, try an xp disc (just make sure sata settings are ide or legacy or something (not "native", "ahci", "raid")). no need to install over your vista yet, unless you just want to confirm that you can at least load xp into it (disclaimer: don't violate any licensing agreements though).

if that still isn't working out, trim your hardware down and isolate to only essential parts: mobo, video, 1 stick of ram, power. try to load from the hdd (no other drives attached), if it doesn't work, unplug the hdd and try to load from the disc drive. still not working? you can also maybe try another hdd (an ide/pata even if you still have one spare for testing), and another disc drive.

not counting a reinstall of any os, it shouldn't take more than about 30-40 minutes to try the above. you'll probably be rebooting your pc about 6-10 times (those bios settings can be hard to pin down).

you also mentioned rma'ing your mobo. even w/ shipping time and stress saved might be worth any fees right?

oh, and please note your current bios version.

good luck!
January 15, 2009 4:30:44 AM

You say it wont boot to CD - I do not want to sound belittling but have you chosen the option to boot from CD?

BIOS update on my system changed my Boot device priority. It was a quick fix but still something to consider.

If you have a single Hard drive and single CDROM drive then the settings are straightforward.

mangodrink > yes vista works flawlessly (for me) with ACHI sata, but if Vista was installed with non ACHI (legacy ata) and then it got changed, it will not boot anymore because of HAL. Which is why i mention changing whatever setting is there now :p 
January 15, 2009 4:25:34 PM

I figured it out, thanks a lot for the support you all. It was Biostars fault...the first release bios worked fine with Phenom II but the new release did not. The Biostar support emailed me an 'update' to a bios I flashed it via USB without even making it bootable first by just hitting F12 and it works perfect now!
January 17, 2009 3:12:50 PM

This is the reason I do not flash the BIOS when everything is working lol.

Bah well, glad that you got it working properly :) 
!