Sign in with
Sign up | Sign in
Your question

I need serious ASUS Bios update help

Tags:
  • Motherboards
  • Asus
  • BIOS
Last response: in Motherboards
Share
January 14, 2009 9:26:57 PM

I am having a problem updating the bios on my motherboard and am completly stumped.

Motherboard Model: Asus M2N-SLI Deluxe
CPU: AMD athlon 5200+ duel core...wanting to upgrade to a AMD Phenom quad core that my buddy gave me but cant use it until I can update the bios.

Basically I used the Asus EZ Flash to flash my bios to the most updated version (1502). I download the bios from the asus website, upzipped on to a USB flash drive, the bios flashes fine until the computer restarts. Once it restarts it comes up as the following.
_____________________________________________________________
Award Bootblock Bios v1.0

Bios ROM check sum error

It then scans for the CD drive...Fails (there is not a disc in the drive)
Then scans for the USB drive...seccess but then looks for AWDFLASH.EXE on the USB drive, can't find it and fails.

Once this happens I can always restore my system bios to the Bios version that is on the CD that came with my motherboard by simply rebooting with the Disc in the drive and then windows boots as normal...

It scans for CD drive like above, finds the disc, and then uses AWDFLASH to reflash the bios back to the version on the CD drive...the kicker is that it does this automatically and never gives an option to pick the bios version that you want to flash...it always flashes to the version on the CD (0702) which is old...from like 2006 and wont work with the phenom.
_____________________________________________________________________________________

The crazy thing is is that my Dad has the exact same setup in his computer so I tried it on his thinking maybe my motherboard bios was screwed...same exact thing and then had to restore it from the orginal CD.

I have no idea what to do...I called Asus tech support and they trasfered me to a high level tech...after being on the phone for 120min (mostly on hold) and him not being able to trouble shoot my problem he asked me to wait and after being on hold forever hung up on me...I was f'ing pissed.

Things that I have tried.
resetting CMOS...battery and jumper before and after flash
DLing AWDFLASH.exe from the internet and putting on the Flashdrive along with the updated bios...Fail
Taking out all of my ram sticks except the first one then flashing...the "asus Advanced tech" solution before he hung up on me"...Fail
Trying to update my bios with the Asus Windows updater program...Fails @ 86% (googled this and found out that other people have the same problem.

The only other thing that I can think of doing is Formatting my HDD and installing Windows XP so that I can boot in DOS mode (I don't think that you can do this in Vista) and then using the AWDFLASH program to flash my bios along with a floppy disc drive...found a guide to do this...then once this is done reformat my drive and install windows vista...but this is a long pain in the ass process and if there is an esier solution I would be greatful.

My only other option is say f**K Asus and buy a New Gigabite board and an intel chip (which I really dont want to spend the money on)

Im sorry this is so long but I am trying to be as detailed as possible.
Thank-you so much in advance for any help you can provide.

More about : asus bios update

a b V Motherboard
January 14, 2009 10:26:20 PM

Hi,
You already have newer version of bios, 1604 i believe.

You also can create bootable usb stick so you dont have to format your hdd and install xp(provided your mobo has an option for booting from USB, which I assume it has). Go to

http://files.extremeoverclocking.com/file.php?f=197

and get the HP usb Disk Format Tool and the Win98system files pack. Those two combined will let you boot to dos from USB stick. Good luck
a b V Motherboard
January 14, 2009 10:29:58 PM

LOL, i forgot the HP Tool doesnt work on vista. So if you still want to do it than you need a PC with XP. But first try flashing again to newest version via EZflash
Related resources
January 15, 2009 2:04:35 AM

MaDMagik said:
LOL, i forgot the HP Tool doesnt work on vista. So if you still want to do it than you need a PC with XP. But first try flashing again to newest version via EZflash



The flash is not the problem its what happens after. Read my post again its after my pc restarts that I am having problems...it won't post and all I get is...

Award Bootblock Bios v1.0

Bios ROM check sum error

It then scans for the CD drive...Fails (there is not a disc in the drive)
Then scans for the USB drive...seccess but then looks for AWDFLASH.EXE on the USB drive, can't find it and fails.

cont cont from my OP

also 1604 is Beta and I was trying to avod a beta version of the Bios simply because i don't need the update that it provides for my phenom CPU
January 15, 2009 3:03:14 AM

well after writing that novel I tried 1604 and it worked...must have been something with the 1502 version...MaDMagik your the man...thanks
a b V Motherboard
January 15, 2009 11:28:38 AM

np, glad it worked
Anonymous
a b V Motherboard
July 24, 2009 11:15:22 AM

Try to find something on that matter on http://biosdriver.net
!