Sapphire HD4870 Problem.. [Game Crashes]

I recently (yesterday) bought a Sapphire ATI HD4870 512MB GDDR5 along with a Corsair HX620w PSU.. I'm using it with the Proc/Motherboard I had already bought quite a while ago.

AMD 5600+ X2 (Windsor) [from my previous build]
ASUS M3A78-EM Motherboard [from my previous build]
Transcend 4GB DDR2-800 [from my previous build]
DELL 22" 16:10 LCD (connected via DVI)
Windows Vista x64 SP1
Catalyst 8.10

The native resolution of my Display is 1680x1050@60Hz, The default onboard gfx supports everything fine! (No crashes, etc). However, I CANNOT run _any_ games with my new GPU at widescreen resolutions!

i.e. If I set the resolution of the games to a 4:3 Resolution, Everything starts and works fine. Even Crysis Warhead and UT3! But it goes on a Blank-screen-and-desktop-for-a-few-seconds spree when I do anything (even older games.. heck, even Quake 3) at Widescreen Resolutions.

The Blank-screen-and-desktop-for-a-few-seconds looks like this: http://youtube.com/watch?v=alaC2XvqMK8 (Similar problem of some bloke with HD4850 in Youtube)

Also, If some game exits. It brings down the desktop resolution to 800x600. AND, once that happens, I cannot change it back to 1680x1050 (or any 16:10 rez) without reboot..

I suspect it's some problem with the drivers.. And yes, My Card is running at 67c Idle. (oh man! :pfff: )

I'd be gracious for your inputs!
7 answers Last reply
More about sapphire hd4870 problem game crashes
  1. Ok, silly question I know but in the bios have you disabled the onboard video and enabled the VC and pcie access? Is the bios up to date? All power ports to VC pluged in?
  2. I've selected 'GFX0-GPP-IGFX-PCI' setting for 'Primary Video Controller' and Disabled Surround View.

    There is no option to 'Disable' the Onboard Video :??:

    And I've plugged in both the 6-pin PCI-E Power connectors to the card.

    (In fact, I can play Crysis at High Settings at 1280x960, but that's a 4:3 resolution! All these problems happen only with 16:10 resolutions)
  3. Have you tried reinstalling the drivers?
  4. bdcrlsn said:
    Have you tried reinstalling the drivers?

    Yup! Even tried Catalyst 8.8 and 8.9.. (after uninstalling the drivers completely each time)
  5. Don't forget to use a driver cleaner after the uninstall. Also the new ATI cards seem to have conflicts with some of the non MS apps and programs that were installed prior to the ATI card install and load on Windows startup. Try disabling them, reboot and see if that helps the situation.
  6. Make shure you do not have you card overclocked at all because if you did it sometimes can cause issues like yours.
Ask a new question

Read More

Radeon Games Sapphire Graphics