AGP slot disabled

Hi, I've been trying to figure this issue out for nearly a week now and it's time for me to ask for help. I have an older custom system and some of the parts are more then likely starting to go but I want to rule anything else out before buying new things. The current issue is the graphics card. I have an AGP slot and an AGP card (obviously). I turned my computer on one day and it wouldn't boot. I swapped out several different parts before coming to the graphics card. I put a PCI card in just to test and my computer booted up. It runs just as flawless as before except the video (because of the old PCI card). I downloaded and checked my system with Everest. It stated that my AGP slot is disabled, I'm not sure how this could be but it is. I've checked the BIOS and it's set to load AGP first. I've uninstalled and reinstalled the drivers for the card. I really don't want to do a complete reinstall of Windows until the very last thing. If anyone has any suggestion on what might be causing this problem please toss it my way.

The card I have is an Ati Radeon X700 Pro, running windows XP SP3
30 answers Last reply
More about slot disabled
  1. Sounds like the drivers for the motherboard aren't installed. Go to the device manager and see if there's any yellow warnings? The drivers for the card are NOT the same as the drivers for the AGP interface on the motherboard. What's the motherboard? If you can't find the drivers someone will for you. You can also try cpu-z and see info on the graphics interface.
  2. Thank you for the reply. I've had the card for a while and only recently it started not working. The mother board I have is Foxconn 748K7AA. I hope thats the right thing. Please let me know if you need any more info. Thank you
  3. I restarted my computer after my last post and now my computer wants me to install something for a video controller. I wasn't sure exactly what the video controller is for so I can't tell it to install from a certain area as of right now. After I looked into Everest again to check the AGP slot status on the motherboard it still states disabled.

    This is the info that I have for the AGP slot from Everest

    AGP Controller
    AGP Version 3.00
    AGP Status Disabled
    AGP Device Video Controller (VGA Compatible) [1002-7A7A] [NoDB]
    AGP Aperture Size 512 MB
    Supported AGP Speeds 1x, 2x, 4x, 8x
    Fast-Write Not Supported
    Side Band Addressing Supported, Disabled

    Problems & Suggestions
    Problem AGP is disabled. This may cause performance penalty.
    Problem AGP aperture size is more than half of the system memory size. This may cause performance penalty.
  4. I agree it sounds like you need to reinstall the motherboard drivers, specifically the vidio controller you mentioned. There should be a disc that came with the motherboard. It should let you choose what to install from a start/menu page.

    Mactronix
  5. Had the same problem on at least one AGP system of mine and the problem was, as has been said, loss/corruption of the AGP MOTHERBOARD drivers.
    If you`ve lost the driver disc, do n`t panic, they are still available for download on the foxxconn website.
  6. Which drivers will I need exactly? What exactly will they be labeled?
  7. Thank you all for the helpful suggestions.

    ghmage, I downloaded and installed the AGP driver, nothing new tho. On restart of the computer after installing the driver I get a window stating that a new device is detected and that it needs a "video controller (vga compatible)". I'm not sure exactly what this is but suggestions or directions on where to get it would be great.
  8. Perhaps the onboard video controller, which should be disabled in the BIOS anyways. Here's the driver for it - http://www.foxconnchannel.com/support/downloads_detail.aspx?ID=en-us0000182
    Edit: This MB has no onboard graphics. Odd that you can d/l drivers for it; differing model perhaps.
  9. Would having a PCI card installed cause the AGP slot to disable?
  10. The BIOS has a setting for which device to initiate first. But in short, you should not have more than one graphics card installed at once when trying to get another one to work, and that includes any onboard integrated graphics (which can be disabled in the bios.)
  11. Im thinking that at this point it may be time to find the reset jumper or pull the CMOS battery and start again from scratch.
    Doing either of these will reset the Motherboard to its factory settings and then you can reinstall the motherboard drivers and go from there.
    It is the last option in most situations but as you seem unsure what or why you should be installing it may just be easier to start from scratch.
    Try installing the drivers ghmage linked to first as they should be the ones you need but after that i would be running out of options.

    Mactronix
  12. Good idea Mac. And lama, you DO have the auxillary power connected to the Radeon X700 AGP card, yes?
  13. Well I have the AGP drivers installed that were linked (I actually came across them before coming here and tried them to no luck). Then I just tried checking out the VGA driver ghmage linked and it won't allow me to install it I get "The system can not detect the device, please confirm that the device is configured properly and then restart the setup program". The BIOS is already set to initiate the AGP slot first and I haven't messed with any of the other AGP slot settings in the BIOS from what they were when the card was working.

    I have a general grasp on the driver world but I always like to get a second or third opinion before doing anything if I'm even remotely unsure about anything. I'll try taking the PCI card out and testing the AGP card again with the new drivers installed for the motherboard. I want to hold off on taking the CMOS battery out till very very last (which is very close)
  14. Sorry for the double post but it won't let me edit my earlier post.

    ghmage, yes I do have the power connected to the card, the fan on the card is spinning very well
  15. http://www.sis.com/download/
    Try going there and getting the GART driver for SiS chipsets.
  16. downloading and then installing of course, I'll post back with the results.
  17. New AGP driver installed and no difference, still looking at Everest stating that the slot is disabled.
  18. Yes remove the PCI card then un install the graphics drivers for the graphics card/s. when you install the Graphics card in the AGP slot it should run without drivers for a start. It will probably run at about 600x800 as default but you can reset this and then when you have a desktop you can see properly you should be able to install the card drivers.
    You will get all sorts of conflicts ifyou have various driver installs on the system so be sure to remove all traces of teh Card drivers before continuing.

    Mactronix
  19. Ok, just to make sure I have the order correct.

    Remove all video drivers from the system.
    Remove both video cards
    Install AGP card
    Pray computer boots to crappy quality video

    that look about right? oh also, the only way that I know how to remove a video driver is thru the add/remove program window. Is there an easier/more effective way?
  20. Device manager. See my first post on this thread.
  21. Yes you have the order correct.
    Device manager as said.
    Add remove woorks for me, i also remove any ATI folders when i do it, just make sure you have the drivers you will be using some where safe so they dont get deleted also.

    Mactronix
  22. Ok I removed all ATI drivers, removed the PCI and AGP cards then started the computer with JUST the AGP card. System starts and sounds 2 beeps, goes no further then there, doesn't start the keyboard/monitor/mouse. Added the PCI card back in system only turned on no beeps or activity at all. Removed AGP card and got the standard 1 beep on system start then booted into windows like before. One thing to not is that without the AGP card in the system stopped telling me it needs a video controller (vga compatible) on startup. Also when looking in Everest to see if the AGP slot enabled the version went from 3.0 as posted above to 2.0.
  23. Its begining to look like the card is bad, do you know anyone who could lend you a card to test ?
    You need to check with your specific Bios version but Beep codes can be looked up on the Internet.
    2 Beeps is normally a Ram issue. When you know your bios, Ami /Award etc, it will tell you on the splash screen at first boot. then look here http://www.pchell.com/hardware/beepcodes.shtml to see whats what. You can download Mem test to test your system ram but i would think if anything its the cards memory thats bad as the beeps dont happen with the pci card. Oh and another thing that isnt that important but i beleive that the AGP Aperture Size is normally set at 64mb. dont know if this could be causing the problem but its worth a go.

    Mactronix
  24. Thank you both for all the help, I'll have to find another AGP card or a slot to test mine in. I started out thinking that the card was bad and that seems to be where I ended up again. I'll check out that Aperture Size and give Mem test a shot just to see if it shows anything. Thanks again for all the suggestions.
  25. Best of luck lama, post back and let us know how you got on

    mactronix :)
  26. Just to give an update on whats going on with the AGP slot.

    I have been unable to solve the issue I've been having thus far but later today I will have another AGP card AND another mobo with an AGP slot on it so I can test both my card and the slot on my mobo. I'll post back with the results when I can. Thank you all again for the help
  27. Hi,

    how did this go ? I have a similar problem. I noticed this in your thread :

    "AGP Device Video Controller (VGA Compatible) [1002-7A7A] [NoDB]"

    the '7A7A' is the device ID I get with my X800 & I'm wondering if that's what happens when it's been fried : It's not a valid device ID that's for sure.

    If you got your card working then there's hope for me ! (& vice versa)
  28. I got extremely frustrated with it and had absolutely no luck so I got a completely new gateway shell and mobo. The gateway had an AGP card in it and once I installed the harddrive and windows I was having the same issues. After following the steps for drivers for EVERYTHING it started to work perfectly. I sent my old computer over to my dad because he needed some of the parts and he tells me that the graphics card works flawlessly so it must have been the AGP slot on the board.

    Only thing that I can really add to this whole thing is to make sure that you have updated windows to SP2 with every single update you can find for it from the microsoft site. Untill I did that no matter how many times I installed the drivers for the video card in the current computer it would not show it as a functioning device. You could even go up to SP3 if you wanted (thats what was on my original system) but its not really needed in my opinion.

    I would like to once again thank everybody that helped me with this, I really do appreciate all the help that you gave. Thank You.
  29. You have to install the latest drivers from tuzhilin.narod.ru/drivers and try to download the drivers for your ati radeon
    x700 pro and download the drivers that has more megabytes and if there says that these drivers are for different windows series you just keep the eye on drivers size because for example drivers for xp are less megabytes.For example for win8 drivers are more megabytes.for example when it says the drivers are for vista or for win7 these drivers can be downloaded on xp also.why not.And you will see that agp is working in windows xp.Tuzhilin.narod.ru is the best way to download the drivers,because the latest inf drivers are there.
Ask a new question

Read More

Graphics Cards Graphics