Sign in with
Sign up | Sign in
Your question

Windows 7 RAID 0 Hard Drive problem!

Last response: in Storage
Share
March 2, 2010 12:30:43 AM

This is a long story abbreviated where possible.

Current computer (nothing overclocked ever)
i7 920, Asus P6X58D (most current Bios)
6gigs Corsair 1600mhz
285gtx
1 gig Seagate 7200.12 1gig
Windows 7pro 64
1Kw Antec PSU
1300VA UPS
All air cooled, checked with Real Temp and backed up with HWmonitor

Previous build was same CPU, memory and GPU. Had Gigabyte GA58x ud4p, vista 64 prem, 750thermaltake PSU, and RAID 0 (2xSamsung F1 750gig). Started getting Explorer crash "ntdll.dll" error. bought win7pro64, installed Raid 0 (Samsung F1s), still had error. bought new 1tb WD black, reinstalled win7pro64, still had error. Bought new Gigabyte GA 58xA ud5, 2nd WD black, reinstalled win7pro64, and Raid 0. "ntdll.dll" problem went away, had host of more yet less annoying problems. Bought new PSU, and Asus P6X58D and could not install windows7 on Raid 0.

Ok here is the hart of the issue. After installing Vista 64 via Raid 0, I was able to install Window7, Raid 0. But both of my Samsungs and now my WD's after having had Win7 in Raid 0, cannot have windows reinstalled on them. Bios can view them, and I can even set them as a Raid via the ICH10R (control I, while booting), but no matter what I do, windows7 will NOT view them as a drive on which an OS can be loaded. I have even tried installing them as IDE and just sata, one drive only, no joy. I have tried installing the driver for the ICH10R via the win7 install, and the driver loads, and still, NO drive available. Perfectly good drives appear to be locked out, and unusable. No matter what I try. I cant even get vista to see them.

So I bought a brand new seagate 1tb and installed Win7 (no raid), with out issue and without the need to load any drivers for the chipset.

Here is my question, are the drives locked somehow, and if so how do I unlock them? Or, did windows or some other problem I dont see, somehow screw these drives up forever and now they are just really shinny paper weights?

Any thoughts would be appreciated. Thanks in advance....

G
a c 415 G Storage
March 2, 2010 2:56:58 AM

Windows 7 will refuse to install onto a FAT partition - you'd have to manually delete the partition or reformat it as NTFS before Win7 will be able to use the space for installation. (Although how you could have got to that point based on your story is a little mysterious...)
a c 328 G Storage
March 2, 2010 1:36:35 PM

If I read right you had Win 7 installed on the drives, and the drives had been set up beforehand as a RAID0 array. In doing that you had to install the RAID drivers as part of the process. So far, so good. Now you try to re-install Win 7 and it won't recognized the drives as usable for the task.

When you try the re-install, are you FIRST telling the Install process to Delete any Partition it finds on the drive? After all, as far as Win Install is concerned, the RAID0 array is just a drive, and its looking for a drive with empty space in which to create a new Primary Partition for the installation. If your drive is already "full" in the sense that ALL of its space has been allocated to a Partition, there is NO space left for the new Install to use.

Actually, following the idea that you need to Delete any and all existing Partitions (which most certainly will DESTROY any old data on them) from the RAID0 array, it might be cleaner to use the Intel RAID management system (enter with CTRL-I). I expect within that you can take any existing RAID array and force it to completely rebuild the array, just as if you were starting to create an array from two blank new disk units. That process ought to re-write all the important parts and establish and format a new empty Partition. Just make sure that it is getting rid of ALL old RAID structures on the disk pair before re-establishing. If you do that, Win 7 Install ought to see the array as one empty new disk resource it can install to, and you're all set. Of course, you still will need to install the RAID drivers as part of the Win Install process.
July 31, 2010 11:56:44 AM

I also have the same problem with my WD 1tb drives. recently i had them running in raid 0. I had an error detecting the drives, and i've tried many ways to find a solution. i have removed each drive and tried to reformat separately but no success. when i load one of my 1tb drives it actually reads as a 2tb drive and will not format. i can load my drivers for the raid controller, and windows 7 will detect the raid array. but when i install it is unsuccessful, i think the problem is when i load the driver it is not stored to raid array? has anyone found a solution yet?
!