Sign in with
Sign up | Sign in
Your question

Very slow USB

Last response: in Motherboards
Share
January 22, 2009 9:39:30 AM

Hi all,
I'm after some advice as i'm not sure what to try next.
I'm suffering from extremely slow USB transfer speeds (400kb/s).
I'm using an asus p5n32-e motherboard with the nvidia chipset and vista ultimate 64-bit. I've found that a number of windows hotfixes for usb mention the nvidia however when i download and try to run them they say they are not relevant.
I'm probably being an idiot and missing something very basic but I can't seem to sort it.
Any advice would be great.

Thanks.

More about : slow usb

a b Ĉ ASUS
a c 216 V Motherboard
January 22, 2009 11:14:47 AM

Did you mean 400Mb/s? USB 1.0 maximum transfer speed is 12 Mb/s and USB 2.0 is 480 Mb/s. If you really get only 400 kb/s in Vista, what's the USB transfer rate if you boot from a CD and a different OS, e.g., Linux or BartPE with Windows XP?
January 22, 2009 1:22:05 PM

Yeah, I mean 400kb/s. I was transferring a 700mb file yesterday and it took over 2 hours. I've tried booting XP from a USB and that seems fine so i guess it's a windows issue but not sure what it could be.
Related resources
January 22, 2009 4:45:04 PM

Does this affect all your usb ports?
January 22, 2009 5:29:22 PM

Yes,
I have a usb hub on the side of my monitor and it affects that, as well as the two in the side of my case and the 4 in the back of the pc.
January 22, 2009 5:31:31 PM

Something to consider: if you have a USB 1.0 device
using the USB subsystem, all USB devices will operate
at that speed even if all USB ports are 2.0 (480 Mb/sec).

Try re-booting and testing the speed with a bona fide USB 2.0 device.

Also, your BIOS setting may be wrong for your USB subsystem;
and, you may need to update the USB driver(s) for your system.


p.s.
"B" is the recommended abbreviation for Bytes;
"b" is the recommended abbreviation for bits.

e.g.

"T" means Tera (trillion)
"G" means Giga (billion)
"M" means Mega (million)
"K" means Kilo (thousand)

"MB/sec" means MegaBytes per second
"Kb/sec" means Kilobits per second
etc.


MRFS
January 22, 2009 5:38:10 PM

MRFS said:
Also, your BIOS setting may be wrong for your USB subsystem;

MRFS


Why would he change the settings of the BIOS if it works correctly with XP?
January 22, 2009 5:49:13 PM

What is the exact model of that motherboard (download cpuz here if you're uncertain)

Then look up the manufacturer of that motherboard maker and see if they have any drivers for your Vista over there.

And by looking at several other forums I have seen that you're not the only one has problems with slow speed on the usb ports with Vista. Here's one forum where they discuss this also.
January 22, 2009 6:32:19 PM

Hi,
I have cpu-z and the mainboard is shown as:
Asus P5N32-E SLI with nForce 680i SLI chipset.

i took a look at that forum and there doesn't appear to be anything there that helps.

Thanks for your help though.
January 22, 2009 6:47:37 PM

I need to know what socket that motherboard has. Look in the CPU-Z program for this if uncertain.
a b V Motherboard
January 22, 2009 7:15:51 PM

khelben1979 said:
I need to know what socket that motherboard has. Look in the CPU-Z program for this if uncertain.


680i is lga775
January 22, 2009 7:20:44 PM

Go to this place and select your hardware and operating system in the list boxes.

They had some applications in the utilities section which might fix something. You can try that.
January 22, 2009 11:03:46 PM

Can't see any applications in there that would really do anything.
There's 2 utilities; ASUS PC Probe II and ACPI driver for ATK 0110 virtual device. Neither of which look like they would do anything.
And as alvine said, it's socket 775.
Running out of ideas a bit now!
Thanks though.
January 23, 2009 11:45:17 AM

look in the bios for something like 'usb high speed' or 'usb full speed'.. these are NOT the same. High speed is usb 2.0, full speed is 1.0. if you set for full speed, your bios programs the chipset to support only usb 1.0
January 23, 2009 3:22:30 PM

I've had this problem, but running XP.
When looking around it seemed to be a nvidia/board isue rather than a OS problem. Most boards use the VIA USB controller chip integrated on the board so its a non issue, but not some nvidia boards(my A8N-SLI Deluxe). Unfortunately, they also don't provide the drivers for it and rely on your OS.
Reinstalling XP with a sp3 seemed to fix it for me.
January 22, 2010 4:58:28 PM

So far I have read many postts and replies about SLOW USB ON VISTA.. and there has not been one solution posted.. anyone?.. Beuller?
January 22, 2010 5:09:30 PM

Are the latest service packs for Vista installed?
January 22, 2010 5:40:16 PM

I have the latest SP's.. and I am getting about 1.5 MB/s vs. the ~32 MB/s xfer rate on USB2 that I should get..
November 3, 2012 3:56:38 AM

I changed the file system on the flash drive to NTFS instead on FAT32 and it worked super fast like it was supposed to. Not sure why the default allocation was FAT32, but it worked for me....
!