Sign in with
Sign up | Sign in
Your question

Hard drive doesn't initialize in vista

Tags:
  • Hard Drives
  • Windows Vista
  • Storage
Last response: in Storage
Share
March 3, 2010 9:36:02 AM

I have removed a 2.5 HDD from my broken Fujitsu Siemens laptop (XP OS), Fujitsu MHT2080AT (yes, small disk) to copy data to my PC (Vista Premium x64) using a USB HDD casing. When that was done successfully, I started using it as an external backup drive. But after some time it did not show in my computer. I thought maybe the casing was broken, so I bought another one but with the same result.

In disk management it shows as “Disk 5” and needs to be initialized, but when I right click and chose initialize either MBR or GPT I get “Disk not ready”. First HDD casing was powered by double USB, and the second one has external power. I even tried to power it from the extra drive power cables inside my computer, but no luck.

I have valuable files on this disk, and I can’t find a way to retrieve them. Can anyone please help?

More about : hard drive initialize vista

March 3, 2010 11:45:24 AM

i have a question I have a toshiba external hard drive but my laptop compaq does not read or maybe see my toshiba
!