Sign in with
Sign up | Sign in
Your question

EP45-UD3R ... USB MOUSE WONT WORK

Last response: in Motherboards
Share
January 23, 2009 2:41:22 AM

I've just installed my gigabyte ep45-ud3r and installed windows xp. typically, the first time i hit the desktop i cancel all the 'found new hardware' wizards and install my mobo drivers. the problem i am having is that i cant get a mouse to work. if i plug the mouse into a usb port (ive tried 3 diff mice) it either does nothing (for a wired usb mouse) or starts looking for drivers (for wireless usb mice) and the driver install fails (im assuming because the mobo drivers are not fully installed yet).

the issue i am having is that the program that comes on the mobo driver cd makes you click on a button to install the drivers (you cant tab to the button and press space or enter, ive tried a million times now).

therefore, i can get to the desktop and do anything with the keybd (browse the web, look at my device manager, browse my hard drive). everything is working fine except i cant get the mouse working (i also tried plugging the usb mouse into one of those green usb to ps2 converters and still nothing). i dont have an old legacy style ps2 mouse but im not sure that would even matter would it? if so, ill try and find one from somebody but wanted to check here first. any guidance would be greatly appreciated!!!

thx,
cid
a b V Motherboard
January 23, 2009 12:08:24 PM

Welcome to the forums!

Try a different mouse. Also check the bios for USB and PS/2 options.
m
0
l
January 23, 2009 1:40:59 PM

tried 5 mice. finally got a true ps2 mouse to work but no usb. bios has all setting enabled for anything related to USB, PS2, MOUSE, etc.

ONe ohter thing of note, my device manager shows a SM Bus with an exclamation mark (mobo is GA-EP45-UD3R). could that have something to do with it? everything else in the entire device manager is working correctly (actually the pc runs fantastic except for this mouse problem)
m
0
l
Related resources
a b V Motherboard
January 23, 2009 3:07:38 PM

Did you install the Intel chipset drivers?
m
0
l
a b V Motherboard
January 23, 2009 3:25:48 PM

Hey arthurcid, I'll assume that you're running XP. What appears on your Device Manager? (Right click on My Computer > Hardware Tab > Device Manager) Are there still lots of question marks on the list, including beside the items under "Universal Serial Bus Controllers"?

If so, try installing the drivers manually (Right Click on item > Update Driver... to re-invoke Found Hardware Wizard). Make sure your driver CD is in before selecting Install software automatically.

Alternatively, you can also try downloading and installing the drivers from the official product page, and the bios update from here.

Do let us know if any of our suggestions help. Good luck! :) 
m
0
l
January 23, 2009 6:10:05 PM

ok, great suggestions. here are my responses. first, i installed the manuf sm bus driver (eliminating the ONLY exlam mark from my dev mgr) problem still existed (btw ALL usb show perfectly fine in my dev mgr). since it was possible that xp was possibly sp1 (from the install disk) and those drivers could have loaded before i got my mobo disk loaded, and now that im on sp3, i right moused on every usb controller and did 'uninstall', rebooted, windows found drivers adn put everything back. as far as dev mgr goes (and windows) everything appears to work normally. here is the last catch, when i plug in a usb mouse, i get the 'found new hardware' and 'installing drivers' (it shows HID-compliant mouse in the device name during driver installation) and then on teh 'finish' screen it says 'an error occured during the installation....THE DATA IS INVALID.' and after i hit finish, there is a mouse listed in my dev mgr (next to my ps2 mouse) with an exclam. i think the answer here is to figure out how to get the HID mouse driver to install. i have tried 5 mice (from 3 manuf microsoft, logitech and compaq) with same results.

to answer other questions, i did the bios update (to gigabyte's latest published version with no errors). i thought i had already downloaded and installed the inf driver (on the link that manic gave from gigabyte) but im going to try that again.

im getting to the point where i'm considering paying real $$ out to the person who can figure this one out :D 

let me know what you all think and ill post back here my progress...

LAST...THANKS TO YOU GUYS FOR YOUR TIME AND EFFORT...IT IS SO SO SO GREATLY APPRECIATED...
m
0
l
January 23, 2009 8:11:05 PM

update.... since i own both vista ultimate and xp pro, i decided to install vista and it wasnt even done unpacking files and my mouse is working (actually both teh ps2 adn teh usb are working simultaneously). i think this is a bug between the gigabyte board (chipset drivers for usb) and windows xp pro (it looks like in their readme file for the chipset drivers that they only support xp PRO 64 meaning they call out 9 opsystems Vista, Vista64, etc and leave out xp pro (non-64)). i could be wrong but wanted to share. ill keep posted on progress...
m
0
l
January 23, 2009 9:20:42 PM

update... vista running flawlessly, should have done that to begin with. I really think that plain xp woudl have work but there must be some problem with this board's chipset drivers and xp PRO (either that or the order that I did thinks on first boot hosed things up). Assuming I dont run into somehting odd, I'm good to go (technically I would have rather used xp instead of vista but at least i am not tethered to a ps2 mouse now)... thanks for the advice and lemme know if you guys have any followup questions...Cid...
m
0
l
January 25, 2009 9:35:10 PM

good luck
m
0
l
a b V Motherboard
April 21, 2009 6:47:47 AM

I actually experienced that "HID-Complaint Mouse" thing you were talking about. The only advice I can thus give is to reformat, because it went away for me after I did that. :) 
m
0
l
December 20, 2009 11:40:40 AM

I have the same problem. Back USB's not working very well under Windows7 64bit. Disk used is a proper genuine one (ultimate signature edition) direct from MS. Was working fine on my old motherboard. anyone had any luck at all? wildbear6@hotmail.com
m
0
l
!