Sign in with
Sign up | Sign in
Your question

Nforce4 Ultra Samsung HD502HJ RAID-0 mysterious problem

Last response: in Storage
Share
March 3, 2010 5:58:11 PM

Hello all,
I have joined your community in hopes of finding an answer to a very mysterious problem of mine.

I have had a RAID-0 array on my ASUS A8N-E motherboard (Nforce 4 Ultra chipset) consisting of two 160GB Hitachi hard drives (NCQ,SATAII) and everything was perfect for many years now even though the drives arent completely identical.

Now I bought two Samsung HD502HJ hard drives and I just cant get them to work in RAID, the problem is very annoying.
I disconnected my old RAID, connected the two hard drives to my SATA1 and SATA2 channels. Booted up the machine, entered the Nvidia RAID BIOS (4.84 at that time) and made an array, everything went smooth, I exited the BIOS, the array was marked as HEALTHY. I went straight to install Windows XP (SP3 integrated) and it found no drives althought it had no problem recognising my previous RAID (before SP2/SP3 yes, I had to hit F6 and feed the installers the nvidia raid drivers). So I rebooted the computer and this time the RAID BIOS just locked up at "Detecting array..."
I switched off the computer, then back on : boots up with no holdback , array is recognised instantly as HEALTHY. After reboot: it freezes at detecting the array.
After several days of testing this is what I have found:

RAID BIOS enabled : fresh start = raid found as HEALTHY, reboot: hangs at "Detecting array".
RAID BIOS enabled but the array itself deleted : fresh start = finds no arrays (the way it should be), reboot : hangs at "Detecting array"
RAID BIOS enabled, no arrays made, only 1 Samsung connected : fresh start = finds no arrays (the way it should be), reboot : hangs at "Detecting array" (same as above)
RAID BIOS enabled, no arrays made, none of the Samsungs connected : fresh start = finds no arrays (the way it should be), reboot : finds no array (way it should be)


RAID BIOS disabled : drives are instantly recognised by the BIOS (newest 1013 btw), Windows can be installed on any of the drives without problem.
RAID BIOS enabled : my old RAID drives reconnected instead of the two new Samsungs : array is recognised, my old system boots up flawlessly, no problems after any reboots.

I have tried new BIOSes for my MB but I already had the latest, so I looked up some modded BIOSes that had the latest Nvidia RAID BIOS integrated into them. I flashed this new BIOS without any problem , my new RAID BIOS is now of version 5.60 and Called Nvidia MediaShield capable of RAID5, but the problem still persists. Yes I remade the RAID every time.

I tried making a RAID-1 instead of a RAID-0 without success with various stipe sizes.
I waited for several minutes for the "Detecting array..." to pass and after a long time it just jumps on and I cant see if it did detect anything or not. Any time I enter the RAID BIOS (can only do ofc for the first time the computer is turned on, so not after a reboot) the array is said to be HEALTHY. Boot has been enabled and of course I always let him clear the discs after making an array.

The power supply is big enough to handle the drives, my motherboard is capable of SATAII, no overclocking has been made to any of the components and here is the complete list of them:
ASUS A8N-E (Nvidia Nforce4 Ultra Chipset) (basicly the same mobo as the A8N-SLI just without SLI) (watercooled)
AMD Athlon64 3200+ Venice (watercooled) (stock speeds)
2x1 GB + 2x512 MB Samsung memory in Dual Channel (stock speeds)
His Excalibur x800GT 256MB (has BIOS flashed to x800GTO) (watercooled) (stock speeds)


So...the question is, what is the difference between my old drives and the new ones and why does it only come when I reboot the system (XP cannot be installed even on fresh start)? I am suspecting that the drives are "not ready" to be detected by the RAID BIOS when it tries to detect them due to some speed differences and this is overcome when you freshly start the computer. I am trying to point out some sort of desynchronization that only happens on reboot, it really is just some random thoughts.
I have been trying to make this work for 4 days now.
I am completely out of ideas, ANY help is greatly appreciated! Thank you for reading this.
March 4, 2010 7:21:59 AM

One more information : my brother successfuly uses the very same hard drives in RAID-0 configuration with an external PCI card
June 6, 2010 10:45:32 PM

I have a similar problem with the same drive and an Asus P5QPL-AM MB. Sometimes the HD is recognized in BIOS and boots fine but eventually locks as if the drive is uninstalled. Searching for a solution, I found a few others have the same Asus/Samsung incompatibility problem. I'm guessing it has something to do with Samsung's Flying on Demand (FOD) head or the dual arm technology/firmware.
!