Sign in with
Sign up | Sign in
Your question

USB Headset, Microphone Not Detecting

Last response: in Components
Share
December 20, 2008 10:18:14 AM

I bought a Fatality USB Gaming Headset model HS-1000 and my computer is not detecting the usb microphone. Creative, the manufacturer, has been of little help, just a response email telling me to view information online at their site and blaming Windows for the problem. I did all that and it just doesn't work. Can anyone enlighten me on how to get it to work? I have a gigabyte P35-DS3R motherboard, running an Intel 8400 cpu, with 2 gig ram. Using Windows XP with SP3.
December 20, 2008 1:42:11 PM

i would reinstall the xfi driver / software and see if that helps at all.
m
0
l
December 20, 2008 7:29:35 PM

Thanks montyuk.. I tried a couple times. went into control panel, device manager, and deleted the drivers and re-installed the complete software. Still zilch. Apparently other people are having this problem, but have yet to find someone who has resolved this problem with USB microphone detection.
m
0
l
Related resources
December 20, 2008 7:42:12 PM

is this one of those items that you need to install the software prior to inserting the usb?

just wondering if that might be the case for this, i know it uses a firmware in the headset to control it all, and it does dolby and other effects, is it possible that one of these settings in the software has been set wrong?

is there anyway to test that the mic has been installed (but isnt working) ?

unplug, reset all settings to defaults (hopefully theres a key to do that), with the software open plug in and see if anything lights up or at least signifies that something has been recognised.

just for random - have you tried each and every usb port on your machine? including fronts..
m
0
l
December 20, 2008 8:05:31 PM

what program are you trying to use the mic in?

Most of the time, you have to tell the program to use the USB mic instead of the default one through the sound card.
m
0
l
!