Sign in with
Sign up | Sign in
Your question

Samsung Format Freeze Problem

Last response: in Storage
Share
March 4, 2010 3:25:49 PM

OK - so I got a SAMSUNG EcoGreen F2 HD154UI 1.5TB HDD, put it in, got it recognized, BIOS shows it as 1500GB, windows shows it as a little less (for obvious reasons), everything was going fine till I went to format it for use....
Tried it on 4 different SATA controllers, all with the same result. Format locks at 73%, will go NO further.
I cannot find a firmware update for the drive, like I said, tried the different controllers, I don't know what else to try.
I have an email in to Samsung, but hoping someone can help me fix the problem.
I even tried partitioning the drive into 2 750GB drives, and it wouldn't work. (Mind you, I do not want it divided like that, but was a desperate attempt to make it work at ALL.)
Any ideas?
March 5, 2010 12:10:07 AM

O yeah forgot - there is no update for my BIOS, it shows as 1500GB in the BIOS, Using VIsta 64-bit Home Premium, mobo specs and whatnot if they're needed.
This seems to be a fairly common problem with Seagates, but mine is (as stated) a Samsung, and none of the solutions for other people are working for me.... >_<
m
0
l
!