Sign in with
Sign up | Sign in
Your question

Windows does not detect my RAID1 Array

Last response: in Storage
Share
March 5, 2010 1:00:37 AM

I have two WD 1.5TB SATA Drives newly purchased. I'm running a system on an ASUS M2N-E Motherboard and an AMD X2 6000+ CPU with 4GB RAM.

My setup is 1x 80GB SATA for Windows, 1x 300GB "Dump/Download" SATA and 2x 1.5TB SATA's Mirrored (RAID1) for data storage. After some back and forth with ASUS, I understood that I had to enable the SATA RAID controller in the BIOS and enable RAID capability on the two SATA Ports for the two 1.5TB's. They also explained that the RAID Controller Drivers MUST be installed at the beginning of the Windows installation.

ASUS also explained that it is normal that the POST and my BIOS do not show the RAID drives present. I guess this is because the RAID Controller takes control of the drives.

So, I Enabled RAID on SATA Ports 3 & 4, and used the MediaShield Utility during boot (after POST) to configure the RAID1 Array. During the installation of VISTA 64 Ultimate, on the "Where do you want to install Windows" screen, I select the "Load Driver" option and proceed to point it to the directory where my Vista64 RAID Controller Drivers are located. It loads the driver and still does not see the 1.5TB RAID1 Array. I proceed through the install of windows, open Device Manager and the 1.5TB Drive is nowhere to be found. Windows DOES See that there are drives there because the NVIDIA RAID Controller software (MediaShield) attempts to configure the RAID Array, but fails to.

Please have a look at the pictures I've provided.

http://www.i-55.com/~scubasteve

My thoughts are that, perhaps, I might have the wrong drivers for my RAID Controller. I do not know what else to do at this point. I've spoken to at least 6 different techs at ASUS. One even told me that what I am trying to do isn't going to work because the capacity of the drives combined is greater than 2TB, but I found that to be false information when another tech confirmed that the 2TB rule only applies to when you are installing Windows on the RAID Array.

I guess I'm going to try nagging ASUS again this weekend for some answers and share these screenshots with them as I have just recently produced this simple webpage for visual aid. One guy at ASUS suggested I speak with nVIDIA since it is their RAID Controller. I might try that after wasting my time grabbing at straws with ASUS.

Thanks in advance for anyone who takes time to look into my problem. If you have suggestions as to what other drivers to try, please provide links. Thanks!
a b Ĉ ASUS
a b G Storage
March 5, 2010 1:44:10 AM

Your nVidia screenshot (10.jpg) shows error on the HDD on port 2.1
If you are using WD Black, and not RE HDDs, there is a known issue trying to install and maintain them in a RAID volume - sometimes they work and sometimes they do not. WD did not install the tler firmware for RAID hardware control on the newer versions of the Black HDDs (because they sell RE versions at a higher price than the Black versions).
m
0
l
March 5, 2010 1:53:34 AM

They're both Western Digital Caviar Green WD15EADS 1.5TB 32MB Cache SATA 3.0Gb/s 3.5" Internal Hard Drive

I bought them from Newegg.

I was assuming the error is showing up because the RAID Controller driver is not installed, or something to that effect is wrong. As I mentioned, during Windows installation when I installed the RAID Controller driver, it still will not display the 1.5TB Array in the list of drives/partitions available to install windows on.

I'm doing some browsing in the forums for RAID-related threads and I found this one: http://www.tomshardware.com/forum/256068-32-thinking-ra... In the threat, Paperdoc says "If you are simply booting from a "normal" stand-alone disk into Windows and then using a RAID array as a data storage system, the RAID driver installation can be done any time after Windows is running as you set up the new storage system." Is this correct? Because this is exactly what I am doing. I am installing Windows on the 80GB SATA drive and simply using the RAID1 of 1.5TB HDD's as storage.
m
0
l
Related resources
March 5, 2010 11:24:31 AM

Let me give you guys a little additional background to my situation...

Before I got on the phone with ASUS to understand what configuring RAID on my mobo entailed, I installed Windows 7 on my 80GB with my fresh 1.5TB drives hooked up (no partitions yet). After W7 installed, I went into Disk Management and went to format and saw that there was an option to Mirror the drives. Not knowing that this was a false RAID (Software RAID) configuration, I proceeded.

I hooked up one of my storage drives and started moving all my data over to the "RAID1 Array". I had left a drive copying data over and went to bed. The next morning, I woke up to see that my RAID1 Array was botched. Both drives were appearing in Disk Management as "Invalid". After reading a few forums, I goofed and converted one of the drives from Dynamic to Basic. I soon realized that it was a bad move because it wouldn't format my drive. I then got out my Recovery software and began backing up my data to a few empty hard drives I had lying around.

Eventually I was able to use Hiren's Boot CD to boot into Acronis and zero both drives while I had the RAID disabled. I got them both cleaned with new NTFS partitions on them, reconfigured the RAID1 Array and proceeded to try and load the RAID Controller drivers during Windows Vista installation. After several attempts, here I am posting on this forum.
m
0
l
January 24, 2011 3:49:40 PM

I was having nearly the same problem. I'm using an 80GB drive as my Windows system drive and two larger SATA drives mirrored (RAID 1) for data storage only. However, Windows would not 'see' my mirrored array, but was detecting it in the Hardware Manager. This is what helped me.

http://ask.adaptec.com/scripts/adaptec_tic.cfg/php.exe/...

Windows needs to partition, format, and mount the new drive array. This link gives you directions to do this from Disk Management. This took no less than searching with 4 different variations of the question and reading at least 12 different threads to find. I hope this helps someone in the future.
m
0
l
February 1, 2011 12:50:06 PM

Sorry I never followed up on this thread. I just got an e-mail notification that someone had posted to this thread and it reminded me to come post my update.

I was able to download the latest motherboard drivers for my nVIDIA chipset motherboard, which in turn loaded the latest RAID drivers. Everything worked smoothly from there.

ASUS was having me download the mobo drivers from their website, but they had a Really old driver collection available. I went directly to nVIDIA's website and found a much more up to date version of the drivers. Problem solved. Best of luck to whoever out there is still experiencing problems.
m
0
l
!