Sign in with
Sign up | Sign in
Your question

Visiontek ATI Radeon HD 4870 x2, PC freezes playing games

Last response: in Graphics & Displays
Share
October 25, 2008 11:34:59 PM

Hello guys,

Here is my PC configuration:

CPU: Intel Q9550 C1 @ 2.83 with Thermalright Ultra 120 Extreme and 120mm Scythe SY1225SL12SH "Slipstream"
MB: ASUS P5E3 Deluxe WiFi-AP@n BIOS 1303
Memory: CORSAIR 4GB DDR3 1333 TW3X4G1333C9DHX with CORSAIR CMXAF1 Fans
PSU: Rosewill RX950-S-B 950W
Video: Visiontek ATI Radeon HD 4870 x2
Case: COOLER MASTER HAF 932
HDD: WD Caviar 2500 JS 250GB x2
OS: Windows XP Pro x64 SP2c

When I play GRID, The Sims 2, and World in Conflict PC freezes. Sound freezes and starts looping. Video freezes too and sometimes gets all messed up. I can't do anything. No Alt + Tab, no Task Manager. Nothing. I can only restart it by pressing the Restart button on the case. I have the latest drivers for everything inside my PC. I have the latest MB BIOS. Video driver is Catalyst 8.10. I even reinstalled Windows with full format. I still get the same problem. However, I can play Fifa 08/09 and COD 4 for hours and it never freezes (best settings at 1680x1050). I have tried manually setting my video fan to 100%. It still freezes. I played 800x600 resolution and it lasted longer than 1440x900 or 1680x1050 but still froze. I tested my memory using Memtest86+ v2.01 for 12+ hours and it didn't find any errors. What can be the problem here? Does it sound like my video card?

Thanks in advance!
October 26, 2008 12:18:25 AM

Reinstall the Graphics drivers and the motherboard drivers. boost the fan speed to >50% in CCC or Rivatuner. Make sure to use driver sweeper to completely uninstall the drivers after you uninstall them through windows. Good luck.
October 26, 2008 6:16:02 AM

Thank you for your reply! But THIS IS a clean install (full format) of Windows. And I installed Catalyst 8.10 right away after reinstalling Windows. It didn't help. I've tried setting my fan to 100%. Not helping.
Related resources
October 26, 2008 6:17:44 AM

Also, I have the latest non-beta BIOS which is 1303 for my MB and the latest chipset drivers. Actually, all drivers are the latest ones.
October 26, 2008 4:16:42 PM

Did you try going to your card manufactures website to download the newest drivers? Also, you may wanna consider going one step down to the driver set released right before the newest set if you still have the problem.
October 26, 2008 5:23:29 PM

The newest drivers Catalyst 8.10. The previous version is 8.9. I have tried both. Same deal. I guess I have to put my nVidia in that PCI Express slot and see if it still freezes.
October 26, 2008 10:59:10 PM

Do you think my PSU could be the reason?

By the way, I noticed something else. OCCT passes 2 hour CPU test but crashes after 10 minutes of 2 hour RAM test. However, Memtest86+ passes for 10+ hours without any errors. I set my RAM to DDR3-1333 9-9-9-24 2T 1.60v in BIOS. That's what's written on the DIMMS. These are THE ONLY things I changed in BIOS. However, sometimes when I reboot my PC, it won't post and says Overclock Failed Press F1. So, is it possible my RAM is failing even though it passes Memtest86+?
Anonymous
November 16, 2008 7:59:42 PM

Hi, I have the same problem with my card (Sapphire Radeon 4870 HD 512MB). I found somewhere that it happens when the card is autoswitching from 500 to 750 MHz and it's recommended to use software like RivaTuner to force it work at a fixed speed. Though it still freezes for me and I've been searching the net for days now and there seems to be no real solution to this problem.

Check out this thread, maybe it will help you:

http://forums.amd.com/game/messageview.cfm?catid=260&threadid=100973
Anonymous
November 23, 2008 8:14:28 AM

I had exactly the same problem as RealSnaD, and performed the RivaTuner fix and still it didn't work. I realized that my boot up seemed longer than it should be so, I started uninstalling each of the Asus P5Q3 Delux drivers one by one.when I got to the Marvel 61xx Raid controller, my boot up was considerably faster and the problem was solved with my Warhammer online video card issues/Freezes (similar to those RealSnaD was experiencing). I believe the issue is that this driver doesn't support my old DVD-ROM property which caused a bottleneck. By uninstalling the Marvel 61xx Raid controller I can't access my DVD-ROM, but I'll just go buy a new one with its own new drivers. This worked for me, and my driver issue with the DVD-ROM was causing a bottleneck. Good luck.

Stephan
!