Sign in with
Sign up | Sign in
Your question

Sapphire Driver issue

Last response: in Graphics & Displays
Share
Anonymous
October 29, 2008 7:35:28 PM

Hello,

I recently decided to upgrade my outdated gaming platform's video card with a Sapphire ATI HD3850 AGP card in which appeared to suite my computer very well judging by the stats.

So here's my problem... I upgraded from an Nvidia Quadro 4 900xgl pro and now I'm having some screwy results...

Here's what's happening...

  • I know this is not a faulty card because my friend has the same card and I tried his in my machine and recieved the same results.
  • I've installed countless drivers off of sapphire's site, ati's site, and even omega drivers. Old and new versions... Yet, I still get lag when dragging windows accross the screen and an error when starting any game claiming that direct X is not installed, when it clearly is.
  • I've compeltely scrubbed my system clean of NVidia drivers and even reformatted my whole computer but the same problem exists.
  • When I start windows, my computer monitor flickers from black, to normal, then to black, then to normal and eventually it stays normal.. By normal I mean the display of windows is present but I still get the signs of the lack of a driver... even though I have tried pleanty.
  • I've completely updated the bios and chipset drivers of my machine.
  • According to the required specs for the graphics card, my computer matches them all by a mile... Including my powersupply which is 460w.

    Here's my computer...

    HP Workstation, xw6000
    (You can look up the specs from HP's website)

    I'm running duel xeon processors and I have 1 gig of ram, and as I said, my powersupply is a 460w.
  • More about : sapphire driver issue

    October 29, 2008 8:12:04 PM

    Have you used DXDIAG (in XP, click START, click RUN and type dxdiag) to check your DirectX files? Maybe they are just outdated because as far as I know thay are not routinely updated by Windows update. The current general version is 9.0c.
    Anonymous
    October 29, 2008 8:37:05 PM

    As I stated, I just reformatted.. Plus, I did reinstall directx and I did have the newest version to begin with...

    One should be able to run their computer with this card without direct x even installed and not get this issue. It's highly unlikely direct x has anything to do with this.

    Is it possible this has anything to do with my AGP Aperture size in my BIOS?
    Related resources
    November 2, 2008 10:00:25 PM

    I have the same card as you and had my own problems with it. Here's what you need to do to hopefully fix it. Go to the ATI website and download the latest hotfix for the card. If that doesnt fix the problem then your going to have to update your motherboard bios. Another thing to watch out for is that the fan can die on you, its a major manufacturing defect that a lot of ppl have complained about. KEEP the bill and box encase you need to send it back
    May 6, 2009 5:19:34 AM

    I have the same rig and have tried to install a powercolor radeon 3850 agp with exactly the same results.
    I have not been able to find a definitive answer for the problem.
    I was hoping to run some pixel shader 3 games which the aging quadro does not support.
    Another post confirmed that a nvidia 7600gt agp will work in this machine, but it in no way quite matches the specs of the 3850.
    I would love to know if this card would work but it looks increasingly like I am going to have to try and get my money back on it.
    mungers
    May 10, 2009 11:21:06 PM

    I have now got the card to work flawlessly and it was actually pretty simple to fix.
    After contacting Powercolour support, i was given a few tips and all I had to do was change the AGP apeture setting in the bios to 256 (it was set to 64) and install the catalyst 9.4 agp hotfix drivers and it worked no trouble at all. I have been playing half life 2 ep1 and ep2 where I have now got glorious hdr lighting and cool reflections at 1920 x 1080.
    I also tried Colin McRaes dirt (bit of a resources hog) which works nicely at at a lower resolution and lower graphic settings.
    !