Sign in with
Sign up | Sign in
Your question

Very odd Network card issue (I think)

Last response: in Toms Network
Share
June 5, 2009 4:30:11 PM

I have an ASUS P5K SE mobo with an on-board Atheros L1 10/100 NIC.

I have had minor networking problems in the past but always put that down to the application that I was using at the time but a recent accidental discovery has me very confused...

Before I start I am having problems with 3 recent games that I have been using as tests for this, (have had problems with more in the past but these 3 are fresh on my mind and currently installed for testing).

Company of Heroes (CoH) often has problems with not being able to connect to hosted games and people not being able to connect to mine (a pier-to-pier hosting system)

Dungeon Keeper 2 (DK2) (oldie but a goodie) - others cannot see my game (LAN). I can see other people games but cannot connect to them.

Rainbow 6 Vegas 2 (R6V) - Can only connect to a few games and am having huge lag issues with a friend over a Hamachi virtual LAN (we have no lag issues with any other games, file sharing is hit and miss). Have also tried playing through the web with the same result but lag could be due to intermediate steps.

EDIT: Stripped out a lot of useless info as I isolated what is going on at last!

Long story short... the above mentioned problems along with a host of other minor annoyances completely disappear if I uninstall all the services and protocols from my Local Area Connection and then uninstall the NIC and reboot.... once windows has reinstalled the card I add all the services and protocols back in and everything works! Interstitially just uninstalling/reinstalling the NIC doesn't work at all.

The problem is that every time I reboot the problems come back, as it stands I would have to uninstall everything at shutdown and install it all again on boot, or go though that every time I wanted to do anything more than file shearing.

Is there a likely cause for this? I think a registry entry might behave like this (taking affect after boot but not immediately on install). If I'm right where should I be looking and what settings might have this effect?

Any help would be greatly appreciated!

More about : odd network card issue

June 6, 2009 9:43:42 PM

Are you using the latest drivers from Atheros? Are you connecting to a modem, a hub, a switch? What speed and mode?
June 7, 2009 3:19:12 PM

Its an ADSL 2 connection to the web but the web always works (except when the NIC is uninstalled of coarse). This PC and another I use to test DK2 are linked via a switch, the switch connects to a router for web. Latest drivers all round (MoBo, NIC & Windows). The network speed is 100.

The only other thing I have noticed is that I often get the task bar icon showing 'Acquiring network address' but I cant recreate that yet, it also appears to have no effect on the programs I'm using for testing at the moment, nor web access.

Now that I think about it, I haven't tried uninstalling services/protocols/NIC and reinstalling without a reboot, will see if that works now.
Related resources
June 7, 2009 3:39:32 PM

Are you using Auto or are you forcing the speed to 100 Mbps/Full-Duplex? Auto doesn't always work well, particularly at 100 Mbps.
June 7, 2009 4:17:50 PM

Its on auto since not everything in the network is at 100mb, I can try forcing and see what happens between this and the slower card.

Also a I just discovered that I dont need to reboot, uninstalling service ect and NIC via device manager, then using 'Scan for Hardware Changes' and reinstalling the services fixed up the 3 test games but doesn't allow me to reinstall client for MS networks until I reboot.

EDIT: Just forced 100/full, no improvement.
June 7, 2009 5:11:41 PM

Are you using static IP addresses or DHCP? If DHCP, what provides them? I don't understand why you have to reinstall. When you have the problem, what happens if you type the following commands from a command prompt (if you use dynamic IP addresses):

ipconfig /all
ipconfig /release
ipconfig /renew
ipconfig /all

Does "ipconfig /renew" work? If so, anything different between the two "ipconfig /all" commands?
June 7, 2009 5:44:28 PM

Dynamic IP, set by the router. DHCP enabled, router set to DHCP Server. No improvement with the ipconfig commands and no difference between the two /all configs.

Just thought of something else too, my security software is pretty extensive, I have been turning it off for testing this to rule it out but it starts on boot, will get the reinstall the network and reboot after removing them from MSCONFIG.

EDIT: Ok now I feel like a complete moron, sure enough that was the problem, will have to re-enable them 1-by-1 and reboot each time to find out whats doing it.

Can't thank you enough for the help though GhislainG, its really appreciated!

Now.... back to smacking my head on the desk for missing such a basic diagnostic step.

EDIT 2: Ahh the irony, now I can't get anything to break my network again... I suspect firewall but after the amount of time I have spent on this I'm taking the 'If it aint broke don't fix it' approach!
June 7, 2009 6:29:37 PM

I know how you feel. I had a system intermittently losing connectivity and it took me a while to figure out that the LAN drivers were the issue. The manufacturer eventually released a version that worked fine and it has never failed again.
!