Sign in with
Sign up | Sign in
Your question

Only 3.5GB of 6GB memory recognized

Last response: in Motherboards
Share
January 29, 2009 3:38:23 PM

Motherboard
Gigabyte GA-P35-DS3R

Chip
Intel Core 2 Duo E6750 Conroe 2.66GHz 4M shared L2 Cache LGA 775 65W Dual-Core Processor

OS: Ubuntu 8.10

Memory 6GB total
2 x G.SKILL 2GB DDR2
2 x G.SKILL 1GB DDR2

When I turn on my computer, the motherboard is recognizing the 6gb of memory, but when I go into Ubuntu and look at my stats it says only 3.5GB. How can I get Ubuntu to recognize all 6GB? Is it possible?
January 29, 2009 4:04:40 PM

Ensure that you have installed the 64bit version of Ubuntu. It sounds like you have the 32bit version installed. 32bit OSes can only address 4Gb or memory (this includes video memory), thus you getting only 3.5Gb.
January 29, 2009 4:07:29 PM

If it is 32bit, you need to have PAE enabled
Related resources
January 29, 2009 4:17:52 PM

Do I enable PAE through the bios or Ubuntu?

Thank you for your help.
January 29, 2009 4:20:01 PM

Do I need to install the 64bit version of Ubuntu in order to get all 6GB working? Or will enabling PAE get them working..

Are there other advantages to getting the 64bit version?

Based on my components am I 64bit compatible? (I believe I am)
January 29, 2009 4:58:51 PM

If I'm not mistaken, you will need to enable PAE in both BIOS and OS. In my BIOS its called Allow > 4Gb Remapping, not sure what it's listed as in a Gigabyte BIOS. Your parts are 64bit compatible, and yes there are advantages for applications written in 64bit. They will handle memory intensive operations much faster.
a b V Motherboard
January 29, 2009 8:00:34 PM

PAE is too unstable to be used, and even then, doesn't grant proper 64-bit support. If you want more than ~4GB RAM, get a 64-bit OS.
January 29, 2009 8:14:34 PM

That is the route I am taking. I am downloading 64bit Ubuntu right now and will install later tonight. Thank you all for your help.
January 29, 2009 11:10:37 PM

64 bit version will fix the problem... stay away from PAE... used it ... dumped it..... not really ready .....
!