Sign in with
Sign up | Sign in
Your question

2.5 HDD in USB/eSATA enclosure problem

Last response: in Storage
Share
March 10, 2010 6:09:52 AM

Hi folks,

My old WD passport died on me so I bought new Seagate Momentus 7200.4 HDD and an external enclosure with USB and eSATA interface.

when I connect it to my computer (Vista Home premium x64)it is recognized as a USB storage device but can not do anything with it. I checked under the "My Computer/Manage/Disk Management" and I see the disk. I tried to format but it is saying that the disk is not initialized...

Can you help me how to initialize/start using this disk?

Thanks!
a c 353 G Storage
March 10, 2010 1:10:32 PM

from control panel goto then Computer management, then disk management. Click on disk and intialize, then partition and formate.
a c 348 G Storage
March 10, 2010 2:43:45 PM

Many miss the detail that Format is the SECOND operation. BEFORE you Format a drive, it must be Created. That is, you first Create a Partition on the physical unit - this sets aside a specific chunk of disk space to be treated as one logical "drive" with its own letter name. THEN you Format this "drive" - that is, you install its File System.

In some versions of Windows Disk Management these two functions are carried out separately in the correct sequence, and that may be your problem - it appears you are trying to Format with no Partition to work on. In other systems the two functions are combined into one helpful Wizard, simplifying it and leaving the user unaware of the process. But in either case, this work is done ONLY in the LOWER RIGHT pane of Disk Management by RIGHT-clicking on the Unallocated Space of the new disk unit.
Related resources
March 12, 2010 8:37:08 PM

Thanks for t he replies :) 

actually I know that should be initialized but I couldn't find it... so at the end, I found it...

thanks again
February 15, 2011 9:38:20 AM

I was actually Googling re problems with a particular brand of 2.5" ATA caddy, as it would appear that my Conico caddy has failed but I wanted proof... anyway, I came across this as a result, read the previous posts and decided to weigh in with a word of caution:

Tech guys, please, PLEASE, P-L-E-A-S-E be careful when dishing out the old "initialise and format" routine, as it can result in needless loss of data! Sometimes it can be the case that it's the CADDY that's at fault.

I inserted a Toshiba MK3021GAS drive into my simple red Conico cadd a couple of days ago and went to run a CHKDSK and defrag on it, but it kept coming up with funny spellings for the drive when it was trying to install the driver/s for it (e.g. "TORHH~ LK2010GGS" or "UOHIBA MR3022GAS")... but after I took the caddy apart, blew on the circuitry and ensured the pins were making good contacts with the caddy's interface, I reassembled it and tried again... and it WORKED!!! So much so that the data that was on there appeared as if by magic!

However, when I brought it into work, it started playing up again! It was one of the tech guys that told me that it was probably dry joints or failed/failing components on the caddy's circuitry!

So be warned! :pt1cable:  :wahoo:  :whistle: 
!