Sign in with
Sign up | Sign in
Your question

Error booting PC (disk read error at boot) - using RAID 5 array

Last response: in Storage
Share
March 11, 2010 11:10:27 PM

Hi there,

I have recently obtained a server, running Win Server 2003, and with 3 SATA hard disks in a RAID5 array using an Intel Raid controller card. The machine was working fine until I unplugged a couple of the hard disks. I made the mistake of trying to turn on the computer while it only had one disk plugged in.... Obviously, it did not boot at that stage. I then plugged all the disks back in exactly as they were before and the machine still failed to start, however it was making really annoying beeps (due to a failed Raid array, I think)! I managed to go into the RAID setup and restarted those drives (which were indicating that they had failed, apparently because there is inbuilt protection to stop failed disks being reinstalled - not because they had actually failed.). This appeared to restore the logical drive so it was listed as "Optimal" in the Raid setup. I have checked the logical drive for consistency (which went through fine).

When I try to boot the computer, I get the error "A disk read error has occurred. Press ctl+alt+del to restart". The BIOS shows no hard disks installed - only the RAID card.... and this is set to be the first boot device. (I also get the error 51A2 - indicating that the server case was opened but that is no big deal, I don't think!).

Can anyone please offer any suggestions?

Thanks in advance for any assistance...

Regards,
Jack.
March 16, 2010 1:46:10 PM

Hi Jack,

I had exactly the same problem as you, one day later. Unfortunately I have not found any solution for that, but here it is what I did:
Summary: Windows 2003 server with 3 HDDs in RAID5. Server is part of domain forest, as DC. The system partition is too small, so I had to replace with other HDDs.
First I created a ghost image, and then tried to replace the HDD one-by-one. After the first replace, system crashed. Even after replacing back the original HDD and rebuild of the array, I got the error message "A disk read error has occurred. Press ctl+alt+del to restart" Nothing helped. I tried many partition program, Partition Magic said Error #1507 - Bad file record signature. I think the reson was that the MBR was incorrect. I tried to reset the boot record, but nothing helped.
Solution:
I have changed all 3 HDDs to the new ones, and built a new RAID5 array. Created a new partition for system with the CD what I had for my IBM server, and restored the ghost image.
And I could restart the server!!
And faced other problems, related to replication in the domain forest, but this is another story...

Regards,
Gábor
m
0
l
March 21, 2010 12:38:12 AM

Hi Gabor,

Thanks for the reply and the information regarding your situation.... It's good to hear that you resolved your Raid problem! Unfortunately for me, I don't have ready ghost image to use to restore the server (I know, I should have created one before doing anything - however, the critical data has previously been backed up, and also as I was not planning on making any changes to the hardware I did not expect to lose the ability to boot the machine!).

I am now leaning towards something similar to your solution - a new installation on different disk(s) (probably not Raid) and then either try to recover the Raid array from within WIndows (or Linux) or simply try to recover, and then backup, the data on the existing drives. Will update when issue is finally resolved (unfortunately, I have had no time to look into it recently so it may take me a little time to get around to it!!).

Cheers,
Jack.
m
0
l
!