Sign in with
Sign up | Sign in
Your question

Caviar Black RAID0 - sudden performance loss

Tags:
  • Hard Drives
  • Performance
  • Western Digital
  • Caviar
  • NAS / RAID
  • Storage
Last response: in Storage
Share
March 12, 2010 12:30:35 AM

Hey everyone, I've got a strange issue...

I have two WD Caviar Black 1TB's. One is 7 months old, the other is 2 months old. I set them up in RAID0 two months ago. At the time, it worked great. They continued to work great, until a couple days ago. I noticed games having really long load times, and all kinds of weird stuttering effects in-game (sounds wouldn't load and would pause, etc). Here is a comparison of my HDTune results, 2 months ago and today:

http://i92.photobucket.com/albums/l7/kylewilcox/RAID_De...

This was my first attempt at RAID, so I have absolutely no idea what to do or what info to give for assistance. There is no data loss, the drives function but they are just a lot slower. Is this an effect of these drives not having TLER? Should I consider using these drives singularly instead of in RAID? Any input is much appreciated!

Thanks.

More about : caviar black raid0 sudden performance loss

March 12, 2010 1:03:40 AM

In a stroke of super-genius I realized I might as well try reinstalling my mobo chipset + RAID drivers. Seems to have fixed it. Now I'm left wondering why they would have gone kaput? Oh well, if anyone has any other input please feel free!
m
0
l
a b G Storage
March 12, 2010 6:24:07 AM

You have to decide what type of controller set for your hard disk, In your BIOS you can choose RAID, AHCI or IDE (pls refer to your mobo manual). Then when you restart your computer you choose what type of RAID 0, 1 etc. then when you install Windows Vista you need to load drivers for ICHxx you can download this one (pls refer to your mobo manual on what type of ICHxx supported. After windows is installed install an updated software for chipset, audio, lan, etc. It is always a good idea to check your mobo website for an updates.
m
0
l
Related resources
a c 127 G Storage
March 12, 2010 10:45:12 AM

What makes you think its slower? I can't judge that from your screenshots; you may have changed the Write Caching option, other than that it shows to be fine.

Could you download HDTune Pro and do a File system benchmark also? The normal benchmark is not really suitable for RAID-arrays; and should only be used for dumb separate disks not for any exotic RAID array.
m
0
l
March 12, 2010 11:22:03 PM

hmm, unfortunately this came back today - I guess reinstalling my RAID drivers didn't fix it, even though it did go away for a bit.

dEAne, I think you misinterpreted me. I've already installed RAID just fine. Thanks for taking the time to reply, though...

sub mesa, maybe I should have pointed out a few things. First, note that the scales are different on the graphs. The numbers pretty clearly show a massive performance drop; minimum 110 MB/sec has gone to 0.2 MB/sec., and maximum 214 MB/sec has gone to 172 MB/sec. Average throughput is still okay, but it's the constant drops to 0.2 MB/sec that is killing me - when a game has to keep loading textures or sounds, it keeps dropping to that transfer rate and the game has to pause for whole seconds until the drives recover and actually load the data.

Also pay attention to the fact that I overlayed two benchmarks on the bad side - the faint background one which constantly spikes down to 0 MB/sec shows what it's like if I'm doing anything that uses more than 0% CPU - i.e. surfing the net, writing in notepad, or even just having my antivirus active. I had to disable literally every background process to get it to make the "wavy" graph.

this is a more typical HDTune result for me right now:
http://i92.photobucket.com/albums/l7/kylewilcox/HDTune_...

Thanks again for your time, if anyone has any further input I'd love to hear it!
m
0
l
March 12, 2010 11:39:10 PM

WD purposefully programs the Caviar Blacks to fail in RAIDs. They want you to pay more money for an RE4, so they make it so that Caviar Blacks fail constantly in RAID, constantly entering some sort of 'Deep Recovery Cycle'. Every review you'll read will say that the Caviars don't work in RAID.
m
0
l
March 12, 2010 11:57:12 PM

I guess that's sort of what I've read now too - except I have read of some rare people getting them working fine. They were working beautifully for me, for 2 months... then all of a sudden just dead, presumably due to this. :(  I had hoped that since they worked for me for so long, they'd just continue to!

maybe it's time to support another HD brand :kaola: 
m
0
l
!