Sign in with
Sign up | Sign in
Your question

Problems with 32GB SSD

Last response: in Storage
Share
March 12, 2010 6:54:33 PM

Hi There,
I've just bought a 32GB A-RAM Alpha Series SSD to put in a computer I am building for a friend....Problems from the first power on!

First of all, it was recognised by the bios as a 4GB drive called "JM00001" (or something similar). I didn't take much notice of this at first, but when I got to the partition manager in the Windows 7 installer and saw that the drive was being reported as 4GB there, I took more notice. I immiedatly looked through my order and then at the sticker on the drive itself to verify that I had infact ordered and received a 32GB rather than a 4GB.

I found after a few attempts installing various versions of windows, that the drive will most of the time detect as a 32GB drive called "ARSSD32GBA". When it does detect as this (what it's meant to be I guess) the Windows 7 and XP installers will hang (Windows 7 just goes to black screen after the "Loading Windows" + Logo screen and XP just hangs at loading partitioner).

I connected the SSD to my main computer via USB and it showed up correctly in the disk manager as a 32GB SSD however, when I tried to partition/format the drive it returned an error - "Windows could not complete the format." ...I next tried my luck by connecting the drive to a free SATA port on this same computer. This resulted in a hang at the "Starting Windows" screen. Starting in safe mode got past this hang but attempting to format the drive had the same issues as via USB.

Next I connected the SSD via USB to one of my laptops running Linux Ubuntu (thinking "linux can do it!"). To my surprise changing anything about the drive failed. It even had a read/write error when trying to change the drive label. At this point my hope died. In my experience, if Windows can't do it, Linux can, and if Linux can't....well your f**ked.

From here I tried a bunch of utilities including the linux distro "Parted Magic" and many tools from the Ultimate Boot CD. All of these tools had read/write errors when trying to change the drive. I couldn't even change the MBR! The only tool that seemed to do anything was Boot n' Nuke..but that might have just been ignoring errors (error count was 0 though...).

All that happened yesterday, and now I've tried once more to install Windows 7... this time the drive was detected as 32GB AND THE INSTALLER DIDN'T HANG! ...unfortunately trying to delete, change, and create partitions on this SSD failed again with the error: "Windows could not format a partition on disk 1. The error occurred while preparing the partition selected for installation. Error code: 0x80070057".

I'm going to take the drive back on Monday and get a refund rather than a replacement...I've never had any problems with hardware out of the box until this. Luckily I bought a 500GB Caviar Black for storage.. I guess I'll just have to install Windows on that drive...

If anyone has any suggestions or comments they'd be greatly appreciated!

Stecman

More about : problems 32gb ssd

a c 127 G Storage
March 12, 2010 7:11:36 PM

Hmm, sounds like you tried alot already, and that this is a case of hardware failure; you've gotten a defect unit.

Your SSD uses Indilinx Barefoot controller by the way, so it should be a decent SSD.

It might have been a cable issue too, but as you used the USB interface (the SSD has one i assume?) that's pretty much ruled out either.

Don't be too demotivated about your (first?) SSD experience. They really are better, but perhaps A-DATA doesn't have that good quality control, to weed out the bad samples before they get shipped to the customer. Your next SSD experience should be a lot better.

Generally, i still highly recommend the Intel X25-M 80GB - or the X25-V 40GB if you're on a budget. Their pricing is in line with other SSDs, but Intel has a very good controller with lots of advantages, one being random I/O performance the other being endurance, due to having a low write amplification ratio.
March 12, 2010 7:43:04 PM

I'm building this system for someone else who has a budget, that's why I went with a lower cost SSD...I love SSDs - my own computer has one as an OS drive! This experience hasn't put me off SSDs in anyway, just reminded me that you get what you pay for...

Thanks :) 
Related resources
a c 353 G Storage
March 12, 2010 8:23:25 PM

stecman, did you go to web A-RAM web page an see if they have a utility program for that drive. Remote possibility is that the very first attemp to write to the drive (identified incorrectly) hosed something up that would be corrected by "Wiping" the disk. I have had HDDs that once messed up, I had to use the manuf utility to "fix" before I could do anything with that disk.
March 12, 2010 8:56:53 PM

Just looked.. They have only have a utility to speed up drives that have slowed down...and it requires having Windows installed on the SSD
a c 353 G Storage
March 13, 2010 5:12:53 AM

yak
What about firmware updates (Not That you would do it)
!