Sign in with
Sign up | Sign in
Your question

Memory speed is only 400 MHz instead of 1066

Tags:
Last response: in Memory
Share
February 5, 2009 11:10:47 PM

I have 4 sticks of (2 dual lots) of Kingston Hyper X (KHX8500D2/1GN) that are supposed to be running at 1066 MHz but according to HWinfo, Everest Ultimate edition & CPUz they are only running at 400.0 MHz

Can someone please tell me how to fix this or what is going, I am totally stumped. I'm not into overclocking but I would like to have the memory running at least close to what they are supposed to be doing

Any help appreciated

My system

Intel Core 2 Duo E6850 CPU
2 x 2 GB Kits Kingston Hyper memory 1066MHz
MSI P35 Platinum Combo
Creative X-Fi Titanium Pro Soundcard
Geforce GTX 285 Video card
Thermaltake 1000W Toughpower PSU
WD 250GB SataII HD
4 x WD 500GB SATAII HD
2 X Samsung 1TB HD
Compro T750 HDTV Dual Tuner PCI Card
Thermaltake Bigwater 745 water cooling
Samsung 226BW 22" monitor
Samsung Syncmaster 913 19" monitor
a c 80 } Memory
February 5, 2009 11:18:34 PM

CPU-Z reports the real frequency. 400 Mhz x 2 (DDR2) = 800 Mhz. You can increase the frequency to 1066 Mhz (533 Mhz x 2) manually. Also increase the voltage to match the specs at 1066 Mhz.
February 5, 2009 11:33:00 PM

Most of the time 1066 memory will be set as 800 by default, like said above you can set it manually in BIOS to the values its rated for.
Related resources
February 6, 2009 1:01:40 AM

The OP bought manufacturer-overclocked RAM. The "auto" settings on your MB will only set standard RAM settings, not overclocked ones, so if you want your RAM to run at the factory overclock spec, you will have to set it manually in the BIOS. You will need to do 2 steps:
1) Look for the spec voltage (should be printed on the DIMMs). It will almost certainly be higher than the DDR2 standard 1.8V -- perhaps something like 2.0V. If it's a range of voltages, use the highest voltage in the range. In your BIOS, set the "DIMM voltage" or "RAM voltage" or equivalent setting to that voltage value. Save your BIOS changes and reboot.
2) Go into the BIOS again and manually set the RAM timings to those in the manufacturer's specs for your specific modules. Save the BIOS changes and reboot.
February 6, 2009 3:07:33 AM

I put the voltage up like suggested and did the timing both to the specs on the Kingston page. I have it stable at 437.7 MHz, can't seem to go any higher without blu screens, I am a novice at this though lol

Also my CPU core speed is now 3151.2 MHz with x9.0 multiplier, bus speed is 350.1, rated FSB is 1400.6 MHz
February 6, 2009 6:29:08 AM

bel - since your FSB at 1400MHz datarate is the data bottleneck between RAM and CPU, you aren't getting any benefit from running your DIMMs at faster than 1/2 that, or DDR2-700. Set your RAM to 1/2 the FSB datarate, and that should make your system more stable without decreasing performance at all.
February 6, 2009 6:43:46 AM

your losing me now lol.

I do appreciate your help though
February 6, 2009 9:04:54 AM

take a look at the SPD tab in CPUz. Your RAM doesn't support EPP but there will be JEDEC ratings. It is often the case that 1066 Mhz RAM is actually 800 Mhz RAM overclocked.

The SPD tab will show you what freq you can get at what voltages and timings.
February 6, 2009 9:44:13 AM

I don't know if I am allowed to dothis hear but here is a shot of my CPU-Z screen

February 6, 2009 3:57:54 PM

Random, it seems that your RAM does support EPP.

Ok well from this it is clear that to run the RAM at 533 Mhz you gotta supply it with 2.2v. (its currently running at the first JEDEC rating).

Do this in the BIOS then run memTest to check its stable.
February 6, 2009 9:32:19 PM

Thanks, do I need to change any other settings to keep up with these changes you suggested?

February 6, 2009 11:24:14 PM

Find In Bios:

CPU (CIE) set to Disable
CPU EIST set to Disable
CPU Host Freq. 400
PCI Express Freq. set to 100
Perf. Enhance set to Standard or normal.
Memory Multiplier set to manual and adjust to increase the Memory Freq.
System Voltage Control set to Manual
DDR2 Overvolt Control set to Manual and +.1 / +.2 / +.3 or what ever it takes to get you Memory to run at the specified voltage.
PCI E Volt set to normal
FSB Volt set to Normal
CPU volt Control set to normal and read th next line.
Normal CPU vcore... this is your VID. What is it ? 1.325
If it is go up to CPU Volt Control set to Manual and set the volt to 1.35 or just a couple of tenths higher than VID.
ESC and F10
CPU=3600mhz
FSB=1600mhz
Run your tests.

I will try to check back later.
February 7, 2009 12:17:28 AM

LoL
February 7, 2009 2:15:02 AM

changed the timing to 4.4.4.12 & 5.6.6.15 and nothing changed
February 7, 2009 3:44:31 AM

CPU Ratio 9

Memory Ratio for Adjusted DDR Memory Frequency

Good Luck!
February 7, 2009 4:04:28 AM

belveder said:
changed the timing to 4.4.4.12 & 5.6.6.15 and nothing changed

What were you expecting to change? (None of this will have any noticeable effect on the speed of your computer.)
a b } Memory
February 7, 2009 12:43:27 PM

No reason to try and run your RAM faster than 800mhz (400mhz DDR x2 =800), or change the timings.
Mondoman said it exact, you will not notice any difference. Some benchmarking programs will show a very, very slight increase in RAM speed, but again, it is not enough for you to actually notice.
February 7, 2009 7:06:10 PM

I realise that now, thankyou everyone for your help, it has been interesting for me.
!