Sign in with
Sign up | Sign in
Your question

Need Help. Storage drive IDE->AHCI->IDE

Last response: in Storage
Share
March 13, 2010 2:29:16 PM

After switching my 1tb sata STORAGE drives from IDE mode to AHCI, they now ask to be formatted... the details.....

Long story short. have a few 1tb drives with data on them, no OS.
the drives were originally installed in my previous pc running vista ult x86 sp1 and the BIOS storage config was set to IDE compatibility mode.

Upgraded my setup with a new mobo/cpu/ram etc, as well as SSD/RAID0 which is boot drive running win7 x64. I dunno why, but I thought I was running Ahci on previous system, so I set new motherboard bios to ahci(this was just to be for the storage drives, as the OS is on the ssd's and on sep raid controller card not ich10r)

So upon connecting the storage drives and booting up, the drives show that they are not formatted, rather than showing the hundreds of gb's of data I have. I immediately switched back to IDE in Bios, and rebooted, but no luck.. same issue. It would seem that the ahci setting messed the config of the hd's up. I tried running getdataback ntfs, which found everything, but none of the data will open, all appears corrupted. I am now trying EASEUS partition master home to rebuild partition.

Any other suggestions? PLEASE PLEASE PLEASE?!?!?! :sweat: 
March 14, 2010 3:25:38 PM

anyone? no one has ever had this happen? plugging a SATA HD that was always configured as IDE into an AHCI port and corrupted the drive?
a c 415 G Storage
March 14, 2010 4:30:51 PM

SATA vs. IDE mode has absolutely no effect on the arrangement of data on the drive. Any corruption that occurred must be due to some other issue.

Were these drives configured in a RAID set on the old system or the new system? That would probably explain the issue.

Have you tried plugging the drives back into your old system to see if you can access the files on them?
Related resources
March 14, 2010 5:23:46 PM

First, thanks for your reply!

but no the sata storage drives were originally on system A and configured as IDE in the storage manager in the bios.. and I plugged them into system B which was mistakenly configured for AHCI..
upon the first boot both drives asked to be formatted. I immediately put them back in system A to check and see if they worked there, and they did not.

It seems that system B being configured in bios to AHCI is what corrupted the partitions. In my experience I have had no issues going from AHCI to IDE systems were hd's are concerned... but apparently you can not go from IDE to AHCI, which is what I did here. In addition I have run get data back ntfs, as well as EASEUS Partition Master Home, and while I can see the folders and files on the drive, they all appear to be corrupt as I cannot click on and open them. Pictures for instance just open as a small red X. In the folder view it shows the files but not the thumbnail previews, and on some select files it does show the thumbnails, but they appear to be scrambled and distorted with only a small amount of viewable/recognizable info that I know was there prior.

Im just wondering if there is ANY way to recover this stuff, or a program that will work.

And to answer your question, no there was no raid with these particular drives.
a c 415 G Storage
March 14, 2010 8:51:46 PM

Sorry, I'm not a disk recovery expert. All I can tell you is that there is no reason why switching from IDE to ACHI would cause a problem. Several people have set up their Windows systems as IDE and then switched them to AHCI after the fact.

Now if what you've done is to take a bootable Windows OS disk and moved it from one system to the other, that is a different issue. There are two potential problems: (1) Windows won't have the motherboard drivers for the new motherboard and so it won't be able to do anything, and (2) it won't have the AHCI drivers and so again, it won't be able to do anything.

(2) is a simple fix, but (1) probably requires a reinstall. But you did say these were storage drives, so I'm assuming this isn't the issue.
March 14, 2010 10:15:24 PM

Let me get a bit more detailed for you...regrettably. lol

yeah, they are storage drives.
the funny thing is I had connected them earlier when the bios settings were IDE so I know there were working and not corrupted, and they remained disconnected during the entire build up until the problem occured. The pc they were connected to that I was in the process of building had 4 vertex 60gb ssd's that were about to be configured for raid0 using the mobos ich10r chipset. I had done several win7 installs(nothing to do with the storage drives at this point) to test stripe sizes with the ssd's in raid. after each install you need to sanitary erase the ssd's to clear them(like a format) which requires that they be in IDE mode. So I was constantly entering the bios and switching between IDE and RAID. All of this was to test ssd raid performance on the Intel chipset prior to installing an LSI megaRaid storage card I had been planning on using, and wanting to compare performance gains. I did stripe size test installs on the LSI card too, again between each win7 install I would have to Sanitary Erase the ssd's and switch to IDE mode in the bios to do so. So during the final switch I accidentally selected AHCI and didn't realize it. (I was about to remove the ssd's from the intel sata ports and switch to the lsi card ports, so in theory I didn't even need to change the storage settings from IDE to anything.. But it had been many hours with little sleep)

I didnt notice my mistake right away because at this point I was using the raid card and not the onboard sata ports on the motherboard (which is an Asus P6X58D premium by the way). Once I finally connected the drives(there are four 1TB drives, but at first I only connected 2 of the 4, sure glad now I didn't do all four! :??: ) I noticed that they were asking for a format like they were new. Upon freaking out about that I checked the bios and saw the AHCI setting...smacked myself, and switched back to IDE mode and tried again.. Same "would you like to format" screen. So I disconnected those 2 drives, and tried the other two via IDE mode and no problem.

ALL 4 1TB drives had previously been in the old system and used via IDE mode. And like I said, I had previously checked all four of them on the new system and all four were fine. (before configuring any raid stuff or even the ssd's for that matter) And again only 2 of the four have the corruption, and only the two that were connected via AHCI. SO I am 99.9% positive that somehow the AHCI bios setting caused the corruption. And whether IDE or AHCI the intel storage manager handles both. But obviously its a different driver, which I recall windows 7 automatically installing upon booting up with these two drives plugged up via ahci(AFTER all the testing was done and the 4x60 ssd raid was setup on the LSI card. and they were NOT connected at ANY point in between). So I'm not really trying to figure out how it happened, but more so, how to reverse it.


Current system:
Silverstone FT01-BW Tower
Intel Core i7 920
Asus P6X58D Premium
12GB Corsair XMS DDR3 1600 2GBx6
Corsair HX750W PSU
nVidia Quadro FX1700 GPU
LSI 9260-4i MegaRaid SAS Controller Card w/ iBBU
OCZ Vertex 60GB SSD drive (4)
Seagate 7200.12 1TB HD's (4)
LG WH10LS30 10X BluRay Burner
Koutech Card Reader
Zalman CNPS10X CPU Cooler
Win7 Ultimate x64
Adobe CS4 Creative Suite
a c 415 G Storage
March 14, 2010 10:56:40 PM

All I can suggest is to find one of those data recovery programs (which unfortunately I'm not familiar with) to see if it can suss out what's on your drive.

Unless someone else can chime in with a better idea....?
a b G Storage
March 15, 2010 2:14:01 AM

All I can say is that I agree, changing IDE to AHCI and back would not have caused this problem.
It sounds to me like in the middle of all the RAID configuring and everything else you had going on, you have done something to the wrong drives somewhere along the line. It would not be the first time it happened.
March 15, 2010 6:51:02 PM

Normally I would be inclined to agree with what you said jit... but in this case I know it isnt possible. all four storage drives were set aside the entire time I was working on the raid setups. Even at the start of the build when I tested all four storage drives.... I did a quick win7 install to a 80gb sata drive in IDE mode, THEN tested them as working, Set them aside untouched the entire time, and did not put them back in until after ALL of the configuring was DONE.

So these drives that for the last 5 months were working fine in a previous PC as IDE, did not exhibit ANY issues until they were accessed on this new pc via AHCI.
previous motherboard was an Intel D975X2BXKR(ICH7R) and new one is an Asus P6X58D (ICH10R) so i seriously doubt it was any kind of driver conflict or anything similar there.

And like I said, I have successfully connected drives that were originally formatted in AHCI to systems configured as IDE.. but not drives formatted as IDE to AHCI, which is what happened to here. Nothing else can explain this. Im at a loss.
Meanwhile, again... not even so much concerned with HOW it happened.
Just have to find a solution.

Thanks for all the replies tho guys.. if anyone has any ideas, fire away.
!